-         

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 24

Thema: Motorsteuerung, diesmal hoffentlich ohne EMV-Probleme.

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    12.07.2010
    Beiträge
    31

    Motorsteuerung, diesmal hoffentlich ohne EMV-Probleme.

    Anzeige

    Hallo zusammen,

    nachdem meine letzte Platine für eine Motorsteuerung massive EMV-Probleme hatte, hier stehts, kommt jetzt der neue Versuch. Ich habe versucht die Hinweise vom letzten Mal umzusetzen, als
    - keinen GND-Ring mehr
    - GND-Versorgung des µC dicker, 5V auch
    - Kondensatoren möglichst nah an der H-Brücke
    - PWM-Motorzuleitungen kreuzen keine Datenleiterbahnen
    Freilaufioden habe ich nicht vorgesehen, das Datenblatt der H-Brücke (VNH3SP30) zeigt aber in der Beispielschaltung auch keine.
    Mag da mal jemand drüberschauen?
    Angehängte Dateien Angehängte Dateien

  2. #2
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Die Lage der Entstörkondensatoren am µC ist relativ schlecht. Wenn die Bauform 0805 zu groß ist, gibt es auch noch 0603 - die lässt sich auch noch einigermaßen von Hand löten. Für die Pins 3-6 reicht auch 1 Abblockkondensator - nur der sollte auch dicht am IC sitzen und nicht erst über VIAs gehen. Die Leitungen zu den Kondensatoren sollten direkt zum µC gehen - nicht an den Abblockkondensatoren vorbei.

    Der MOSFET in der Masseleitung erschließt sich mir nicht so ganz. Da sind Probleme vorprogrammiert wenn die Masse nicht verbunden ist, aber die 24 V Versorgung da ist - im ungünstigen Fall zerstört es den µC. Da sollte eigentlich eine Masseverbindung sein. Ohne den MOSFET wird dann auch die Verbindung vom Treiber zu den Elkos besser. Die 24 V Versorgung könnte auch noch ein paar Kondensatoren vertragen, nicht nur die ELKOs, auch eine Transsorb Diode wäre je nach Motor nicht verkehrt, damit die Spannung nicht über etwa 30 V gehen kann, falls der Motor als Generator wirkt.

    Der OP-Amp ist auch nicht gut gewählt - der Typ ist reichlich schnell, das gibt ggf. Probleme. Ein Präzisionstyp ist schon gut, aber so schnell muss er nicht sein. Rail to Rail muss auch nicht sein. Zwischen OP und dem µC sollte besser auch noch ein Widerstand (z.B. 1 K). Der Kondensator vor dem OP ist so auch falsch. So würde die Schaltung wahrscheinlich schwingen. Ein Kondensator von inv. Eingang nach GND ist fast nie eine gute Idee. Entweder müsste man R3 aufteilen und den Kondensator in der Mitte, oder je einen Kondensator parallel zu R7 und R8.

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2013
    Ort
    Region Basel
    Alter
    59
    Beiträge
    2.435
    Hallo,

    Der FET in der Masseleitung ist als Kurzschlusssicherung gedacht.

    Allerdings müsst das Gate auf +24V gelegt werden und nicht an +5V.

    Wenn man jetzt +5V abschaltet und die +24V stehen lässt, zerknallt es den µC !!
    Das passiert jetzt aber auch bei einem Kurzschluss.

    1k begrenzt den Strom dann auf maximal 24mA pro Pin, als total 120mA welche in den µC fliessen!

    Eine Entkopplung wäre mit Dioden, an Stelle der Widerstände (Anode am µC) und Pull Down Widerstände am Treiber möglich.

    MfG Peter(TOO)
    Manchmal frage ich mich, wieso meine Generation Geräte ohne Simulation entwickeln konnte?

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    12.07.2010
    Beiträge
    31
    Hallo,

    ich habe das mal überarbeitet:
    - Abblockkondensatoren am µC angepasst
    - Der MOSFET soll die Schaltung von Überspannung schützen, wenn das System ausgeschaltet ist. Der MOSFET ist jetzt direkt am 24V angeschlossen. GND verbindet immer zuerst, weil es am Stecker an beiden Seiten geführt wird.
    - OP-Sache: Das hatte ich irgendwie ohne zu denken aus der alten Schaltung übernommen... Ich möchte den gemessenen Strom (also die Spannung am Shunt) über einen PT1 an den µC schicken. Haben den Schaltplan jetzt überarbeitet, so dass am Ausgang vom OP ein RC-Glied sitzt. Aber das ist ja auch nicht optimal, oder? Was für einen OP wäre den besser geeignet? Mein OP-Wissen hält sich leider in Grenzen.
    Angehängte Dateien Angehängte Dateien

  5. #5
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Der MOSFET bietet in der Schaltung keinen wirklichen Schutz, sondern verursacht nur mehr Probleme. Mit Drain -Source vertauscht gäbe es noch einen gewissen Verpolungsschutz für den Treiber - ob da die Widerstandswerte zum µC reichen müsste man noch sehen. Ein Chance hat der µC jedenfalls noch.

    Der Kondensator C7 ist da recht weit ab vom Schuss - ob er da viel hilft weiss ich nicht. Redenfalls ist der für C10 im Weg. Als schnelle Lösung einfach die Plätze tauschen.

  6. #6
    Benutzer Stammmitglied
    Registriert seit
    12.07.2010
    Beiträge
    31
    Der MOSFET wird so im Datenblatt des VNH3SP30 so empfohlen. Die Alternative wäre eine Schottky-Diode in der Zuleitung. Aber da gibt's halt mehr Spannungsabfall und eine Diode, die ein paar Ampere verträgt, habe ich jetzt auch nicht gefunden.
    Die Sache mir den C7 / C10 ist klar.

  7. #7
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Das mit dem MOSFET im Datenblatt kenne ich, aber da ist der MOSFET mit Drain/Source getauscht. Auch dann ist das nur eine halbherzige Sache, etwa weil man dann die extra Widerstände zum µC braucht. Ein guter Schutz wäre ein P-MOSFET auf der +24 V Seite - ist größer und teurer, aber auch besser, weil dann GND durchgeht.

    Auch wenn es nicht im Datenblatt ist, wäre ein Platz für einen Kondensator an der Versorgung des Treibers auch nicht schlecht.

    Die LED am Ausgang könnte Probleme bekommen mit der Spannungsfestigkeit in Sperrichtung, falls das keine 2 farbige ist.

    Die Kühlfläche für den Shunt und den MOSFET sollte vielleicht auch noch etwas größer,wenn es irgendwie passt.

  8. #8
    Benutzer Stammmitglied
    Registriert seit
    12.07.2010
    Beiträge
    31
    So, vielen Dank mal soweit.
    Ich habe jetzt einen P-MOSFET eingebaut, ist im Schaltplan rot eingekastelt. Der FET sollte durchschalten, wenn es 5V gibt, oder? Die Schaltung wird so mit 17-20 V betrieben, die V_GS sollte also ~ -9V betragen.

    Die LED ist eine DUO-Led, da gibts keine Probleme.
    Angehängte Dateien Angehängte Dateien

  9. #9
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Der P-MOSFET ist wie der N-MOSFET zuvor noch falsch herum drin: Source gehört zur Schaltung und Drain zum Eingang. Das ist nun mal so, dass als Verpolungschutz die MOSFETs anders herum als normal genutzt werden. Halt so, dass Anfangs die Interne Diode leitet.

    Die Elkos sind besser hinter dem MOSFET - so sind die Elkos auch geschützt und können Pulsströme direkt liefern. Ob die Elkos jetzt direkt parallel zum IC, oder gegen GND liegen sollten, darüber könnte man ggf. noch streiten. Einmal 100 nF oder so am Treiber IC wären aber sicher nicht verkehrt.
    Den Transistor zu den 5 V braucht man nicht - es geht so, aber es sollte auch klein Problem sein wenn die 24 V am Treiber anliegen obwohl die 5 V nicht da sind. Da sollten schon die DIAG Pins dafür sorgen, das dann die Ausgänge hochohmig geschaltet werden.

    Beim OP sollte man besser gleich einen 1-fach OP wählen und besser auch etwas langsamer, etwa ein MCP6051. Einen ungenutzten Kanal des 2 Fach OP müsste man sonst noch einen definierten Eingang geben. Etwa als Impedanzwander mit Eingang an GND, oder hart in die Sättigung Treiben wenn der OP das verträgt.

  10. #10
    Benutzer Stammmitglied
    Registriert seit
    12.07.2010
    Beiträge
    31
    So, habe die Sache nochmal überarbeitet:
    - Die Elkos und ein 100n Kerko hängen jetzt direkt parallel zur H-Brücke.
    - Ich habe den MOSFET durch die Schottky-Diode B560C ersetzt. Wenn man sich nicht nur auf Reichelt beschränkt, findet man ja durchaus was passendes. Irgendwie schein die MOSFET-Lösung ja nicht das allerbeste zu sein...
    - Kann man die Beschaltung des OP noch verbessern? Vor allem die R23/C4 Sache "gefällt" mir als Filter irgendwie nicht so ganz.
    Angehängte Dateien Angehängte Dateien

Seite 1 von 3 123 LetzteLetzte

Ähnliche Themen

  1. Eagle Motorsteuerung ohne Drehrichtungsumkehr
    Von Balu18 im Forum Konstruktion/CAD/Sketchup und Platinenlayout Eagle & Fritzing u.a.
    Antworten: 10
    Letzter Beitrag: 08.03.2013, 21:24
  2. EMV-Probleme durch 3-Phasen Brücke?
    Von ikarus_177 im Forum Elektronik
    Antworten: 12
    Letzter Beitrag: 02.12.2012, 21:03
  3. Schaltnetzteil verursacht starke EMV-Probleme
    Von D35troy3r im Forum Elektronik
    Antworten: 13
    Letzter Beitrag: 25.08.2012, 10:17
  4. Antworten: 10
    Letzter Beitrag: 19.03.2011, 10:32
  5. EMV-Probleme (Überschrift Edit)
    Von Mirror81 im Forum Elektronik
    Antworten: 11
    Letzter Beitrag: 21.05.2007, 00:13

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •