-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: P-FET schaltet langsam

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    20.01.2014
    Beiträge
    8

    P-FET schaltet langsam

    Anzeige

    Hallo,

    ich habe eine Testschaltung in der ich einen P-FET (BSS192) mit 500kHz ansteuere.

    Die Schaltung ist im Anhang angefügt. Im Prinzip die einfachste Schaltung mit einem P-FET und einem Widerstand in Serie.

    Im Datenblatt steht, dass die Einschaltzeit ca. 5-10ns und die Ausschaltzeit ca. 10-20ns beträgt.

    Mit einem 5k Ohm Widerstand in Serie gebe beträgt die Ausschaltzeit ca. 650ns. (Bild ist im Anhang angefügt)
    Mit einem 50 Ohm Widerstand beträgt die Ausschaltzeit ca. 10ns.

    Gemessen wird natürlich zwischen dem Transistor und dem Widerstand.

    Die Einschaltzeit verändert sich nicht wirklich.

    Kann mir jemand sagen woran das liegt? Und was kann man machen, damit der FET schneller schaltet?
    Wenn man einen anderen FET nimmt, worauf muss man dabei achten, um diesen Effekt zu vermeiden?

    LG,

    P
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken P_FET_Schaltung.PNG   Signal_5k_Ohm.jpg   Signal_50_Ohm.jpg  

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2013
    Ort
    Region Basel
    Alter
    59
    Beiträge
    2.435
    Hallo P
    Zitat Zitat von feilibo Beitrag anzeigen
    Die Schaltung ist im Anhang angefügt. Im Prinzip die einfachste Schaltung mit einem P-FET und einem Widerstand in Serie.

    Im Datenblatt steht, dass die Einschaltzeit ca. 5-10ns und die Ausschaltzeit ca. 10-20ns beträgt.

    Mit einem 5k Ohm Widerstand in Serie gebe beträgt die Ausschaltzeit ca. 650ns. (Bild ist im Anhang angefügt)
    Mit einem 50 Ohm Widerstand beträgt die Ausschaltzeit ca. 10ns.
    Zwischen D und S befindet sich eine Kapazität!
    Bei Ausschalten hast du also ein RC-Glied welches geladen werden muss.

    http://www.nxp.com/documents/data_sheet/BSS192.pdf
    Fig 5. auf Seite 4

    MfG Peter(TOO)

  3. #3
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo!

    Zitat Zitat von feilibo Beitrag anzeigen
    Kann mir jemand sagen woran das liegt?
    Das liegt an paralellen zu R25 unsichtbaren Montagekapazitäten.


    Zitat Zitat von feilibo Beitrag anzeigen
    Und was kann man machen, damit der FET schneller schaltet?
    Das was du schon ausprobiert hast: R25 verkleinern.


    Zitat Zitat von feilibo Beitrag anzeigen
    Wenn man einen anderen FET nimmt, worauf muss man dabei achten, um diesen Effekt zu vermeiden?
    Eigentlich ist es unvermeindbar und könnte nur durch möglichst kurze Verbindungen minimiert werden.
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  4. #4
    RN-Premium User Stammmitglied
    Registriert seit
    26.01.2005
    Ort
    Leipheim / Donau
    Beiträge
    53
    Hallo feilibo,

    du kannst das Schaltverhalten verbessern indem du R25 am Drainanschluss anbringst und zusätzlich ist
    im Datenblatt Fig.2 ein 50 Ohm Widerstand parallel zur Signalquelle geschaltet.
    Es ist wie Peter(TOO) schreibt du lädst ein ein RC Glied.

    mfg ihle

    Klicke auf die Grafik für eine größere Ansicht

Name:	BSS192_Page_4.jpeg
Hits:	19
Größe:	70,2 KB
ID:	27273

  5. #5
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Dämpfen der Signalquelle ist hier unnötig bzw. schädlich für den Gatetreiber (V3), siehe bitte die angehängte Oszillogramme.
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    20.01.2014
    Beiträge
    8
    Hallo,

    Danke für eure Antworten. Mit einem kleineren Widerstand ist nicht wirklich optimal, da ich damit einen relativ hohen Strom bekomme und die Schaltzeit doch noch relativ lange dauert.

    Im Prinzip gehts mir darum, dass ich einen DC/DC-Konverter- Controller mit einem P-FET Ausgang habe, der 40V und 5A schalten können soll.
    -------
    Die Angaben für den Converter sind: Eingangsspannung zwischen 12 und 40V, und am Ausgang eine LED (-> Current control) mit 5A (bei einer Flussspannung von ca. 9V). Zusätzlich soll man die LEDs parallel kurzschließen können um sie schnell abzuschalten (das ist die Vorgabe).
    Dafür hab ich einen controller IC gefunden, der auch beim einschalten den Strom in den LEDs rasch wieder auf Nennstrom bringt (gutes Regelverhalten für meine Anwendung).
    Der IC ist der LM3409 von TI. Es wäre natürlich auch möglich den IC zu wechseln, aber ich hab leider keinen IC mit einem guten Regelverhalten für die Anwendung mit einem N-FET gefunden.
    -------
    Nur habe ich bis jetzt einige P-FETs probiert - alle mit einem sehr schlechten Wirkungsgrad bzw. mit Verlustleistung von ca. 5-8W in der Simulation.
    Also habe ich mir gedacht, ich ersetze den P-FET durch einen N-FET (entweder mit einem H-Brücken Treiber, oder in Serie gegen GND), weil die in der Regel weniger Verluste beim Schalten haben. Ich hab dabei an den IPD35N10S3L-26 gedacht - falls das interessiert.

    Das Problem dabei ist, dass der IC einen P-FET Ausgang hat. Also habe ich mir gedacht, ich mach mir mit einem P-FET - NPN - P-FET, einen Pegelwandler und invertiere das Signal, so dass ich damit zum Eingang von einem H-Brückentreiber oder einem N-FET Treiber gehen kann.
    Ich hab auch eine 11,3V Spannungsversorgung intern.
    Wie ich eben feststellen musste, geht sich mit der P-FET - NPN - P-FET kombination bei einer Schaltfrequenz von 500kHz leider kein sauberes Signal mehr aus - auch bei 100kHz nicht.

    Hat jemand eine Idee, wie ich aus dem P-FET Signal ein N-FET signal machen könnte?

    Anbei habe ich die Bilder von meiner Simulation vom Pegelwandler alleine, und von meinem Konverter eingefügt.
    Wie gesagt, ich hab mir überlegt die H-Brücke auch einfach durch einen N-FET in Serie gegen GND zu geben. Macht vll mehr Sinn...

    LG,

    Feilibo
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken Pegelwandler.PNG   Konverter_Teil.jpg   Ganze_schaltung.jpg  

  7. #7
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2013
    Ort
    Region Basel
    Alter
    59
    Beiträge
    2.435
    Hallo Feilibo,
    Zitat Zitat von feilibo Beitrag anzeigen
    Nur habe ich bis jetzt einige P-FETs probiert - alle mit einem sehr schlechten Wirkungsgrad bzw. mit Verlustleistung von ca. 5-8W in der Simulation.
    Deine Simulation ist für die Katz!

    Wie du gesehen hast, spielt die Last eine grosse Rolle auf das Schaltverhalten. Also musst du auch die tatsächliche Last am Ausgang in die Simulation einbeziehen!

    Hinzu kommt noch, dass sich die reale Schaltung nochmals etwas anders verhält als deine Simulation.

    Manchmal frage ich mich, wieso meine Generation Geräte ohne Simulation entwickeln konnte?
    Auch wenn die Simulation gute Werte liefert, kann man alleine durch ein schlechtes Layout dann eine nicht funktionierende Schaltung haben.

    MfG Peter(TOO)

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    20.01.2014
    Beiträge
    8
    Hallo Peter(TOO)

    danke für deine Antwort.

    Als Last hab ich 7 Dioden mit einer Flussspannung von ca. 9V anstatt einer LED mit 9V. Die Dioden können deutlich mehr als 5A.
    Der Widerstand R6 ist keine Last sondern bestimmt zusammen mit C4 die Schaltfrequenz.
    Das sollte also kein Problem sein. Und es war auch kein Problem in der Simulation. Ich hatte 5A und 9V am Ausgang. Das Problem war die hohe Verlustleistung am P-FET, für die ich eine Lösung suche.
    Hast du diesbezüglich einen Tipp?

    LG,

    Philipp

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2013
    Ort
    Region Basel
    Alter
    59
    Beiträge
    2.435
    Hallo Philipp,

    Kannst du als erstes mal ein lesbares Schema einstellen?
    Mit 800x443 Pixel ist da nicht wirklich lesbar.

    MfG Peter(TOO)

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    20.01.2014
    Beiträge
    8
    Hallo Peter,

    Danke Sehr.

    Anbei nochmal die Schaltung. Ich hoffe es ist jetzt besser lesbar. Ansonsten versuch ichs am Nachmittag nochmal mit einer besseren Auflösung.

    LG,

    Philipp
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken Ganze_schaltung_hoehere_Aufloesung.jpg  

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. [ERLEDIGT] PIC 18F4420 schaltet FET, mal nicht
    Von pointhi im Forum PIC Controller
    Antworten: 34
    Letzter Beitrag: 19.12.2013, 22:15
  2. FET 1404 Schaltet nicht richtig durch (TTL)
    Von pointhi im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 28.01.2012, 16:20
  3. IGBT schaltet nur langsam ab
    Von bdanubis im Forum Elektronik
    Antworten: 17
    Letzter Beitrag: 03.06.2009, 14:24
  4. Funktion PNP, P-FET, N-FET
    Von Dani-Bruchflieger im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 15.05.2007, 16:01
  5. [Suche] FET der bei niedriger Spannung schaltet
    Von Fennias im Forum Elektronik
    Antworten: 22
    Letzter Beitrag: 04.02.2007, 10:27

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •