-         

Ergebnis 1 bis 2 von 2

Thema: Problem mit Printbin Anweisung

  1. #1
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.07.2004
    Ort
    Mammendorf
    Alter
    61
    Beiträge
    1.058

    Problem mit Printbin Anweisung

    Anzeige

    Hallo Freunde

    Ich programmiere gerade mit Bascom AVR die von mir benötigten VT100 Befehle um die Ausgabe von der RN-Control oder RN-Motor über die RS232 formatiert auf dem Terminal Tool darzustellen.

    Wenn ich folgenden Kode ausführe, so wird der Bildschirminhalt des Terminal Emulators gelöscht und die Ausgabe erscheint dann so wie ich will:

    printbin 27 ; 91 ; 50 ; 74

    Wenn ich jetzt jedoch ein Array mit 4 Elementen deklariere:

    Dim Vterasescreen(4) As Byte

    Die Werte im Array initialisiere

    Vterasescreen(1) = 27
    Vterasescreen(2) = 91
    Vterasescreen(3) = 50
    Vterasescreen(4) = 74
    Varerasescreen = 4

    und dann die Anweisung:

    Printbin Vterasescreen(1) ; Varerasescreen

    verwende erscheint vor dem eigentlichen Text nur Schrott. Offensichtlich ist das Ergebnis von printbin auf das Element in Array nicht equivalent mit dem printbin des Wertes den ich dem Array-Element zugewiesen habe.

    Folgerichtig müsste meine Array Deklaration mit "as byte" falsch sein. Wie mache ich es richtig? Danke, es ist dringend.
    MfG

    Hellmut

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    02.07.2004
    Ort
    Mammendorf
    Alter
    61
    Beiträge
    1.058
    Hallo Freunde

    Das Problem scheint darin zu liegen, dass die Anweisung

    Printbin Vterasescreen(1) ; Varerasescreen

    Die Daten zu schnell in die serielle schnittstelle schreibt. ich habe 9600 eingestellt. habe obige Anweisung durch eine "For-Schleife ersetzt, da klappts! Trotzdem danke.
    MfG

    Hellmut

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •