-
        

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 26

Thema: 12V DC Motor Konstanten

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    29.08.2012
    Ort
    Dresden
    Beiträge
    13

    12V DC Motor Konstanten

    Anzeige

    Hallo!

    ich versuche seit paar Tagen Konstanten von einem 12V DC Motor (www.pololu.com/catalog/product/1443) experimentell zu ermitteln.

    Am Ausgang meines Motortreibers (www.pololu.com/catalog/product/707) messe ich ca. 6V Spannung. Wenn ich den Motor am Ausgang meines Motortreibers anschieße , messe ich ca. 3V Spannung. Ich finde es sehr seltsam warum die Spannung so abfällt als wäre das kurzgeschloßen.

    Ist die meine gemessene 3V Spannung die Motorankerspannung oder induzierte Motorgegenspannung?

    Grüße!

  2. #2
    Erfahrener Benutzer Lebende Robotik Legende Avatar von PICture
    Registriert seit
    10.10.2005
    Ort
    Freyung bei Passau in Bayern
    Alter
    66
    Beiträge
    10.970
    Hallo!

    Zitat Zitat von bolorkhuu_d Beitrag anzeigen
    Ist die meine gemessene 3V Spannung die Motorankerspannung oder induzierte Motorgegenspannung?
    Beim drehendem Motor ist es die Differenz der beiden Spannungen.
    MfG (Mit feinem Grübeln) Wir unterstützen dich bei deinen Projekten, aber wir entwickeln sie nicht für dich. (radbruch) "Irgendwas" geht "irgendwie" immer...(Rabenauge) Machs - und berichte.(oberallgeier) Man weißt wie, aber nie warum. Gut zu wissen, was man nicht weiß. Zuerst messen, danach fragen. Was heute geht, wurde gestern gebastelt. http://www.youtube.com/watch?v=qOAnVO3y2u8 Danke!

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    29.08.2012
    Ort
    Dresden
    Beiträge
    13
    Vielen Dank für die Antwort.
    Die Spannung am Ausgang meines Motortreibers ist die Ankerspannung Ua richtig?
    Ist der Reibungsmoment beim Leerlauf konstant oder von der Drehgeschwindigkeit abhängig?

    Grüße!

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Welche Spannung hast du denn gemessen? Die über die Anschlussklemmen abfallende Spannung oder die am Motor anliegende Spannung? Denn die Spannung, die an den Anschlussklemmen abfällt, dürfte nur durch zu hohen Stromverbrauch einbrechen, ich finde es ein wenig seltsam, dass die so klein wird. Was du nämlich brauchst, ist die EMK-Spannung, die der Motor erzeugt. Die entspricht dann fast der Spannung, die über dem Motor abfällt, wenn man die ohmschen Spannungsverluste nicht beachtet. Was du dann noch brauchst, ist die sich einstellende Drehzahl in radiant/s. Die Motorkonstante ist dann EMK-Spannung geteilt durch Drehzahl. Die Einheit müsste dann auch dieselbe sein wie Drehmoment durch Strom, kann man sich auch selber nochmal herleiten. Man kann die Motorkonstante auch über Strom und Drehmoment im Stillstand berechnen, allerdings sind die Größen schwieriger zu messen.

    Und die Reibung hat typischerweise ein nichtlineares Verhalten, je nachdem, um was für Reibung es sich handelt. Für den Anfang kann man sie wohl erstmal ignorieren.

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2004
    Ort
    Kreis Starnberg
    Alter
    52
    Beiträge
    1.819
    ... messe ich ca. 3V Spannung. Ich finde es sehr seltsam warum die Spannung so abfällt als wäre das kurzgeschloßen.
    Klingt so, als ob die Versorgungsspannung zusammenbricht, oder der Treiber steuert nicht voll durch. Am besten, Du misst die Versorgungsspannung unter Last auch mal um das einzugrenzen.
    Was du an den Anschlüssen mißt ist die Ankerspannung, die induzierte Gegenspannung kann man nicht direkt messen.
    Das Reibmoment ist bei kleinen Kollektormotoren häufig recht zufällig schwankend, aber eher konstant als proportional zur Drehzahl.

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    29.08.2012
    Ort
    Dresden
    Beiträge
    13
    mein Netzteil liefert mir genug stabile Spannung. Ich messe die Spannung die ich am Motor anlegt habe bzw. am Ausgang meines Motortreibers. Es ergibt Sinn dass ich beim laufenden Motor die differenz Spannung (Ua - k*w)messe.
    Ua = k*w + R*I + L*dI/dt

    ich messe über Hall-Encoder sehr präzise Winkelgeschwindigkeit. Bei konstanten 2 Arbeitsdrehzahl habe ich 2 unterschiedliche Ankerspannung sowie 2 Ströme L*di/dt gegen Null.
    R = (w1* Ua2 - w2* Ua1)/ (w1*I1 + w2*I2) so ist der Ankerwiderstand. Motorkonstante k = Ua1/w1 - R * I1/w1 ; Ich hoffe dass der Reibungsmoment konstant ist.

    Hat jemand Idee wie man Motorinduktivität misst?

    Grüße!

  7. #7
    Super-Moderator Lebende Robotik Legende Avatar von Manf
    Registriert seit
    30.01.2004
    Ort
    München
    Alter
    64
    Beiträge
    12.372
    Der Ankerwiderstand ist doch beispielsweise auch die Ankerspannung geteilt durch den Ankerstrom bei stehendem Motor.
    Die Motorkonstante würde ich zunächst einmal grob mit der Angabe aus der Produktbeschreibung mit 11000 Upm bei 12V bei unbelastetem Motor abschätzen.
    Im nächsten Schritt käme dann für mich die Überlegung wie genau es werden soll.

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    29.08.2012
    Ort
    Dresden
    Beiträge
    13
    ich hätte möglichst genaue Übertragungsfunktion vom Motor und Motortreiber.

    den Motortreiber wollte ich als einen PT1 Glied annähern. Wieder zeigt er seltsames Verhalten. Ohne Verbraucher am Ausgang des Motortreibers messe ich die maximale Spannung 15.4V egal welcher PWM Wert gegeben wird. Wenn ich als Verbraucher 20 kOhm Widerstand am Ausgang des Treibers anklemme messe ich ca. 4V. Wenn ich danach den Motor parallel anschliesse messe ich am Ausgang des Treibers ca. 0.3V bei 8bit PWM=10 (Motor dreht nicht)

    kann jemand mir erklären warum das Ding sowas zeigt.

    Grüße!

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2004
    Ort
    Kreis Starnberg
    Alter
    52
    Beiträge
    1.819
    den Motortreiber wollte ich als einen PT1 Glied annähern
    Ich kenne den betreffenden Motortreiber nicht, aber mir würde es nicht in den Sinn kommen, einem Motortreiber eine Zeitkonstante zu geben. Er hat sicherlich eine, aber die Zeitkonstanten des Motors sollten in aller Regel dominant sein.

    Ohne Verbraucher am Ausgang des Motortreibers messe ich die maximale Spannung 15.4V egal welcher PWM Wert gegeben wird. Wenn ich als Verbraucher 20 kOhm Widerstand am Ausgang des Treibers anklemme messe ich ca. 4V. Wenn ich danach den Motor parallel anschliesse messe ich am Ausgang des Treibers ca. 0.3V bei 8bit PWM=10 (Motor dreht nicht)
    Möglicherweise gibt es bei den Treibern eine Streuung der Leckströme. Oder es wird absichtlich ein kleiner Stromfluß bei abgeschaltetem Motor aufrecht erhalten um eine eventuelle Unterbrechung im Stromkreis zu erkennen. Du kannst dir ja mal das Datenblatt vom Treiber-IC durchlesen, vielleicht gibt es darin einen Hinweis. Damit könnte ich mir die hohe Spannung am unbelasteten Ausgang erklären (20kOhm sind wohl aus Sicht eines Motortreibers immer noch "unbelastet"). Die Praxisrelevanz dieser Erkenntnis für den Betrieb würde ich allerdings als eher gering einschätzen, das braucht man dicht in die Modellbildung aufnehmen. Praxisrelevanter wären Abschlusswiderstände, die im Bereich des ohmschen Widerstands des Motors bis etwa dem zehnfachen des ohmschen Widerstand des Motors liegen, hier zum Beispiel der Stromfluß als Funktion der PWM-Vorgabe.

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    29.08.2012
    Ort
    Dresden
    Beiträge
    13
    Zitat Zitat von ranke Beitrag anzeigen
    Ich kenne den betreffenden Motortreiber nicht, aber mir würde es nicht in den Sinn kommen, einem Motortreiber eine Zeitkonstante zu geben. Er hat sicherlich eine, aber die Zeitkonstanten des Motors sollten in aller Regel dominant sein.
    Da hast du völlig recht.

    am Ausgang des Treibers (VNH3SP30 pololu) habe ich unterschiedliche Widerstände angeschloßen. Unterschiedliche Spannungen messe ich. Heißt das dass der Treiber am Ausgang sehr niederohmig ist. Vom Datenblatt verstehe ich leider wenig.

Seite 1 von 3 123 LetzteLetzte

Ähnliche Themen

  1. Configuration Word Konstanten
    Von Siro im Forum PIC Controller
    Antworten: 10
    Letzter Beitrag: 01.11.2012, 19:50
  2. Suche DC-Motor 12V ca. 1Kw
    Von Powell im Forum Motoren
    Antworten: 7
    Letzter Beitrag: 14.06.2007, 22:49
  3. Hilfe !! Suche 12v Motor
    Von NumberFive im Forum Motoren
    Antworten: 26
    Letzter Beitrag: 27.07.2005, 08:07
  4. Akku für 12V/6A Motor
    Von Spurius im Forum Motoren
    Antworten: 2
    Letzter Beitrag: 13.11.2004, 01:48
  5. 12V Motor
    Von Jumbo im Forum Motoren
    Antworten: 15
    Letzter Beitrag: 01.06.2004, 16:55

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •