-
        

Ergebnis 1 bis 8 von 8

Thema: L293 Zusammenbruch

  1. #1

    L293 Zusammenbruch

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hi Leute,
    ich hab ein Problem mit einer L293 Motorsteuerung und ich komm und komm nicht drauf wo der Fehler liegt.
    Meine Schaltung ist im wesentlichen folgende:
    http://www.rn-wissen.de/index.php/Ge...iber_IC_L293_D

    Zusätzlich habe ich noch Kapazitäten eingebaut wie das direkt drunter für den L293B empfohlen wird und ich nutze einen Arduino Uno zum Steuern. Gepowert wird das ganze von einem 12V AC/DC-Adapter.
    Zwei Probleme sind aufgetreten:
    1. Ich kann die 8bit PWM zwischen 0 und 255 regeln. Bei 0 liegen 0V an, bei 255 liegen 14,5V an. Alles dazwischen sollte sich ja linear verhalten. Tatsächlich konnte ich die vom L293 ausgegebene Spannung nicht unter ca. 7V regeln
    2. Ich betreibe damit einen Lego-Eisenbahnmotor. Nach kurzem bricht allerdings der Strom ein und der Zug bleibt stehen.

    Das erste Problem konnte ich lösen, indem ich die PWM-Frequenz runter gesetzt habe. Der Strom brach allerdings immer noch ein. Also hab ich gemutmaßt, dass der L293 irgendwie anfängt zu schwingen und hab an den Ausgang noch einen 220µF Elko reingesetzt. Jetzt hält der Strom, aber die ausgegebene Spannung ist wieder nicht mehr proportional zu dem was die PWM macht.
    Habt ihr Ideen wie ich das Dilemma lösen könnte?
    Lg

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    07.03.2011
    Beiträge
    1.397
    Zitat Zitat von johannes.mueller88 Beitrag anzeigen
    ... und hab an den Ausgang noch einen 220µF Elko reingesetzt.
    Und wenn du den Motor rückwärts laufen lässt, grillst du den Elektrolyten.

    MfG Klebwax
    Strom fließt auch durch krumme Drähte !

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von BMS
    Registriert seit
    21.06.2006
    Ort
    TT,KA
    Alter
    26
    Beiträge
    1.192
    1. Ich kann die 8bit PWM zwischen 0 und 255 regeln. Bei 0 liegen 0V an, bei 255 liegen 14,5V an. Alles dazwischen sollte sich ja linear verhalten. Tatsächlich konnte ich die vom L293 ausgegebene Spannung nicht unter ca. 7V regeln
    2. Ich betreibe damit einen Lego-Eisenbahnmotor. Nach kurzem bricht allerdings der Strom ein und der Zug bleibt stehen.
    Hallo,
    Zu 1.: Die Spannung am Ausgang ist mit derselben PWM wie am Eingang moduliert. Nicht jedes Messgerät kann den Mittelwert der PWM vernünftig messen.
    Zu 2.: Ich tippe auf Überlast/Überhitzung. Welchen Strom zieht der Motor, wenn du ihn direkt mit der Betriebsspannung versorgst? Der L293B kann max. 1A am Ausgang und wird dabei schon ziemlich heiß. Den solltest du wahrscheinlich kühlen oder/und den zweiten Kanal im Motortreiber parallel schalten.
    Was mich verwirrt: Im Text schreibst du von einem L293B, verlinkt hast du den Schaltplan vom L293D. Die B-Variante braucht zusätzliche Freilaufdioden! Die D-Variante hat diese integriert, schafft aber nur 600mA Ausgangsstrom. Welchen hast du gekauft?
    Grüße,
    Bernhard

  4. #4
    Zitat Zitat von BMS Beitrag anzeigen
    Hallo,
    Zu 1.: Die Spannung am Ausgang ist mit derselben PWM wie am Eingang moduliert. Nicht jedes Messgerät kann den Mittelwert der PWM vernünftig messen.
    Zu 2.: Ich tippe auf Überlast/Überhitzung. Welchen Strom zieht der Motor, wenn du ihn direkt mit der Betriebsspannung versorgst? Der L293B kann max. 1A am Ausgang und wird dabei schon ziemlich heiß. Den solltest du wahrscheinlich kühlen oder/und den zweiten Kanal im Motortreiber parallel schalten.
    Was mich verwirrt: Im Text schreibst du von einem L293B, verlinkt hast du den Schaltplan vom L293D. Die B-Variante braucht zusätzliche Freilaufdioden! Die D-Variante hat diese integriert, schafft aber nur 600mA Ausgangsstrom. Welchen hast du gekauft?
    Grüße,
    Bernhard
    Ich messe das alles mit einem normalen Digital-multimeter. Ich habe die Schaltung zweimal gebaut. Einmal mit einem 293B und Freilaufdioden und einmal mit einem L293D ohne Freilaufdioden. Ich habe bloß auf die Schaltung von 293B verwiesen weil in dem Schaltplan die Stabilisierungs-kondesatoren eingezeichnet sind die ich (in beiden Schaltungen) verbaut habe. Die Probleme sind aber die selben. Die Stromaufnahme des Motors muss ich nochmal nachmessen.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    15.12.2008
    Ort
    Bad Ems
    Alter
    55
    Beiträge
    109
    Hallo,

    zufälliger Weise habe ich hier gerade eine Schaltung mit dem L293D auf dem Breadboard. So wie in dem verlinkten Schaltbild funktioniert das. Die beiden Kondensatoren sind imho nicht notwendig. Freilaufdioden brauchst Du auch nicht, die hat der L293D bereits eingebaut.

    Du kannst aber nicht erwarten, dass Du mit einem Multimeter die PWM korrekt messen kannst. Dann benötigst Du ein Multimeter, dass den sog. Duty-Cycle messen kann. Mein altes WENS 20 TRMS kann das zum Beispiel.

    Wenn Dein Motor die Lust verliert liegt das mit ziemlicher Sicherheit daran, dass er zuviel Strom zieht und wenns dem L293D zu warm wird, schaltet er ab - Stichwort Thermal Shutdown.

    Hoffe, das hilft Dir weiter.

    Gruß,
    Ralf
    http://www.Elektronik-Bastelkeller.de - Elektronik und Mikrocontroller als Hobby

  6. #6
    hm, hab das ganze jetzt nochmal mit dem 293B probiert, der kann ja nen Zacken mehr Strom liefern, die Spannung bricht aber dennoch ein. Ein Legomotor kann doch nicht mehr als 1A strom ziehen? oder doch? Lg

  7. #7
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Bei hoher Belastung könnte der Strom beim Lego motor schon mal Richtung 1 A gehen - ist aber schon eine halbe Ewigkeit her, das ich was damit gemacht habe. Wenn die Spannung einbricht, kann das auch an der Stromquelle, also dem nicht näher benannten AC/DC Wandler liegen.

    Die Kondensatoren an der Versorgung vor dem Motortreiber haben schon ihren Grund. Je nach Spannungsquelle geht es ggf. aber auch ohne. Es gibt dann aber die Gefahr von Funkstörungen und ggf. einem Schaden durch Überspannungsspitzen. Je nach Spannungsquelle sollte der Elko auch noch deutlich größer werden.

    Ein Elko direkt parallel zum Motor ist keine gute Idee. Damit wird eine wirksame PWM Regelung erschwert und die Verluste am Treiber steigen noch. Ein Problem könnte sogar ggf. sein wenn der Motor bereits Kondensatoren drin hat.

    Wie hoch ist denn die PWM Frequenz, und was sind das für Freilaufdioden ? Die einfachen 1N400x sind als Freilaufdioden nur sehr eingeschränkt (niedrige PWM Frequenz, und Probleme bei hohen PWM Werten) geeignet.

  8. #8
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    15.12.2008
    Ort
    Bad Ems
    Alter
    55
    Beiträge
    109
    Ich denke doch... Versuch doch mal folgendes: Schalte ein Amperemeter mit dem Motor in Reihe und versorge ihn über ein Netzteil, also ohne irgendein Treiber-IC. Dann läuft der Motor und Du siehst, wieviel Strom er zieht, wenn er so gut wie keine Belastung hat. Jetzt bremst Du ihn mit der Hand vorsichtig ab, so dass er etwas tun muss. Dabei hältst Du das Amperemeter im Auge. Ich nehme an, das wird ganz schön hochgehen. Guck Dir z.B. mal die Motoren in einem Modellflugzeug an, die sind auch nicht größer als ein Legomotor und benötigen teilweise Regler bis 30A und sogar mehr (na gut, die sind nicht direkt vergleichbar - sollte auch nur ein Beispiel sein, dass auch ein kleiner Motor reichlich Strom ziehen kann...)

    Ich hab' gerade mal ergooglet, dass z.B. ein Legomotor Powerfunctions XL bei 9V 1,8A zieht. Also miss am besten mal nach wie oben beschrieben und pass auf, dass Du Deine Treiber nicht grillst Ach ja, und schreib mal, was bei der Messung rauskommt, würd' mich auch interessieren...

    Gruß,
    Ralf
    http://www.Elektronik-Bastelkeller.de - Elektronik und Mikrocontroller als Hobby

Ähnliche Themen

  1. IC L293 D Frage
    Von Arduino99 im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 06.12.2009, 21:57
  2. Dummer L293 D
    Von g36c im Forum Motoren
    Antworten: 1
    Letzter Beitrag: 29.12.2008, 18:29
  3. L293 D Tester ?
    Von PsychoElvis64 im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 23.07.2006, 18:44
  4. L293 ansteuerrung
    Von core im Forum Motoren
    Antworten: 10
    Letzter Beitrag: 17.07.2006, 16:54
  5. L293 Motorsteuerung
    Von nux im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 18.12.2004, 13:23

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •