-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Fahrregler mit L298 und CD4011

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    23.07.2008
    Beiträge
    96

    Fahrregler mit L298 und CD4011

    Anzeige

    Hallo alle zusammen,
    Ich habe mir folgende Schaltung zusammen gebaut:
    Klicke auf die Grafik für eine größere Ansicht

Name:	IMG_20130719_104111.jpg
Hits:	39
Größe:	50,5 KB
ID:	26045
    und habe Enable auf 5V gelegt und dann ein PWM Signal angeschlossen.

    Benutze ich auch 5V für die Motorspannung funktioniert alles perfekt. Doch ich brauch eigentlich 24 V, schließe ich die an kommt gar nichts an meinem Ausgang an. Irgendwie macht das für mich keinen Sinn.
    Hatte jemand schon mal so ein Problem oder eine Idee was da falsch sein könnte.
    Ich sollte vielleicht noch dazusagen das in dem Schaltplan die Stromversorgung für den CD4011 verdreht ist also Pin7 geht auf Masse und Pin14 auf 5 Volt.

    MFG Micha

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    GND zwischen der 5V und der 24V Stromversorgung ist verbunden?
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    23.07.2008
    Beiträge
    96
    Zitat Zitat von Hubert.G Beitrag anzeigen
    GND zwischen der 5V und der 24V Stromversorgung ist verbunden?
    Ja. GND von der 5 Volt Versorgungsspannung sowie GND von der Motorspannung sind alle verbunden.

  4. #4
    Erfahrener Benutzer Begeisterter Techniker Avatar von schorsch_76
    Registriert seit
    25.03.2012
    Ort
    Kurz vor Neuschwanstein
    Alter
    41
    Beiträge
    398
    Die beiden Massen müssen miteinander verbunden sein.

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Der L298 hat sowohl einen Pin für 5V Logikpegel, als auch einen für die Motorspannung. Bekommt der am Logikversorgungs-Pin immernoch die 5V, wenn du die 24V anschließt? Der braucht dann nämlich zwei verschiedene Versorgungsspannungen, nur mit 24V funktioniert er nicht, würde glaub ich dann sogar kaputt gehen.

  6. #6
    Benutzer Stammmitglied
    Registriert seit
    23.07.2008
    Beiträge
    96
    Zitat Zitat von schorsch_76 Beitrag anzeigen
    Die beiden Massen müssen miteinander verbunden sein.
    Wie ich oben schon geschrieben habe sind beide Massen miteinander verbunden.

    Der L298 hat sowohl einen Pin für 5V Logikpegel, als auch einen für die Motorspannung. Bekommt der am Logikversorgungs-Pin immernoch die 5V, wenn du die 24V anschließt? Der braucht dann nämlich zwei verschiedene Versorgungsspannungen, nur mit 24V funktioniert er nicht, würde glaub ich dann sogar kaputt gehen.


    Ja ich habe den L298 mit Loigkpegle von 5 V beschaltet und einmal an dem anderen Pin die 24 V. Das komische ist ja wenn ich 5V an beide Pins lege wird der Ausgang auch von dem PWM Signal gesteuert, lege ich aber irgendeine andere Spannung an also eine Fremdspannung ( z.B 12V 24 V ) kommt gar nichts am Ausgang an.

  7. #7
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Das ist dann wirklich seltsam. Die Nand-Gatter hängen auch an den 5V? Hast du schonmal die Pins vom L298 durchgemessen?

  8. #8
    Benutzer Stammmitglied
    Registriert seit
    23.07.2008
    Beiträge
    96
    Zitat Zitat von Geistesblitz Beitrag anzeigen
    Das ist dann wirklich seltsam. Die Nand-Gatter hängen auch an den 5V? Hast du schonmal die Pins vom L298 durchgemessen?
    Ja die Nand-Gatter hängen auch an den 5 V.... Wie meinst du durch gemessen Also ich hab am Output gemessen aber sonst noch nicht.....

  9. #9
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    03.09.2009
    Ort
    Berlin (Mariendorf)
    Beiträge
    938
    Zitat Zitat von Asuro91 Beitrag anzeigen
    Das komische ist ja wenn ich 5V an beide Pins lege wird der Ausgang auch von dem PWM Signal gesteuert
    Komisch daran ist für mich, dass es so funktioniert, denn diese Spannungsverhältnisse sind nicht von der Spezifikation des L298 gedeckt. Die Motorspannung muss mindestens 2,5V höher als die High-Spannung an den Logikeingängen sein.
    Eventuell ist das Funktionieren mit 5V & 5V eine Fehl-Fehl-Funktion: eine falsche Ansteuerung, die durch die unzulässige 5V/5V-Konfiguration verdeckt wird.
    Mir ist noch folgendes an dem Schaltungsvorschlag aufgefallen: Wenn die PWM auf die Inputs gelegt wird, kriegt der DC-Motor Wechselspannung. Bei 50:50 bleibt er stehen und verbraucht Strom, ohne wirksam Arbeit zu verrichten. Besser ist es, die PWM an die Enable-Eingänge anzulegen; wenn man dann noch die Inputs einzeln ansteuert, kann man sogar wählen, ob der Motor ohne "Gas" austrudelt oder bremst.
    Geändert von RoboHolIC (20.07.2013 um 00:39 Uhr) Grund: Schreibfehler

  10. #10
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Man kann auch die PWM auf jeweils eine Brückenhälfte geben und auf die andere das Richtungssignal. Muss man nur aufpassen, dass das Tastverhältnis sich bei einer Richtungsumkehr auch umkehrt, aber das kann man relativ leicht im Code berücksichtigen.

    Zum eigentlichen Problem kann ich leider nichts weiter beitragen.

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Schrittmotor ansteuern mit L298 und L297
    Von berserker im Forum Motoren
    Antworten: 406
    Letzter Beitrag: 26.07.2014, 11:51
  2. Problem mit PWM und L298
    Von p_mork im Forum Elektronik
    Antworten: 10
    Letzter Beitrag: 21.02.2009, 12:20
  3. Probleme mit L298, RB35 und PWM
    Von sledge77 im Forum Motoren
    Antworten: 11
    Letzter Beitrag: 01.03.2007, 14:18
  4. Rotary Transformer mit L297 und L298 ?
    Von drylemon im Forum Elektronik
    Antworten: 13
    Letzter Beitrag: 13.03.2006, 08:44
  5. Antworten: 5
    Letzter Beitrag: 29.07.2005, 12:15

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •