-
        

Ergebnis 1 bis 10 von 10

Thema: HiTec HSR-5980SG bringen nicht angegebenes Moment

  1. #1

    HiTec HSR-5980SG bringen nicht angegebenes Moment

    Anzeige

    Guten Tag,

    ich habe ein Problem mit den HiTec-HSR 5980SG.
    Mir stehen mehrere der digitalen Servos zur Verfügung.
    Angegeben sind die Servomotoren mit einem Moment von 3 Nm bei 7,4 V mit einem Maximalen Strom von 5,2 A.

    Bei meinen Versuchen schaffen die HSR5980SG nur 1 Nm bei 2,2 A.

    Als Versuchsaufbau werden die Servos mit einem PWM Signal von einem Arduino Duemilanove angesteuert. Es steht eine Spannungsquelle mit 7,4 V und einem maximalen Strom von 5 A zur Verfügung.

    Weiß jemand wodran es liegt, dass die Servos nur noch 1 Nm schaffen? Die Servos sind zwar schon 3-4 Jahre alt, aber ich kann mir kaum vorstellen, dass das so einen Leistungsverlust erklärt.
    Hatte jemand schonmal ähnliche Probleme mit digitalen Servos

    Vielen Dank für die Antworten
    Grüße
    McSturm

    Ps: Gutes Forum

  2. #2
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    17.09.2004
    Alter
    32
    Beiträge
    647
    Ich tippe mal auf deine Spannungsversorgung. Wie genau sieht die aus? Ist das ein Akku? Wie weit bricht die Spannung ein wenn die Servos auf "Volllast" laufen!?

    Mit wieviel HZ arbeitet dein Servosignal?
    Unser Sommer ist ein grün angestrichener Winter. Das einzige reife Obst, das wir haben, sind gebratene Äpfel. [Heinrich Heine]

  3. #3
    Heyho,

    also die Spannungsquelle ist eine Netzteil. Die Spannung bricht also gar nicht ein.

    Da es sich um Digitale Servos handelt, bekommen sie ein PWM Signal das nur die Soll-Position angibt(Wenn ich alles richtig verstanden habe). Das heißt, das Servosignal ist immer unterschiedlicher Frequenz, je nach gewünschter Position.

    Grüße

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Geistesblitz
    Registriert seit
    16.03.2011
    Ort
    Dresden
    Alter
    30
    Beiträge
    1.937
    Ich glaube nicht, dass sich die Frequenz ändert, wenn man eine andere Position anfahren will, sonst würde es nicht der normalen Servosteuerung entsprechen. Normalerweise hat man eine feste Frequenz, aber die Einschaltzeit verändert sich. Bei analogen Servos wiederholt sich das Signal alle 20ms (50Hz) und für den üblichen Stellbereich ist die Einschaltzeit zwischen 1-2ms. Bei digitalen Servos kann man die Frequenz auf bis zu 333,33Hz (Signal alle 3ms) hochschrauben, 1-2ms Einschaltzeit bleiben gleich. Ist nun nur die Frage, ob dieser Denkfehler zu dem Fehlverhalten führt, eigentlich dürfte das keinen drastischen Einfluss auf das Drehmoment haben. Viel wichtiger sind die Bedingungen, unter denen du das überprüft hast. Wie hast du denn zB. das Drehmoment gemessen?

  5. #5
    Hallo,

    ich habe versuche mit jeweils einer Schrittweite von 1° und einem Delay von 25 µs gefahren, aber auch mit einer direkten Ansteuerung um 45° bewegt. Das hat keinen Unterschied bei der Kraft gebracht.

    Der Testaufbau ist sehr simpel. Ich hebe Gewichte über einen 100 mm Hebelarm.

    Ich habe gerade gesehen 2009 gab es anscheinend schonmal das gleiche Problem: http://www.roboternetz.de/community/...R-5980SG-Servo

    Grüße
    Mcsturm

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    07.03.2011
    Beiträge
    1.401
    Zitat Zitat von mcsturm Beitrag anzeigen
    .... Delay von 25 µs gefahren ....
    Verstehe ich nicht. Ein Servopuls hat zwischen 1000 und 2000 µs, wie passen da die 25 µs rein?

    MfG Klebwax
    Strom fließt auch durch krumme Drähte !

  7. #7
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.557
    Verstehe ich nicht ... Servopuls hat zwischen 1000 und 2000 µs, wie passen da die 25 µs rein ...
    Ich lese schon ne ganze Weile mit und habe auch den Verdacht, dass die Ansteuerung nicht stimmt. Da ich fast nur analoge Servos habe fehlt mir Erfahrung zu den digitalen; trotzdem werde ich mal wieder Hirnschmalz ins Servowiki (hier) schreiben müssen zur Ansteuerung bzw. Programmierung . . . Ich arbeite daran.
    Ciao sagt der JoeamBerg

  8. #8
    Heyho,
    Okay, war mein Fehler. Der Delay liegt nur in meiner Programmierung für die Position und er beträgt 25 ms (Habe mich um 1000 Stellen vertan, kommt mal vor).
    Aber wenn ich die Digitalen Servos richtig verstanden habe, bekommen die Position über ein PWM Signal. Das PWM Signal bekommt der Servo von meinem Arduino. Das heißt diesen selbst eingebauten Delay kann man gepflegt ignorieren. Ich kann nochmal das in der Arduino internen Libary entstehende PWM Signal für die Position überprüfen, aber das dürfte nicht das Problem sein.
    Grüße

  9. #9
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.557
    ... versuche mit ... einem Delay von 25 µs ... ... ... beträgt 25 ms (Habe mich um 1000 Stellen vertan ...
    EIN Trost: es sind nur drei Stellen gewesen, das sind 3%0 - fast zu vernachlässigen *ggg*.

    Schau doch bitte - wenns Dir möglich ist - das Signal am Oskar an!?
    Ciao sagt der JoeamBerg

  10. #10
    Erfahrener Benutzer Roboter Genie Avatar von malthy
    Registriert seit
    19.04.2004
    Ort
    Oldenburg
    Beiträge
    1.379
    Also dass du noch nicht so ganz firm mit der "Theorie" (etwas hochtrabend formuliert) hinter der Ansteuerung von Servos bist, mag schon sein. Aber andererseits: dein Servo scheint ja zuverlässig 1kg an 100 mm Hebel zu tragen, oder habe ich dich da falsch verstanden? Das würde bedeuten, dass der Servo ja grundsätzlich mal tut was er soll (die Position regeln). Dass das Haltemoment in irgendeiner Weise von der PWM abhängen kann, ist mir nicht bekannt (außer in dem Fall, dass es garnicht geht, das ist hier ja nicht so). Ohne jetzt ein großer Servo-Experte zu sein habe ich allgemein den Eindruck, dass die Leute aufgrund der Herstellerangaben diese kleinen Spielzeugservos hoffnungslos überschätzen ...

    Gruß
    Malte

Ähnliche Themen

  1. Probleme mit HSR-5980SG Servo
    Von Kim im Forum Motoren
    Antworten: 0
    Letzter Beitrag: 16.06.2009, 18:53
  2. Hitec Robonova abzugeben
    Von FrankPopp im Forum Sonstige Roboter- und artverwandte Modelle
    Antworten: 1
    Letzter Beitrag: 08.10.2008, 21:29
  3. Antworten: 3
    Letzter Beitrag: 02.11.2007, 03:41
  4. Hitec Hs-311
    Von PabloEscoba im Forum Elektronik
    Antworten: 11
    Letzter Beitrag: 01.02.2007, 18:03
  5. Moment auf Motor
    Von Mad im Forum Mechanik
    Antworten: 1
    Letzter Beitrag: 28.02.2006, 07:33

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •