-         

Ergebnis 1 bis 7 von 7

Thema: Arduino + ULN 2803A + 7 LED's

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    14.04.2012
    Beiträge
    16

    Arduino + ULN 2803A + 7 LED's

    Anzeige

    Hallo an Alle!
    Ich muss zum ausleuchten einer Tablettenbox 7 LED's über einen I/O Pin am Arduino ansteuern. Da ein I/O des Arduino aber nur 40mA hergibt und das zu wenig ist, brauche ich einen Verstärker.
    Dafür hatte noch einen ULN 2803A rumfliegen und wollte das ganze damit lösen. So ist es angeschlossen:

    Klicke auf die Grafik für eine größere Ansicht

Name:	LED + ULN2803A.jpg
Hits:	21
Größe:	25,1 KB
ID:	25575

    Ich hoffe man kann das erkennen. Ich habe auf Pin 9 des ULN "GND", sowie auf Pin 12 die 7 LED's mit jeweils 82 Ohm Vorwiderstand. Jede LED zieht 3,6V und 20mA, deswegen sollten 82 Ohm passen.

    So wie es jetzt aufgebaut ist, funktioniert es nicht ... ich habe auf Pin 7 des ULN den Pin 8 des Arduino gelegt. Pin 8 am Arduino ist als "OUTPUT" deklariert und steht auf "LOW".

    Eigentlich sollte es doch so klappen? Weiß Jemand was ich falsch gemacht habe? Danke im Vorraus.

    LG
    Nuke

  2. #2
    Erfahrener Benutzer Begeisterter Techniker Avatar von Slowly
    Registriert seit
    08.05.2004
    Ort
    24558
    Alter
    49
    Beiträge
    265
    Als erstes würde ich sagen das die LEDs falsch herum angeschlossen sind. Vorwiderstand zu klein aber ich habe gerade keinen Taschenrechner hier

  3. #3
    RN-Premium User Roboter Genie Avatar von 5Volt-Junkie
    Registriert seit
    06.03.2008
    Alter
    30
    Beiträge
    946
    Wie Slowly gesagt hat, sind die LEDs falsch (gucken in die falsche Richtung) angeschlossen wenn man nach Schaltplan geht.
    Ein Widerstand von 82Ohm ist in Ordnung aber welche LEDs sind es denn? Wenn es ein paar von Ultrahellen sind, da reichen oft nur 3mA damit sie nicht blenden.
    Pin 10 vom ULN-Treiber ebenfalls mit 5Volt verbinden.

  4. #4
    Erfahrener Benutzer Begeisterter Techniker Avatar von Slowly
    Registriert seit
    08.05.2004
    Ort
    24558
    Alter
    49
    Beiträge
    265
    Hmm.. Ich habe gerade 180 Ohm als Widerstand ermittelt. Boah lange ist´s her. Pin 10 ist nur bei Induktiven Lasten wichtig. (Freilaufdioden)

    Und ich meine mich zu erinnern, das Du High auf die Eingänge gibst damit die Treiber die Last auf Low ziehen.

  5. #5
    RN-Premium User Roboter Genie Avatar von 5Volt-Junkie
    Registriert seit
    06.03.2008
    Alter
    30
    Beiträge
    946
    Du musst ja nicht die 3,6V als Spannung nehmen, sondern die Differenz, 1,4V.
    Ahja, die Freilaufdioden...

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    14.04.2012
    Beiträge
    16
    Hallo, danke. Mit "HIGH" als Signal funktioniert es. Und 82 Ohm passen, denn:
    R = U/I = 5V-3,6V/0,02A = 1,4V/0,02A = 70 Ohm.

    Danke an Alle!

    LG
    Nuke

    Edit: Ich musste keine 5V am Pin 10 des ULN anlegen. Und es ist schon so gedacht, das die LED's blenden. Bei 3,6V und 82 Ohm kommen sie auf ca. 17mA. Das ist wunderbar für mich
    Geändert von NukeNoob (22.05.2013 um 22:57 Uhr)

  7. #7
    Erfahrener Benutzer Begeisterter Techniker Avatar von Slowly
    Registriert seit
    08.05.2004
    Ort
    24558
    Alter
    49
    Beiträge
    265
    Zitat Zitat von 5Volt-Junkie Beitrag anzeigen
    Du musst ja nicht die 3,6V als Spannung nehmen, sondern die Differenz, 1,4V.
    Oh ja, das ist mir jetzt aber etwas peinlich

Ähnliche Themen

  1. Arduino Uno LED blinkt mit Xbee Pro S1 und Shield
    Von BEADG im Forum Arduino -Plattform
    Antworten: 11
    Letzter Beitrag: 29.03.2013, 10:37
  2. LED Matrix mit Arduino ansteuern?
    Von robots4-ever im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 01.03.2012, 08:56
  3. LED Matrix ULN 2803?!
    Von deko im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 29.06.2011, 13:12
  4. Uln 2803?04?05?
    Von Superfreak im Forum Elektronik
    Antworten: 9
    Letzter Beitrag: 16.12.2008, 14:43
  5. Antworten: 1
    Letzter Beitrag: 26.01.2007, 23:42

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •