-
        

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 40

Thema: Bitte um Hilfe für RaspberryPi per Kabel am Notebook

  1. #1
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.551

    Bitte um Hilfe für RaspberryPi per Kabel am Notebook

    Anzeige

    Das Raspberry Pi mit seinen 2 UARTs als UART-Recorder für die eine oder andere Platine zu nutzen sollte doch gehen. Dachte ich - sozusagen das RPi als Protokollator. Es gibt ja das schöne, ausführliche Tutorial von Kampi zum RPi und Kampi selbst hatte mir zwischendurch auch ein paar Hinweise gegeben - vielen Dank für Beides.

    Also will ich als Linux-Newbie (absoluter Newbie in Linus, aber nicht direkt ein Noob) das RPi ingang setzen, da grad ein bisschen Leerlauf da ist.

    Meine Aufgabenstellung:
    1) RPi ingang setzen
    2) RPi per Kabel am Notebook betreiben,
    ... d.h. RPi ohne Tastatur/Maus/Monitor, mit
    ... SD 8GB, 2013-02-09-wheezy-raspbian.img
    ... am Notebook: WIN7, Ethernet-Kabel, PuTTY
    3) RPi für Allein-Sofortanlauf einrichten
    4) UART-einlesen = Einlesestrings
    5) Einlesestrings fortlaufend in einem File speichern
    6) Zeitstempel für Einlesestrings generieren
    7) Wie 5) aber Strings mit vorgespannten Zeitstempel

    Problem:
    Ich hänge schon bei 2.

    Was bisher geschah.
    - Mein "normaler" Monitor mit DVI-Anschluss (Fujitsu-Siemens SCENICVIEW A19-2A) funktioniert mit HDMI-DVI-Kabel am RPi selten, das nervt.
    - Der TV läuft mit dem normalen HDMI-Kabel am RPi zuverlässig.
    - Punkt 1) funktioniert.
    - Vorbereitungen zu 2) nach Kampis Tutorial "Embedded Linux Einstieg leicht gemacht" bis zu "Ändern von Hostname und IP", in meinem Fall nur statische IP, geht nicht. Ich komme bis zum Ändern von '/etc/network/interfaces", lösche dort die DHCP-Zeile und edidtiere nach der Tutorial-Empfehlung ein:
    "Diese muss wie folgt editiert werden.
    iface eth0 inet static
    --- address 192.168.0.100
    --- network 192.168.0.0
    --- netmask 255.255.255.0
    --- broadcast 192.168.0.255
    --- gateway 192.168.0.1"

    Das geht, wird weggespeichert, beim Neuladen (ohne shutdown von RPi) ist auch alles da wie es das Terminal vorschreibt.

    Jetzt $ sudo shutdown now -r

    und nach der üblichen Anmeldung kommt mit:
    $ ip addr

    brrrrrrrrrrrrrrrr!! mal die letzen paar Zeilen:
    $ ip addr
    1: lo: <LOOPBACK> ntu 16436 qdisc noop state DOWN
    ----link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eth0: <NO_CARRIER,BROADCAST;MULTICAST;UP> mtu 1500 qdisk pfifo_fast state DOWN qlen 1000
    ----link/ether b8:27:eb:f0:6a_4e brd ff:ff:ff:ff:ff:ff
    pi@raspberypi ~ $ _

    War gestern Nacht so, ist heute noch so, obwohl ich DHCP-Zeile entfert hatte und GENAU den Text von Kampi übernommen hatte:
    "
    iface eth0 inet static
    ----address 192.168.0.100
    ----network 192.168.0.0
    ----netmask 255.255.255.0
    ----broadcast 192.168.0.255
    ----gateway 192.168.0.1
    "

    Die von mir eingetragenen Adressen sind also nicht übernommen worden. Dadurch ist es mir auch nicht möglich, mit PuTTY das am Notebook mit Ethernetkabel hängende RPi anzusprechen - ich hab ja keine existierende Adresse fürs PuTTY . . .


    Bitte um Hilfe. Oder notalls auch den Ratschlag: lass es :-/
    Geändert von oberallgeier (04.05.2013 um 16:32 Uhr)
    Ciao sagt der JoeamBerg

  2. #2
    Erfahrener Benutzer Roboter-Spezialist Avatar von -schumi-
    Registriert seit
    30.12.2009
    Ort
    Wasserburg am Inn / Bayern
    Alter
    23
    Beiträge
    449
    Was hast du denn für ein Betriebssystem auf dem Raspberry Pi? Raspbian?

    Bewegst du dich nur in der Konsole, oder hast du eine grafische Oberfläche? Falls ersteres, gib mal "startx" in der Konsole ein und probiere, ob du grafisch weiter kommst.

    Im übrigen musst du nicht neustarten, um neue Netzwerkeinstellungen zu übernehmen. Es müsste auch mit "/etc/init.d/networking restart" funktionieren. (müsste, weil ich grad vor keinem raspbian sitze und mir nicht 100% sicher bin. Aber wenn der Befehl "etwas" macht, ist es der richtige)

  3. #3
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.551
    Zitat Zitat von -schumi- Beitrag anzeigen
    Was ... für ein Betriebssystem ... Raspbian? ... musst du nicht neustarten ...
    Danke - und sorry für die Nachlässigkeit: ich habe das 2013-02-09-wheezy-raspbian.img , das hat der Win32DiskImager auf die SD-Karte geschaufelt. Trage ich gleich oben noch nach. Den Rest probiere ich mal.

    Mit der graphischen Oberfläche komme ich mal ein bißchen weiter: mittlerweile habe ich nach ip addr wenigstens u.a.
    inet 192.168.0.100/24 brd...
    das stimmt also mit meiner Eingabe überein.

    NUR auf
    sudo mv /boot/boot_enable.ssh.rc /boot/boot.rc
    bekomme ich die Antwort
    mv: cannot stat '/boot/boot_enable.ssh.rc /boot/boot.rc' : No such file or directory

    ... und das PuTTY (am LAN-Kabel) findet auch keine Reaktion/Verbindung.

    Trotzdem danke für Deine Mühe. ETWAS bin ich ja weiter!

    Nachtrag: nach dem Verlassen der graphischen Oberfläche gabs wieder keine "Erinnerung" an die Änderungen. Also wieder startx und da steht in networks:

    default 0.0.0.0
    loopback 127.0.0.0
    link-local 169.245.0.0

    :-/

    Nach exit GUI und ip addr kommt wieder so ein ähnlicher (habs nicht verglichen) Text wie anfangs, hier wird das
    inet 192.168.0.100/24 brd ...
    nicht mehr gezeigt.
    Geändert von oberallgeier (04.05.2013 um 17:50 Uhr)
    Ciao sagt der JoeamBerg

  4. #4
    Erfahrener Benutzer Roboter-Spezialist Avatar von -schumi-
    Registriert seit
    30.12.2009
    Ort
    Wasserburg am Inn / Bayern
    Alter
    23
    Beiträge
    449
    Ich hab mal kurz gegoogelt und anscheinend ist das mit dem "mv..." nicht mehr aktuell. Versuche mal "sudo raspi-config", dort sollte es entsprechende Optionen geben um SSH zu (de)aktivieren.

  5. #5
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    18.05.2007
    Ort
    Berlin
    Alter
    46
    Beiträge
    765
    broadcast und network habe ich nicht in meiner config.

    Code:
    auto lo
    
    iface lo inet loopback
    iface eth0 inet static
    address 192.168.2.38
    netmask 255.255.255.0
    gateway 192.168.2.1
    Mit welchem Editor bearbeitest Du die Dateien?

    Ich bin immer als root angemeldet. Bist Du nicht root, dann brauchst Du sudo.

    sudo nano /etc/network/interfaces

    Falls Du eine Fritzbox oder einen Linux NAS hast, dann sollte die SD-Karte auch in einem Kartenleser darüber erreichbar sein. Dann die Datei einfach mit Notepad++ direkt bearbeiten. Als Sprache einfach Shell einstellen, dann passen die Zeilenendezeichen.

    Die Dateien unter /boot sind auf der ersten Partition der SD-Karte und direkt unter Windows zugänglich. Da einfach beide Dateien umbennen.

    Wie man die Grundvorraussetzungen für UART schafft, steht auch in meinem Internetradio Tutorial.
    Wenn das Herz involviert ist, steht die Logik außen vor! \/

  6. #6
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    27
    Beiträge
    3.517
    Blog-Einträge
    9
    Du musst aufpassen.
    Alle Verzeichnisse die vom Verzeichnissbaum UNTER /home/pi sind, kannst du nicht mit dem User Pi betreten/ändern.
    Dafür brauchst du den root/sudo.
    Wenn du die Datei in der Konsole öffnest....speicherst du die dann auch mittels Strg + X und anschließend mit j/y (je nach Layout) bestätigen?
    Weil sonst verwirfst du die Einstellungen wieder
    Schaut ruhig mal auf meiner Homepage vorbei :
    http://kampis-elektroecke.de

    Oder folge mir auf Google+:
    Daniel Kampert

    Es gibt 10 Arten von Menschen. Die einen können Binär, die anderen nicht.

    Gruß
    Daniel

  7. #7
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.551
    Endlich.

    Ein wesentlicher Tipp kam auf der maker faire. Und es läuft. Nicht zuletzt wegen dieses Blogs. So kann ich also bei der Spätnachmittags- /Frühabend- Sonne auf der Terrasse sitzen und mich über das RPi-Logo auf meinem Notebook freuen. Es läuft wirklich die Kommandozeilenvariante und die graphische Oberfläche prächtig und problemlos - aber ich tu ja auch nix - bisher. Inzwischen hängt der RPi am Router irgendwo in der kühlen Wohnung. Leider kommt der RPi-Grafik-Bildschirm als Vollbildformat über den ganzen Bildschirm bei mir an, das Teilbild ist dann auch wirklich nur ein Teil des Ganzen - wenn auch mit Scrollmöglichkeit. Da wäre mir eine geringe Reduzierung des vollen Bilds in einem Teilfenster des Notebooks lieber. Aber - es geht so auch.

    Jetzt könntesolltewird es weiter gehen, da kommt der eher schwierige Teil der Arbeit (für den Linux-Noob-DAU): die serielle(n?) Schnittstelle(n) ingang setzen und den RPi als Protokollator nutzen, der mir Informationen von einer Platine fortlaufend und möglichst schnell in eine Protokolldatei schreibt. D.h. ich muss wohl ein Terminal mit Log-Möglichkeit/-Funktion unter Linux finden. Und wer weiß, vielleicht bekomme ich auch die Geschichte mit der Cam und der einfachen Bildauswertung hin. Man träumt an Sommerabenden eben.

    Könnte mir bitte jemand ein paar Tipps geben? Besonders zum Thema UART (1 oder 2?) mit Schreiben in eine fortlaufende Protokolldatei. Jedenfalls danke für die Hilfe bisher.
    Ciao sagt der JoeamBerg

  8. #8
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    27
    Beiträge
    3.517
    Blog-Einträge
    9
    Hey,

    wie willst du den UART den verwenden (der UART ist als ttyAMA0 unter /dev verfügbar)? In C, Python, Shell etc.?
    Ansonsten kann ich dich nur hier hin verweisen

    http://kampis-elektroecke.de/?page_id=1682

    Alternativ kannst du auch Python und das Modul "serial" verwenden:

    $ apt-get install python-serial

    Hier ist dann ein Python Programm, welches die beim Aufruf übergebenen Parameter per UART sendet:

    http://kampis-elektroecke.de/wp-cont...ART-Python.zip
    Schaut ruhig mal auf meiner Homepage vorbei :
    http://kampis-elektroecke.de

    Oder folge mir auf Google+:
    Daniel Kampert

    Es gibt 10 Arten von Menschen. Die einen können Binär, die anderen nicht.

    Gruß
    Daniel

  9. #9
    Erfahrener Benutzer Robotik Visionär Avatar von oberallgeier
    Registriert seit
    01.09.2007
    Ort
    Oberallgäu
    Beiträge
    7.551
    ... wie willst du den UART den verwenden ...
    Ich bin wieder mal am RasPi dran - an dessen UART.

    Gibt es fürs RaspberryPi (evtl. Linux allgemein??) ein brauchbares Terminalprogramm (bin vom Terminal von bray recht verwöhnt). Damit will ich dann erste Erfahrungen mit dem UART beim Raspi machen mit Senden und Empfangen von UART-Sequenzen von und zu Controllern.
    Ciao sagt der JoeamBerg

  10. #10
    Erfahrener Benutzer Roboter-Spezialist Avatar von -schumi-
    Registriert seit
    30.12.2009
    Ort
    Wasserburg am Inn / Bayern
    Alter
    23
    Beiträge
    449
    Ich benutze gern "minicom", wenn du es mit "minicom -s" aufrufst bekommst du auch ein Konfigmenü

Seite 1 von 4 123 ... LetzteLetzte

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 29.01.2013, 20:33
  2. Antrieb für Drehscheibe - Bitte um Hilfe!!!
    Von trick17 im Forum Motoren
    Antworten: 42
    Letzter Beitrag: 16.06.2006, 21:56
  3. Hilfe mein Notebook streikt !
    Von connycp im Forum PC-, Pocket PC, Tablet PC, Smartphone oder Notebook
    Antworten: 11
    Letzter Beitrag: 14.10.2005, 11:18
  4. Ultraschall störend für Hund und Katze? Bitte hilfe
    Von muraad im Forum Sensoren / Sensorik
    Antworten: 8
    Letzter Beitrag: 07.09.2004, 09:27
  5. Welches Kabel für TWI (I2C) verwenden? Hilfe bei TWI Routine
    Von Sauginius im Forum AVR Hardwarethemen
    Antworten: 23
    Letzter Beitrag: 26.07.2004, 14:33

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •