-         

Ergebnis 1 bis 5 von 5

Thema: Probleme mit RNstepp297

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.04.2013
    Beiträge
    370

    Probleme mit RNstepp297

    Anzeige

    Moin allerseits,

    das Thema Schrittmotoren ist für mich ziemlich neu, ich mache gerade meine ersten Schritte.

    Ich habe mit das RNstepp297 als Fertigmodul gekauft und es zum Testen erstmal nur mit zwei Schaltern und einem Taster und natürlich Stromversorgung bestückt. Die beiden Schalter sind "Enable" und "Drehrichtung", der Taster ist für "Takt", alle sind an den JP1-Pins angschlossen und schalten den jeweiligen Pin bei Betätigung auf Masse. Wenn ich die Schaltung recht verstehe, zieht der Pull-Up-Widerstand die Pins beim öffnen der Schalter wieder auf +5V. Die Buchse MOTCTRL habe ich offen gelassen. Angeschlossen habe ich einen Emis Schrittmotor E7123-0140 12 V/DC, Phasenstrom 1,0 A.

    Im Prinzip funktioniert das ganze, d.h. ich kann mit dem Taster den Motor Schritt für Schritt fahren, die Drehrichtung umschalten und über Enable den Motorstrom an/ausschalten. Leider macht er ab und zu, so alle zehn bis zwanzig Schritte, einen Rückwärtsschritt oder auch mal einen größeren Schritt. Hat jemand eine Idee, woran das liegen kann?
    Was mich auch verwirrt, laut Anleitung sollte der Motor bei GND-Flanke auf "Takt" einen Schritt machen. Tatsächlich macht er den Schritt aber immer erst beim loslassen des Tasters, was ja eigentlich die +5V-Flanke ist, oder missverstehe ich da etwas?
    Noch eine Sache, die im Manual leider nicht klar drinsteht: Wenn ich den Pin für Halbschritt unbelegt lasse, ist die Schaltung dann im Halbschritt- oder Ganzschrittmodus? Und wofür sind die weiteren Pins (Home, Reset, CNTL) ?

    Wenn alles funktioniert, soll die Einheit über eine I/O-Karte vom PC aus mit einem Labview-Programm gesteuert werden.

    Bin für alle Tips dankbar!

    Gruß

    Nils

    - - - Aktualisiert - - -

    @ Admin: Gerade gesehen, vielleicht ist der Thread im Elektronik-Forum besser aufgehoben, wenn ja, bitte verschieben

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    03.09.2009
    Ort
    Berlin (Mariendorf)
    Beiträge
    938
    Taster prellen grundsätzlich beim Schaltvorgang. Handelt es sich um einen Taster mit deutlichem Klick oder Knack sowie mechanischer Hysterese, dann springt bei der Betätigungsbewegung das bewegte Kontaktblech noch mehrere Male von seinem Gegenüber wieder weg und kehrt zurück, sodass real elektrisch gesehen mehrere Pegelwechsel geschehen. Bei mechanisch schleifenden Kontakten holpern die Kontaktpartner aneinander vorbei und können dabei ebenfalls ein Prellen erzeugen.
    Je nach Tasterexemplar und Eingangsbeschaltung (Tiefpassverhalten, RC-Glied) werden diese falschen Prellsignale z.T.unterdrückt, aber eben nicht zuverlässig immer. Was die RN-STEP elektrisch daraus macht, kann der Stepper elektromechanisch unter Umständen nicht umsetzen: drei zu schnelle Schritte rechts werden dann eben zu einem Schritt links.

    Und:
    Eingänge unbeschaltet lassen, wenn es nicht eindeutig so spezifiziert ist, ist immer kritisch. Ein 10kOhm-Widerstand beseitigt diese potentielle Fehlerquelle.

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.04.2013
    Beiträge
    370
    Vielen Dank, das könnte natürlich die Ursache sein. Gibt es denn Taster, die nicht prellen? Es muss ja irgendwie möglich sein, von Hand Steps zu erzeugen.
    Die offenen Anschlüsse sind laut Anleitung zulässig, ich habe es nur der Vollständigkeit halber erwähnt.

    - - - Aktualisiert - - -

    So, ich werde mal versuchen, den Tasteingang mit einem Tiefpaß zu entprellen. Ich werde berichten...

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    03.04.2013
    Beiträge
    370
    Problem gelöst! Es war tatsächlich nur ein Tastenprellen. Ich habe das jetzt so gelöst, daß zwischen Takt-Pin und GND ein 1 mF Elko hängt, der über einen Umschalttaster und einen 100 Ohm Widerstand zwischen High und Low umgeschaltet wird. 100 Ohm und 1 mF ergeben eine Zeitkonstante von 1/10 Sekunde, so schnell kann ich nicht tippen, also völlig ausreichend. Vermutlich würde auch noch viel weniger Kapazität reichen. Ich habe den Umschalttaster außerdem so beschaltet, daß er von Low auf High umschaltet, weil der RNstepp tatsächlich bei der High-Flanke und nicht bei der Low-Flanke einen Schritt macht. So habe ich den Schritt sofort beim Tastendruck, und beim Loslassen passiert nichts.

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    03.09.2009
    Ort
    Berlin (Mariendorf)
    Beiträge
    938
    Zitat Zitat von hbquax Beitrag anzeigen
    Problem gelöst! Es war tatsächlich nur ein Tastenprellen. ... zwischen Takt-Pin und GND ein 1 mF Elko ... 100 Ohm Widerstand ... Zeitkonstante von 1/10 Sekunde
    Perfekt! Das ist die universelle Minimallösung.

    Ansonsten kann man einen UM-Schalter (-Taster) mit zwei 10k-Widerständen und zwei NAND-Gattern zum prellfreien Impulsgeber pimpen. Dabei wird ein FLipFlop geschaltet. Diese Lösung taugt auch für beliebig schnelle mechanische Schaltzyklen, weil hier die Entprellung nicht per Zeitkonstante sondern durch die Speicherwirkung des FlipFlops bewirkt wird.

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 05.02.2011, 11:18
  2. Uhr mit 32768Khz mit der Zeit ungenau - Code Probleme?
    Von MelMan im Forum C - Programmierung (GCC u.a.)
    Antworten: 10
    Letzter Beitrag: 01.03.2010, 11:28
  3. rnstepp297 schrittmotor pwm
    Von hardy78 im Forum C - Programmierung (GCC u.a.)
    Antworten: 0
    Letzter Beitrag: 04.02.2009, 22:14
  4. Probeme mit RNStepp297
    Von tiller im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 26.07.2008, 16:16
  5. Antworten: 17
    Letzter Beitrag: 16.01.2008, 10:37

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •