-         

Ergebnis 1 bis 6 von 6

Thema: Servo funktioniert nicht

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    04.02.2013
    Beiträge
    6

    Servo funktioniert nicht

    Anzeige

    Hallo,

    Ich habe ein Problem mit einem Modelcraft RS-2-Servo. Wir haben ihn neulich in einem Robotik-Kurs (ja, ich bin unerfahrener Anfänger, also verzeihung, falls die folgenden Fragen allzu banal sind) an einen Arduino angeschlossen, dort hat es reibungslos funktioniert. Ich habe die Schaltung zu Hause nachgebaut, aber hier schaltet sich der Arduino ständig ab, anscheinend wird eine Sicherung aktiviert, weil der Servo am 5V-Pin zu viel Strom zieht. Hier meine erste Frage: Kann es sein, dass der Servo deshalb eine so hohe Stromstärke benötigt, weil er irgendwie beschädigt ist? Im Robotikkurs ließ er sich schließlich auch problemlos über einen Arduino steuern. Dann habe ich versucht, ihn an eine externe Stromquelle anzuschließen, unter anderem an 4 AA-Batterien und einen 9V-Block mit dahintergeschaltetem Spannungsteiler. In allen Fällen hat sich der Servo nicht bewegt, bzw. nur gezuckt. Ich hege die starke Vermutung, dass der Servo defekt ist. Könnt Ihr mir das bestätigen? Oder muss ich ihn irgendwie anders anschließen (mehr Batterien, Vorwiderstand, etc.)?

    Bedanke mich schon im Voraus,
    Nachbarino

  2. #2
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    21.02.2013
    Ort
    Graz
    Beiträge
    211
    Hast du im Kurs den selben Arduino benutzt wie zuhause? Mir ist keine solche Abschaltung bei zuviel Strom bekannt, sicher nicht nur ein schlechter Kontakt? Hast du das Programm im Kurs schon raufgespielt oder erst zuhause eingetippt?
    Hast du den Servo bei diesem späteren Test nur an eine Quelle angeschlossen, oder auch an den Mikrocontroller, ohne Steuersignal wird er sich nämlich nicht bewegen. Da das nicht allzu groß sein wird, solltest auch ruhig das Programm posten. Und die Schaltung. Man kann hier sonst wirklich nur ins Blaue raten.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    04.02.2013
    Beiträge
    6
    Sowohl im Kurs, als auch zu Hause habe ich einen Arduino Uno benutzt. Das Programm ist ein Beispielprogramm namens "Knob", das bereits bei der Arduino-Software unter der Library "Servo" enthalten ist:

    // Controlling a servo position using a potentiometer (variable resistor)
    // by Michal Rinott <http://people.interaction-ivrea.it/m.rinott>

    #include <Servo.h>

    Servo myservo; // create servo object to control a servo

    int potpin = 0; // analog pin used to connect the potentiometer
    int val; // variable to read the value from the analog pin

    void setup()
    {
    myservo.attach(9); // attaches the servo on pin 9 to the servo object
    }

    void loop()
    {
    val = analogRead(potpin); // reads the value of the potentiometer (value between 0 and 1023)
    val = map(val, 0, 1023, 0, 179); // scale it to use it with the servo (value between 0 and 180)
    myservo.write(val); // sets the servo position according to the scaled value
    delay(15); // waits for the servo to get there
    }

    Die Schaltung:
    http://fritzing.org/projects/analog-input-to-servo/
    (Wobei ich als analogen Input A0 statt A2 benutzt habe, wie dem Programm zu entnehmen ist)

    Als ich das Ganze mit Batterien ausprobiert habe, habe ich einfach den 5V und GND-Input des Servos an verschiedene Batterien (im ersten Beitrag zwei Beispiele) angeschlossen.

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    21.02.2013
    Ort
    Graz
    Beiträge
    211
    Doch, das Problem der Überlastung tritt offenbar gerne auf. Such mal im Forum nach Problemen mit dem Servotyp, ich hab jetzt einige threads dazu gelesen.
    Ich hab auch ganz vergessen, dass es zwar kaum eine "Sicherung" gibt, aber der Spannungsregler bei Überlastung natürlich einbrechen kann. Seltsam ist, dass die scheinbar selbe Konfiguration im Kurs funktioniert hat?

    edit: bei der Schaltung kann man wirklich nicht viel falsch machen. Hast du ein Multimeter irgendwo rumliegen, mit dem du schauen kannst, wie sich die Spannung verhält, was vom Potentiometer am Analog-Pin ankommt, etc etc ... ?
    Geändert von ichbinsisyphos (16.03.2013 um 18:39 Uhr)

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von BMS
    Registriert seit
    21.06.2006
    Ort
    TT,KA
    Alter
    26
    Beiträge
    1.192
    Als ich das Ganze mit Batterien ausprobiert habe, habe ich einfach den 5V und GND-Input des Servos an verschiedene Batterien (im ersten Beitrag zwei Beispiele) angeschlossen.
    Hallo,
    wenn du eine externe Spannungsversorgung für den Servo verwendest, musst du unbedingt GND vom Board mit dem Minus deines externen Akkus verbinden, da sonst der Bezugspunkt für die Steuerleitung fehlt.
    Grüße, Bernhard

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    04.02.2013
    Beiträge
    6
    Danke für all die raschen Antworten! Endlich funktioniert es! Der Grund war, wie BMS es angesprochen war, die fehlende Verbindung zwischen GND dem Minus der externen Spannungsversorgung. Dass sich der Arduino bei zu hoher Stromstärke abschaltet, ist jetzt wohl auch nicht mehr von Belang, weil ich den Servo nun über die Batterien versorgen kann.

Ähnliche Themen

  1. Programm funktioniert nicht, Servo ansteuerung mit MSP430G2553
    Von alex91 im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 7
    Letzter Beitrag: 10.12.2012, 21:15
  2. Servo Motor BlueBird ansteuern funktioniert nicht
    Von HannoHupmann im Forum Motoren
    Antworten: 17
    Letzter Beitrag: 21.12.2011, 17:30
  3. Servo Ansteuerung funktioniert nicht ( PIC und C)
    Von Pilotzi im Forum PIC Controller
    Antworten: 1
    Letzter Beitrag: 04.11.2009, 20:42
  4. Servo funktioniert nicht.
    Von HAL9999 im Forum Schaltungen und Boards der Projektseite Mikrocontroller-Elektronik.de
    Antworten: 3
    Letzter Beitrag: 23.02.2008, 15:07
  5. Servo funktioniert einfach nicht
    Von Inkoknito im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 10
    Letzter Beitrag: 03.01.2008, 12:19

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •