-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Asuro Flash Probleme unter Ubuntu 12.04LTS mit Usb Transceiver

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27

    Asuro Flash Probleme unter Ubuntu 12.04LTS mit Usb Transceiver

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    aufgrund von schlecht installierten Systemen in unserer Schule habe ich die ganze RoboterAG auf Linux umgekrempelt. Beim Start der Rechner wird von einem USB-Stick Linux (Ubuntu 12.04lts) gebootet. Das Programmieren und Compilieren funktioniert perfekt und ohne Errors.

    Einige Mitglieder haben die neuere Ausgabe vom Asuro und einige die alte, auch ich.

    Das Flashtool habe ich nach der Anleitung (http://wiki.ubuntuusers.de/ASURO) installiert.

    Bei den IR-TRansceivern, die über die Serielle Schnittstelle funktionieren kann ich mit dem Asuroflashtool erfolgreich Flashen.
    Wenn ich nun einen USB-Transceiver anstecke wird dieser erkannt und stellt eine Verbindung mit dem Asuro her, bleibt aber bei Page 0 (1) hängen und gibt nur tttt und cccc aus (ttccttt) daraufhin gibt es eine Fehlermeldung und der Flashvorgang wird abgebrochen. Unter Windows7 +XP funktioniert das Flashen über USB perfekt, bei den alten und neuen Modellen.

    Außerdem lassen sich die neuen Asuro Modelle nur sehr schwer über einen alten IR Transceiver flashen.

    Das heisst Windoof geht und Linux hackt nach. Aber wir sind auf die LinuxSticks angewiesen, da manche keinen Laptop besitzen.

    (Ich habe Win7 auf meinen UbuntuStick in VMWare installiert und das flashen funktioniert. Aber das ist nicht die Lösung für uns da man mit den Lizenzen in konflikt kommt obwohl ich die 90 Tage Testversion berücksichtigt habe )

    Kennt jemand einen Lösungsweg.

    Danke für das durchlesen des langen Textes


    LG

    Matthias

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Einige Gedanken:

    Neuer ASURO vs. alter Transceiver: Möglicherweise ist die eingestellte Frequenz am Transceiver leicht falsch, habt ihr das mal ausprobiert?
    USB-Transceiver: Könntest du mit einem zweiten Transceiver die übertragenen Daten Mal mit protokollieren? Vielleicht ergibt sich daraus eine Auffälligkeit? Habt ihr beide Programmversionen (grafisch und Konsole) ausprobiert? Und was passiert, wenn du die Programme als Administrator (evtl. testweise mit höchster Priorität) ausführst?

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    Hallo Markus,

    die Daten kann ich erst am nächsten Mittwoch protokolieren und werde euch das ergebnis schicken.

    Ja ich habe es sowohl grafisch als auch in der Konsole versucht und immer als Administator.(Bei Linux sudo asuroflash).


    Danke für die guten Gedanken

    Matthias

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    Hallo Markus,

    ich habe ein bisschen mit den Flashtools rumexperimentiert und mir aus der Source für Linux einen Selbst erstellt. Ich habe den Quellcode so modifiziert, dass er USB ansprechen kann. Dies tut er auch.

    Open Serial Port --> OK !
    Bulding RAM --> OK !.
    Connect to ASURO --> ...................OK !
    Sending Page 000 of 026 --> .t.t. flashed !
    Sending Page 001 of 026 --> .t.c.t.t.t. flashed !
    Sending Page 002 of 026 --> .t. flashed !
    Sending Page 003 of 026 --> .t. flashed !
    Sending Page 004 of 026 --> .t. flashed !
    Sending Page 005 of 026 --> .t.t. flashed !
    Sending Page 006 of 026 --> .t. flashed !
    Sending Page 007 of 026 --> .t.t. flashed !
    Sending Page 008 of 026 --> .t.t. flashed !
    Sending Page 009 of 026 --> .t. flashed !
    Sending Page 010 of 026 --> .t.t.t.t.t. flashed !
    Sending Page 011 of 026 --> .t.t. flashed !
    Sending Page 012 of 026 --> .t. flashed !
    Sending Page 013 of 026 --> .t. flashed !
    Sending Page 014 of 026 --> .t. flashed !
    Sending Page 015 of 026 --> .t.t.t. flashed !
    Sending Page 016 of 026 --> .t.t. flashed !
    Sending Page 017 of 026 --> .t.t.t. flashed !
    Sending Page 018 of 026 --> .t.t. flashed !
    Sending Page 019 of 026 --> .t.t. flashed !
    Sending Page 020 of 026 --> .t. flashed !
    Sending Page 021 of 026 --> .t.t.t. flashed !
    Sending Page 022 of 026 --> .t.t. flashed !
    Sending Page 023 of 026 --> .t.t. flashed !
    Sending Page 024 of 026 --> .t. flashed !
    Sending Page 025 of 026 --> .t.t. flashed !
    Sending Page 026 of 026 --> .t.t. flashed !
    All Pages flashed !!
    ASURO ready to start !!.
    Press RETURN to Exit
    Nun gibt es immer die Timeoutfehler und manchmal bricht er auch ab, kann es was mit dem Timing am USB zu tun haben, wenn ja was muss man umstellen.?

    LG matthias

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Das spricht eigentlich eher für Übertragungsprobleme, später kommt die Übertragung ja zustande. Ob da evtl. das Timing kaputt ist, lässt sich nur über einen zusätzlichen Transceiver feststellen, evtl. sogar nur über einen zweiten ASURO der Mal einige Pages mitprotokolliert und dann auf Anfrage zurück überträgt.

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  6. #6
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.781
    Blog-Einträge
    8
    Hallo

    In der Datei AsuroFl.ini kann man die Anzahl der Versuche und die Timeouts einstellen:

    http://www.roboternetz.de/community/...l=1#post307264

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    Das Problem besteht immer noch:


    Es gibt viele t's und viele c's beim flashen. Unter Windoof funktioniert der USB Transceiver perfekt aber unter verschiedenen Linux PC nicht. Der Com Tranceiver funktioniert unter Linux und Windoof wunderbar.

    Was kann ich machen?


    LG

    Matthias
    Geändert von Mattze96 (09.03.2013 um 12:05 Uhr)

  8. #8
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Zitat Zitat von Mattze96 Beitrag anzeigen
    Was kann ich machen?
    Steht in meinen beiden vorherigen Antworten.

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    Es ist kein Timer Problem!!! Sondern ein Software Problem. Die Hardware ist ok, nur das Flashtool hat einen Fehler unter Linux (Ubuntu 12.04lts und mint13).

    Darf ich die funktionierende Datei für andere hier hochladen?

    Trotzdem Danke!

    LG

    Matthias

  10. #10
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.781
    Blog-Einträge
    8
    Hallo

    Schön, dass es nun funktioniert.

    Darf ich die funktionierende Datei für andere hier hochladen?
    Da Arexx viele interne Infos für den asuro und den RP6 veröffentlich hat (bei den aktuellen Produkten sind sie wegen der Mitbewerber etwas zurückhaltender), gehe ich davon aus, dass du uns deine Lösung zeigen darfst. Vorsichtshalber, und auch um Arexx über einen eventuellen Bug zu informieren, solltest du Ihnen eine E-Mail (mit Bezug auf diesen Thread) senden.

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Asuro unter Ubuntu 11.10 flashen
    Von derwisch im Forum Asuro
    Antworten: 12
    Letzter Beitrag: 20.04.2012, 07:18
  2. USB-ISProgrammer unter Ubuntu Linux
    Von goara im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 0
    Letzter Beitrag: 01.04.2008, 11:37
  3. Probleme mit Asuro USB-IR-Transceiver
    Von hr.robotix im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 05.01.2007, 18:19
  4. Probleme mit IR-USB Transceiver
    Von damaltor im Forum Asuro
    Antworten: 6
    Letzter Beitrag: 08.10.2006, 12:45
  5. Antworten: 5
    Letzter Beitrag: 22.04.2005, 15:56

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •