-
        

Ergebnis 1 bis 5 von 5

Thema: RS-2 Servohack

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    11.09.2007
    Beiträge
    211

    RS-2 Servohack

    Anzeige

    Hallo,

    ich versuche gerade das RS-2 Servo (Modelcraft) zu hacken, damit es endlos dreht.
    Habe die Platine ausgebaut und den Poti durch 2 Widerstände mit jeweils 2.4 kOhm ersetzt. Beim Einschalten dreht der Motor auf der Platine sofort los, wenn ich versuche den Servo zu steuern, hat eine Richtung keine Auswirkung. In der Gegenrichtung wird der Servo nur etwas langsamer, bleibt aber nicht stehen

    Was mache ich falsch?

  2. #2
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8
    Da kann man nur raten: Widerstände nicht gleich groß (2,4k und 24k?), kalte Lötstellen, unterbrochene Leiterbahnen, Servoimpuls nicht für Mittelstellung (,weil Drehbereich des Servos nicht linear). Wie reagiert ein nicht gehackter Servo bei der selben Impulslänge?

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    11.09.2007
    Beiträge
    211
    Ich teste es mit einer RC Funkfernbedienung.
    Ein nicht gehackter Servo baugleichen Typs bleibt in der Mittelstellung stehen.

    Habe probehalter den Poti wieder eingelötet, nur die Anschlagsbegrenzung ist also raus - gleiches Verhalten - Servo dreht endlos in eine Richtung.

  4. #4
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.782
    Blog-Einträge
    8
    Oje. Vermutlich ist das Servo defekt. Mit dem orginalen Poti ohne mechanische Verbindung (Poti fliegend) sollte die Drehrichtung bei Links- und Rechtsanschlag des Potis wechseln. Vielleicht doch eine Leiterbahn verbrutzelt.

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  5. #5
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    11.09.2007
    Beiträge
    211
    Jetzt habe ich den Fehler gefunden - hatte unten auf der Platine einen Lotkleks :-o - ist mir gar nicht aufgefallen.
    Platine gereinigt, Widerstände eingelötet - alles tutti.

    Danke euch

Ähnliche Themen

  1. Weglaufen der Mittelstellung bei Servohack
    Von Searcher im Forum Motoren
    Antworten: 37
    Letzter Beitrag: 20.09.2011, 20:52

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •