-         

Ergebnis 1 bis 2 von 2

Thema: Startprobleme mit Asuroflash v1.4.6.56

  1. #1

    Startprobleme mit Asuroflash v1.4.6.56

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    ich habe seit kurzem einen Asuro, bei dem auch die Programmierung einigermaßen mit WinAVR Programmer's Notepad funktioniert.

    Nun wollte ich Asuroflash (Alias Eierlegendewollmilchsau) ausprobieren, aber ich bekomme immer einen Fehler beim kompilieren.

    Zum testen habe ich vorerst nur das Beispiel-Test-Projekt, das bei der Installation mitkommt, verwendet.

    Folgender Fehlercode wird beim kompilieren ausgeworfen:





    Asuro Flash (Alias Eierlegendewollmilchsau) V1.4.6.56 (c) O.O. Müller 2008
    User has admin rights.
    Processor branding Intel(R) Core(TM)2 Duo CPU T6500 @ 2.10GHz, OS WINVISTA
    Hello Matthias on R522, have fun

    >Session Environment Variables:
    AF_AVRDIR=C:\WinAVR-20100110
    AF_PROJECT=Project1
    AF_SOURCE_FILES=
    AF_ASM_SRC_FILES=
    AF_PRGDIR=C:\Program Files (x86)\AsuroFlash
    AF_PRJDIR=C:\ProgramData\AsuroFlash
    AF_ASURO_LIB_PATH=C:\ProgramData\AsuroFlash\asuro-lib\lib
    >Ready.
    >Session Environment Variables:
    AF_AVRDIR=C:\WinAVR-20100110
    AF_PROJECT=AsuroTest
    AF_SOURCE_FILES=test.c asuro.c
    AF_ASM_SRC_FILES=
    AF_PRGDIR=C:\Program Files (x86)\AsuroFlash
    AF_PRJDIR=C:\ProgramData\AsuroFlash\Projects\TestA suroProjekt
    AF_ASURO_LIB_PATH=C:\ProgramData\AsuroFlash\asuro-lib\lib
    File test.c saved.
    File asuro.h saved.
    File asuro.c saved.
    >Default make_all.cmd file created.
    >Default makefile created.
    Make
    C:\ProgramData\AsuroFlash\Projects\TestAsuroProjek t>C:\WinAVR-20100110\utils\bin\make.exe all
    set -e; avr-gcc -MM -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=asuro.lst -IC:\Program Files (x86)\AsuroFlash\include asuro.c \
    | sed 's,\(.*\)\.o[ :]*,\1.o \1.d : ,g' > asuro.d; \
    [ -s asuro.d ] || rm -f asuro.d
    /usr/bin/sh: -c: line 1: syntax error near unexpected token `(x'
    /usr/bin/sh: -c: line 1: `set -e; avr-gcc -MM -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=asuro.lst -IC:\Program Files (x86)\AsuroFlash\include asuro.c \'
    set -e; avr-gcc -MM -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst -IC:\Program Files (x86)\AsuroFlash\include test.c \
    | sed 's,\(.*\)\.o[ :]*,\1.o \1.d : ,g' > test.d; \
    [ -s test.d ] || rm -f test.d
    /usr/bin/sh: -c: line 1: syntax error near unexpected token `(x'
    /usr/bin/sh: -c: line 1: `set -e; avr-gcc -MM -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst -IC:\Program Files (x86)\AsuroFlash\include test.c \'
    -------- begin --------
    avr-gcc --version
    avr-gcc (WinAVR 20100110) 4.3.3
    Copyright (C) 2008 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    avr-gcc -c -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst -IC:\Program Files (x86)\AsuroFlash\include test.c -o test.o
    /usr/bin/sh: -c: line 1: syntax error near unexpected token `(x'
    /usr/bin/sh: -c: line 1: `avr-gcc -c -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst -IC:\Program Files (x86)\AsuroFlash\include test.c -o test.o'
    make: *** [test.o] Error 258

    ExitCode 2
    >Ready.
    Flash file not found!


    Bitte um Hilfe!

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2008
    Ort
    Niederlanden
    Beiträge
    1.167
    Ich vermutte es hat zu tun mit das Leerzeichen in dieser "C:\Program Files (x86)\AsuroFlash" Pfaden. Versuch mal diese in die AsuroFlash Config Dateien zu finden und das ganze Pfad mit "" Zeichen zu um-grenzen.

Ähnliche Themen

  1. Probleme mit AsuroFlash
    Von siemek im Forum Asuro
    Antworten: 2
    Letzter Beitrag: 23.12.2010, 10:11
  2. Startprobleme mit Asuro - help wanted!
    Von Robocop2010 im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 6
    Letzter Beitrag: 31.01.2010, 15:39
  3. Fehler beim Compilieren mit AsuroFlash
    Von ezo2k3 im Forum Asuro
    Antworten: 6
    Letzter Beitrag: 24.11.2008, 14:50
  4. Startprobleme
    Von orph im Forum PIC Controller
    Antworten: 7
    Letzter Beitrag: 08.05.2006, 00:36
  5. Startprobleme mit BASCOM
    Von maximilian25 im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 4
    Letzter Beitrag: 27.02.2005, 17:58

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •