-         

Ergebnis 1 bis 7 von 7

Thema: Diagnose Led's im RS485

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    29.07.2011
    Beiträge
    340

    Diagnose Led's im RS485

    Anzeige

    Hallo zusammen,

    ich habe vor einem MAX485 ein paar LED's nachzuschalten um zu sehen, ob die Verbindung gerade aktiv ist oder nicht. Ich habe sie nach folgender Schaltung angeschlossen.

    Klicke auf die Grafik für eine größere Ansicht

Name:	led.jpg
Hits:	33
Größe:	19,7 KB
ID:	24356

    Jetzt habe ich nur folgendes Problem, die Rote LED fuktioniert. Die Grüne allerdings nicht. Ich habe sie auch schon gewechselt, jedoch ohne Erfolg.

    Ich fürchte ich habe entweder einen Denkfehler in der Schaltung oder meine Widerstände sind falsch?

    Ich hoffe jemand kann mir helfen?

    Gruß

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240
    Die Widerstände könnten etwas groß geraten sein ...
    Vor den Erfolg haben die Götter den Schweiß gesetzt

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    29.07.2011
    Beiträge
    340
    Also ich habe jetzt die Widerstände halbiert und trotzdem leuchtet nur die rote Led!
    Tausche ich die Grüne gegen eine Rote funktionieren beide! Die Grüne habe ich natürlich überprüft und sie funktioniert!
    Ich weiß dass Led's mit unterschiedlichen Farben unterschiedliche Spannungen benötigen, aber muss ich denn noch weiter runter mit meinen Widerständen?

  4. #4
    Erfahrener Benutzer Robotik Einstein Avatar von Vitis
    Registriert seit
    06.01.2005
    Ort
    Südpfalz
    Alter
    43
    Beiträge
    2.240
    Terminierung??

    Vor den Erfolg haben die Götter den Schweiß gesetzt

  5. #5
    Erfahrener Benutzer Roboter-Spezialist Avatar von sast
    Registriert seit
    30.11.2004
    Alter
    47
    Beiträge
    497
    Wenn ich mich recht erinnere hab ich mal gelesen, dass eine belastete RS485 in der Spannungsdifferenz bei 1,5 bis 3V liegt. Habs aber selbst noch nie gemessen. Ist nicht gerade viel, wenn das stimmt. Rote Leds liegen bei 1,7-2,1V und grüne fangen bei ca 2V an und gehen bis ca 3,4V. Eventuell sind deine roten Leds dann auch noch 2mA Typen und die grünen wollen 15mA oder mehr. Das kannst nur du wissen. Wenn zwei rote gehen, dann liegts an den unterschiedlichen Parametern der Leds.
    Wieviel treiben den die Ausgänge des 485 Bausteines?

    sast

    雅思特史特芬
    开发及研究

  6. #6
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    29.07.2011
    Beiträge
    340
    Hallo zusammen,

    also ich habe jetzt nochmal das Datenblatt beider LED's studiert. Die Spannungen der beiden LED's liegen bei 2V und der Strom bei 2mA, laut meiner Rechnung müsste dann sogar ein Widerstand von 1,5K Ohm rein. Also wieso gehen nun nur die Roten? Typ grün: HLMP-1790, Typ rot: HLMP-1700.

    Die Terminierung des Busses, inklusive Pullup und Pulldown der Kanäle A und B findet im Stecker statt. Es sind evtl. noch Suppressordioden vorgesehen.

    Gruß

  7. #7
    Erfahrener Benutzer Roboter-Spezialist Avatar von sast
    Registriert seit
    30.11.2004
    Alter
    47
    Beiträge
    497
    Also in dem Datenblatt, welches ich gefunden habe steht, dass die 1700 bei 1,7-2,0V Flussspannung liegen und die 1790 bei 1,9-2,2V. 1k5 als Vorwiderstand wäre in etwa korrekt, wenn man von einer 5V Spannungsquelle ausgeht bei 2V Flussspannung. Wie vorher geschrieben, kannst du aber nicht von 5V ausgehen.
    Ich würde mir eine grüne und eine rote Led mit Vorwiderstand zurechtlegen und mit einem Labornetzteil testen, wann welche angeht. Dann mal den RS485 Bus belastet und unbelastet messen, wie groß die Differenzspannung ist. Dazu bietet sich eventuell ein Oszi an, da man da die highs und lows besser betrachten kann. Danach weißt du sicher, wo das Problem liegt.

    Eventuell ist es eine Kombination aus deinem zu hohen Vorwiderstand und der unterschiedlichen Ansprechzeit. Diese liegt bei den grünen bei 5xrot.

    sast

    雅思特史特芬
    开发及研究

Ähnliche Themen

  1. Schrittmotor-Treiber-IC mit umfangreichen Programmiermöglichkeiten und Diagnose-Funkt
    Von Roboternetz-News im Forum Neuigkeiten / Technik-News / Nachrichten / Aktuelles
    Antworten: 0
    Letzter Beitrag: 24.05.2012, 12:30
  2. RS485 Datenübertragung
    Von elkokiller im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 5
    Letzter Beitrag: 10.12.2006, 23:54
  3. Teilnehmerbegrenzung RS485
    Von bertl100 im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 24.03.2006, 20:26
  4. LED und IR-LED parallel. LED brennt nicht
    Von Goblin im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 12.07.2004, 21:57
  5. RS485
    Von AlexAtRobo im Forum AVR Hardwarethemen
    Antworten: 15
    Letzter Beitrag: 08.07.2004, 19:18

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •