-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Raspberry Composite Video Ausgang

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    30.05.2006
    Ort
    Hamburg
    Beiträge
    165

    Raspberry Composite Video Ausgang

    Anzeige

    Hallo

    ich habe ein Problem mit meinem Raspberry und zwar bekomme ich kein Bild über den Composite (PAL) Video-Ausgang. Über HDMI bekomme ich ein Bild und ansonsten hat der Raspberry auch noch keine Probleme gemacht. Es ist Raspian Wheezy als Betriebsystem installiert (2012-12-16-wheezy-raspbian). Der Raspberry ist die etwas stärkere Variante. Um auf PAL umzustellen habe ich auf der SD-Karte in der config.txt einfach das #-Zeichen vor sdtv_mode=2 entfernt. Er gibt aber wie gesagt nur über HDMI ein Bild aus. Die komplette config.txt ist also bei mir:

    Code:
    # uncomment if you get no picture on HDMI for a default "safe" mode#hdmi_safe=1
    
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    
    # uncomment for composite PAL
    sdtv_mode=2
    
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    
    # for more options see http://elinux.org/RPi_config.txt
    Ich habe es an verschiedenen Fernsehern getestet. Hat jemand eine Idee, was ich noch ausprobieren könnte? Man kann ja die config.txt auch über Befehle direkt am Raspberry ändern, vielleicht wäre das ja noch ein Versuch wert. Leider habe ich die entsprechenden Befehle nicht im Internet gefunden. Ich bin absoluter Linux Neuling deswegen bitte ein bisschen ausführlicher beschreiben was zu tun ist.

    Über Antworten würde ich mich freuen

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    30.12.2008
    Beiträge
    1.418
    was gibt es noch zu sagen

  3. #3
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    28
    Beiträge
    3.517
    Blog-Einträge
    9
    Hey,

    hast du HDMI UND den Composite Video angeschlossen?
    Sobald der HDMI angeschlossen ist wird das Bild nur über HDMI ausgegeben.
    Wie du an den beiden Posts über meinem siehst funktioniert es problemlos
    Schaut ruhig mal auf meiner Homepage vorbei :
    http://kampis-elektroecke.de

    Oder folge mir auf Google+:
    Daniel Kampert

    Es gibt 10 Arten von Menschen. Die einen können Binär, die anderen nicht.

    Gruß
    Daniel

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    30.05.2006
    Ort
    Hamburg
    Beiträge
    165
    Danke für die Antworten. Ein Problem am Fernseher kann ich ausschließen, da ich mehrere ausprobiert habe und beide das Composite Signal eines DVD-Spielers anzeigen können. Ein defektes Kabel kann ich auch ausschließen. Ich probiere morgen mal mit einem Multimeter zu messen ob sich an der Cinchbuchse vom Rasp irgendwas tut (ich weiß aber nicht ob ich da mit einem Multimeter wirklich weit komme). Es gibt für HDMI ja so einen "abgesicherten Modus" sowas gibt es für PAL nicht oder? Das HDMI Kabel hatte ich abgezogen um die PAL Verbindung herzustellen.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.09.2010
    Beiträge
    110
    Schau Dir mal die Zeilen an:
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    Da muss der Kommentar weg, sonst kein Bild ohne HDMI.

    Dateien editieren unter Linux, dafür gibts aber wirklich genug Anleitungen

    Falls du mit Norton Commander etc. was anfangen kannst, installer dir den Midnight Commander:
    sudo apt-get mc

    Dann hast du mit
    sudo mcedit <Dateiname>
    einen Editor wie zu fortschrittlichen DOS Zeiten.

    Mit vi und nano solltest du dich aber trotzdem vertraut machen. Mit den wichtigsten Linux Befehlen ebenfalls.

  6. #6
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    28
    Beiträge
    3.517
    Blog-Einträge
    9
    Also ich habe die Zeile nicht wegkommentiert und bekomme an meinem Bildschirm ein Bild.
    Schaut ruhig mal auf meiner Homepage vorbei :
    http://kampis-elektroecke.de

    Oder folge mir auf Google+:
    Daniel Kampert

    Es gibt 10 Arten von Menschen. Die einen können Binär, die anderen nicht.

    Gruß
    Daniel

  7. #7
    Moderator Robotik Einstein Avatar von HannoHupmann
    Registriert seit
    19.11.2005
    Ort
    München
    Alter
    35
    Beiträge
    4.528
    Blog-Einträge
    1
    Es gibt übrigens ein eigenes Raspberry Pi Unterforum im Forum also am besten dort diskutieren damit auch andere User die Lösung finden.

  8. #8
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    28
    Beiträge
    3.517
    Blog-Einträge
    9
    Huch gar nicht gesehen das es nicht in dem Forum ist.
    Kann das bitte ein dementsprechender Admin verschieben?
    Schaut ruhig mal auf meiner Homepage vorbei :
    http://kampis-elektroecke.de

    Oder folge mir auf Google+:
    Daniel Kampert

    Es gibt 10 Arten von Menschen. Die einen können Binär, die anderen nicht.

    Gruß
    Daniel

  9. #9
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    02.09.2010
    Beiträge
    110
    Zitat Zitat von Kampi Beitrag anzeigen
    Also ich habe die Zeile nicht wegkommentiert und bekomme an meinem Bildschirm ein Bild.
    Interessant

    Hab hier einen Rev.B, Raspian, aktuelle Firmware der XBMC bekommen soll.

    Hatte das HDMI Display abgesteckt und den Raspberry in eine Ecke gelegt um via SSH drauf zu arbeiten. Ohne Display hat der Raspi allerdings erst gar nicht gebootet. Das ging erst nachdem ich den Kommentar entfernt hatte.

    Einen Versuch ist es auf jeden Fall wert, geht ja auch mit einem Einzeiler:
    sudo sed -i 's/#hdmi_force_hotplug=1/hdmi_force_hotplug=1/g' /boot/config.txt

  10. #10
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    30.05.2006
    Ort
    Hamburg
    Beiträge
    165
    Sorry für das falsche Unterforum. Den Befehl hatte ich ganz übersehen in der config.txt, allerdings wird dieser in Anleitungen (gibt es ja reichlich im Netz) auch nie erwähnt. Jedenfalls danke für den Tip. Leider hat sich nichts geändert. Vielleicht ist meiner ja wirklich defekt, aber wie wahrscheinlich ist es, dass er über HDMI tadellos funktioniert und lediglich die composite Verbindung nicht funktioniert? Raspbian habe ich schon neu installiert und es auch schonmal mit dem Arch-Linux versucht - allerdings ohne Erfolg.

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Composite - Video per atmega übertragen
    Von Thegon im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 13
    Letzter Beitrag: 26.01.2011, 20:00
  2. AVR Ausgang gegengleich zu PWM Ausgang schalten
    Von Thegon im Forum Microcontroller allgemeine Fragen/Andere Microcontroller
    Antworten: 25
    Letzter Beitrag: 24.01.2011, 19:50
  3. PC TFT mit Composite ansteuern
    Von Felix H. im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 29.03.2008, 19:47
  4. Composite Video Signal auslesen?
    Von Hyla im Forum Sensoren / Sensorik
    Antworten: 4
    Letzter Beitrag: 30.06.2007, 14:04
  5. Composite Videosignal
    Von God im Forum Sensoren / Sensorik
    Antworten: 20
    Letzter Beitrag: 31.05.2004, 15:13

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •