-         

Ergebnis 1 bis 5 von 5

Thema: Probleme bei DC Motorsteuerung

  1. #1

    Probleme bei DC Motorsteuerung

    Anzeige

    Liebe Forenmitglieder,
    Ich bastle momentan an einer kleinen Motorsteuerung für 6 6V DC Motoren. Die Motoren sollen mit 3 L293B Motortreiber getrieben und über einen AVR ATMega32 gesteuert werden. Prinzipiell erzeugt der AVR ein PWM Signal mit dem Timer2 und legt das Enable Signal für den zu steuernden Motor über einen Mutiplexer an. Um nur ein PWM Signal für Vor und Rücklauf zu erzeugen wollte ich das PWM Signal an die Collectoren von zwei Transistoren führen. Sinn der Sache war es über zwei IO pins, die mit 10k Widerstand an jeweils einer Basis eines Transistor führen, zu bestimmen ob nun das PWM Signal auf die Leitung von Vor oder Rücklauf geht. Alle Inputs der L293B für Vorlauf hängen an einer Leitung genau so die Inputs für Rückläufe. Das Problem ist das das ganze nur nicht so ganz funktioniert wie ich es mir vorgestellt habe. Das PWM Signal besitzt bei Betrieb nur eine Amplitude von 1V und somit bewegt sich der angesteuerte Motor keinen millimeter. Ich habe ein kleinse Schaltbild mit exemplarischer Beschaltung für 2 Motoren beigefügt. Die Grundbeschaltung des AVRS hab ich mal weggelassen
    Klicke auf die Grafik für eine größere Ansicht

Name:	Motorstrg.jpg
Hits:	12
Größe:	38,5 KB
ID:	24324

  2. #2
    Erfahrener Benutzer Begeisterter Techniker Avatar von Chypsylon
    Registriert seit
    02.02.2011
    Ort
    Graz/Österreich
    Beiträge
    256
    Unabhängig von deinem Problem sollten an die Ausgänge noch Dioden wie z.B. hier.

  3. #3
    Klar die Rücklaufdioden. Hab sie mal weggelassen kommen aber noch ran. Keine Sorge hab sie nicht vergessen

  4. #4
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.183
    Entweder auf pnp-Transistoren umsteigen oder die Basiswiderstände weglassen und PullDown Widerstände am Emitter mit 10k einsetzen.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  5. #5
    Ich habe die Basiswiderstände weggelassen und 10k pulldowns hinzugebaut und mal mit einem L293B getestet. Das PWM Signal der Leitung bei der der Transistor nicht durchschällt wird irgendwie vom L293B auf ungefähr 4.5 Volt gezogen. Wenn ich alle L293B Bausteine ausbau und die Signale anschau ist auf der einen Leitung das PWM Signal zu sehen und auf der anderen eine klare 0. Mit L293B sehe ich das PWM Signal und auf der anderen Leitung 4.5 V. Woher kommt das?

    - - - Aktualisiert - - -

    Ich hab mir mal den Beitrag zu Getriebemotoren im Wiki durchgelesen und halt die Methode wie sie dort vorgestellt wird für sinnvoller. Könnte sich jemand den Schaltplan anschaun.Klicke auf die Grafik für eine größere Ansicht

Name:	MotorStrg2.jpg
Hits:	5
Größe:	33,8 KB
ID:	24335

Ähnliche Themen

  1. PWM Motorsteuerung probleme
    Von homedom im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 07.01.2008, 14:22
  2. Antworten: 0
    Letzter Beitrag: 19.11.2007, 19:23
  3. Motorsteuerung bei Entenklappe
    Von Enten Züchte im Forum Elektronik
    Antworten: 17
    Letzter Beitrag: 06.11.2007, 17:42
  4. Anfänger braucht Hilfe bei Motorsteuerung
    Von Jokill im Forum Motoren
    Antworten: 4
    Letzter Beitrag: 30.09.2007, 19:38
  5. Brauche Hilfe bei Schaltung zur Motorsteuerung
    Von PhilippW im Forum Elektronik
    Antworten: 35
    Letzter Beitrag: 29.03.2006, 01:03

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •