-         

Ergebnis 1 bis 3 von 3

Thema: Brauche Hilfe bei Vorwiderstände für XOR Gate

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    01.10.2012
    Beiträge
    44

    Brauche Hilfe bei Vorwiderstände für XOR Gate

    Anzeige

    Guten Abend Roboterfans,

    ich scheitere daran, die Vorwiderstände meines XOR Gates zu berechnen. Folgender schaltplan:
    Das ziel ist es, dass bei R11 ein Strom von 1mA Durchfließt.

    Ebenfalls wundert es mich, dass an der Basis Emitterstrom von Q7 0mA beträgt, der Collektor Emitterstrom beträgt allerdings 0,4mA.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken XOR.jpg   Untitled.jpg  

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von BMS
    Registriert seit
    21.06.2006
    Ort
    TT,KA
    Alter
    26
    Beiträge
    1.192
    Hallo,
    also auf den ersten Blick sieht das ziemlich kompliziert aus. Auf den zweiten Blick hab ich erst mal die grobe Struktur erkannt 2 Inverter, 2 NANDs, 2 Emitterfolger.

    Da R12 und R13 (Kollektorwiderstände) ungefähr so groß sind wie R10 und R??, hast du nur noch ungefähr die halbe Spannung - also 2,5V - an der Basis der letzten Transistoren gegenüber Masse. Da diese in Kollektorschaltung sind, liegen am Emitter 0,6V weniger an - also nur noch ca. 1,9V. Über der CE-Strecke müssten dann 5V-1,9V=3,1V abfallen. Der Strom durch R11 wäre nur noch 1,9V/5kOhm=0,38mA. Gerundet sind das deine 0,4mA. TADAA!
    0mA Basisstrom bei Q7 kann eigentlich nicht sein, behaupte ich.

    Fazit: Die Kollektorschaltung der letzten Transistoren sind das Problem.
    Lösungsvorschlag: pnp-Transistoren in Emitterschaltung nehmen, Signal von den NANDs an R12/R13 über Basisvorwiderstände abgreifen.

    Grüße, Bernhard
    Geändert von BMS (20.12.2012 um 22:29 Uhr)

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    01.10.2012
    Beiträge
    44
    Genauer gesagt sind das doch keine NANDS , die Transistoren Q3,Q4 und Q5,Q6 bilden ein AND gate, strom soll an Output wenn beide Transistoren 1 sind oder lieg ich da falsch.
    Ich muss alles mit npn Transistoren bauen.
    Ein Xor besteht aus 2Not, 2AND und einem OR Gate.
    Und das Problem ist, warum die 0,4AmA Fließen. Durch nachprüfen habe ich gesehen, dass an der Basis von Q7 eine spannung von ca 3V anliegt gedoch an Q8 keine Spannung anliegt obwohl beide schaltungen gleich aufgebaut sind.

Ähnliche Themen

  1. Drehscheibe für Lego Bahnhof bauen -> brauche Hilfe bei den Bauteilen
    Von tio im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 20
    Letzter Beitrag: 09.01.2012, 12:45
  2. Brauche Hilfe bei Tastatureingabe
    Von Phill93 im Forum Robby RP6
    Antworten: 11
    Letzter Beitrag: 13.06.2010, 18:09
  3. Antworten: 4
    Letzter Beitrag: 17.06.2009, 18:55
  4. Brauche hilfe bei odometrie.
    Von Sim Robot im Forum Asuro
    Antworten: 6
    Letzter Beitrag: 23.12.2008, 18:41
  5. brauche hilfe bei bauteilsuche für modelleisenbahnsteuerung
    Von fw-thomas im Forum AVR Hardwarethemen
    Antworten: 109
    Letzter Beitrag: 03.09.2008, 08:57

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •