-         

Ergebnis 1 bis 7 von 7

Thema: Bascom-USBISP zerstört durch ATmega1284P ?

  1. #1

    Bascom-USBISP zerstört durch ATmega1284P ?

    Anzeige

    Hallo,

    ich habe eine Robotersteuerung mit einem RNControl Board und dem ATmega32 in Betrieb. Da ich nun
    mehr SRAM brauchte habe ich im System den 32er durch einen ATmega 1284P ersetzt. Alle Servo- und
    Motorsteuerungen, LCD und Sensoren blieben dabei angeschlossen, da ich davon ausging, dass der
    1284P voll pinkompatibel ist. Der 1284P kam fabrikneu daher.
    Bei Inbetriebnahme des Steuerung pfeift ein Schrittmotor etwas und das LCD ist ohne Anzeige - ok, ist
    ja noch nicht programmiert dachte ich mir.
    bascom-USBISP angestöpselt und ein Auslesen der Fuses versucht. Ab diesem Moment meldet Bascom
    immer "USB programme not found". Auch wenn ich eine andere Steuerung mit dem 32er anschliesse findet
    er den Programmer nicht mehr. Er scheint defekt zu sein.
    Meine Frage als wenig erfahrener: kann ich den Programmer hierbei zerschossen haben, weil ich irgendetwas
    nicht beachtet habe oder ist dies einfach nur ein blöder Zufall?
    Kann ich einen ATmega ab Werk einfach so mit dem Programmer im RNControl Board programmieren oder
    ist das ein Irrglaube von mir? Ich dachte Fuses setzen und Programm aufspielen und fertig. Aber ich
    konnte ja nichteinmal die Fuses auslesen. Hätte ich evtl. alle Sensoren und Aktoren erstmal
    abstöpseln sollen, so dass er nur auf dem nackten RNControl Board steckt?
    Ich habe jetzt Bedenken, mir den soeben bestellten Programmer gleich wieder zu zerschiessen
    Bin für Tips dankbar.

    Grüße
    Christian

  2. #2
    Erfahrener Benutzer Robotik Visionär Avatar von Hubert.G
    Registriert seit
    14.10.2006
    Ort
    Pasching OÖ
    Beiträge
    6.186
    Es ist eher unwahrscheinlich das der Programmer dadurch zerstört wurde. PortB sollte frei sein.
    Funktioniert der Mega32 noch im RNcontrol.
    Grüsse Hubert
    ____________

    Meine Projekte findet ihr auf schorsch.at

  3. #3
    Ich habe den uC wieder umgesteckt und mit dem ATmega32 läuft die Steuerung einwandfrei. Allerdings kann
    ich auch den nicht mehr programmieren - der Programmer ist definitiv platt.
    Vielleicht ist es dann doch nur ein Zufall gewesen und er hat eine statische Entladung abbekommen oder so.
    Beim nächsten Versuch mit dem neuen Programmer werde ich mal vorher alle Portstecker abziehen. Ich befürchtete
    ich hätte aus Unwissenheit einen Anfängerfehler gemacht und dass ich den neuen gleich wieder brate. Ich konnte mir
    nicht vorstellen, dass eine Fehlkonfiguration o.ä. meinen Programmer abschiessen könnte - aber da draussen gibt
    es noch viel über uC was ich noch nicht weiß...daher lieber mal vorher fragen

    Grüße
    Christian

  4. #4
    Erfahrener Benutzer Roboter Genie Avatar von Searcher
    Registriert seit
    07.06.2009
    Ort
    NRW
    Beiträge
    1.410
    Blog-Einträge
    101
    Zitat Zitat von Hinweis zum Bascom-USB-ISP-Programmer
    Wenn der Jumper am USBISP eingesteckt wird, dann wird der zu programmierender Controller übe rden USB-Port mit Spannung versorgt. Dies ist jedoch nur dann gestattet wenn nicht mehr als 40mA entnommen werden. Eine höhere Belastung kann den USBISP beschädigen.
    Da bisher alles gut gegangen ist, gehe ich davon aus, daß der Jumper nicht gesteckt war?

    Gruß
    Searcher
    Hoffentlich liegt das Ziel auch am Weg
    ..................................................................Der Weg zu einigen meiner Konstruktionen

  5. #5
    Korrekt, ich habe den noch nie mit Jumper benutzt. Ich versorge
    den uC immer über das RNControl während des Programmierens.

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.02.2006
    Beiträge
    1.112
    Einen ähnlichen Effekt hatte ich letztens mit einem Diamex auch: Es ging nichts mehr, Programmer wurde nicht mehr erkannt.
    Ich hatte auch schon befürchtet, dass der relativ neue Programmer zerschossen wäre.
    Spannung wegnehmen usw. half nicht. Erst als ich Bascom runtergefahren und wieder neu gestartet hatte, wurde der Programmer wieder erkannt.

  7. #7
    So freundlich ist meiner leider nicht. Ich hatte den Rechner schon neu gestartet und
    es auch auf einem anderen probiert, an dem der Programmer früher lief. Beides ohne Erfolg.

    Grüße
    Christian

Ähnliche Themen

  1. IRLIZ34N am Atmega1284P
    Von D35troy3r im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 12.04.2012, 13:10
  2. USBISP Probleme
    Von LotMey im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 8
    Letzter Beitrag: 03.11.2010, 17:58
  3. myavr usbisp mit bascom
    Von Roboman93 im Forum AVR Hardwarethemen
    Antworten: 2
    Letzter Beitrag: 21.08.2008, 14:55
  4. USBisp reparieren
    Von Kagerer im Forum AVR Hardwarethemen
    Antworten: 15
    Letzter Beitrag: 26.10.2005, 18:21
  5. Antworten: 11
    Letzter Beitrag: 28.04.2005, 22:52

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •