-         

Ergebnis 1 bis 6 von 6

Thema: osx: asuro flash-tool

  1. #1

    osx: asuro flash-tool

    Anzeige

    Ich hab vor kurzem meinen ersten asuro fertig zusammengebaut - yeha - leider hab ich Probleme damit, den asuro zu flashen.

    Dafür würde ich gerne mein macbook mit osx benützen, dass sollte nach meinen web-Recherchen auch machbar sein.
    Ich bin nach dieser Anleitung vorgegangen:
    http://xythobuz.org/index.php?p=asuro

    und soweit funktioniert auch alles (CoolTerm bekommt während des SelfTests alle infos gesendet, und auch der IR test am ende klappt einwandfrei...).

    Nur der Flasher (con_flash) mach Probleme:
    Er wurde normal via make/install installiert (keine Fehler bis hierhin), aber sobald ich versuche eine .hex datei zu flashen:


    Code:
    con_flash "/dev/tty.*" test.hex
    bekomme ich folgenden Fehler:


    Open /dev/tty.* --> Could not open /dev/tty.*
    Already in use ?!?!


    Failed !

    wenn ich den befehl auf "con_flash "/dev/tty..usbserial-AXVEAVEX" test.hex" (hab ich per "ls -l /dev/tty.*" ermittelt) ändere, gehts immerhin schon weiter... bis hier hin:


    Open /dev/tty.usbserial-AXVEAVEX -->
    danach passiert, auch wenn ich den asuro einschalte, nichts mehr...


    kann mir hier jemand weiterhelfen?

  2. #2
    RN-Premium User Roboter Genie Avatar von 5Volt-Junkie
    Registriert seit
    06.03.2008
    Alter
    30
    Beiträge
    946
    Hi und willkommen im Forum

    muss man nicht statt
    Code:
    con_flash "/dev/tty.*" test.hex
    Folgendes eingetippt werden
    Code:
    con_flash "/dev/tty.usbserial-AXVEAVEX" test.hex
    Denn mit Sternchen spricht man ja eigentlich alle serielle Schnittstellen an.

    Auch die Datei ist vielleicht falsch konfiguriert
    Code:
    alias "asuro"="1386-linux-con_flash /dev/tty.* /pfad/zur/hex.hex"
    hier soll anstelle von * dein Programmer eingetragen werden

  3. #3
    @5Volt-Junkie

    Danke für deine Antwort, aber wie ich in meiner Frage geschrieben habe:

    wenn ich statt "/dev/tty.*" "/dev/tty.usbserial-AXVEAVEX" eingebe, bekomm ich folgende ausgabe:

    Open /dev/tty.usbserial-AXVEAVEX -->


    dann passiert nichtsmehr. Wenn ich den asuro jetzt einschalte oder er schon an war - es tut sich nichts und nach n paar sekunden fängt der automatische selbsttest an.
    Die Ausgabe im terminal verändert sich auch nicht mehr.

  4. #4
    Das hilft Dir jetzt vermutlich nicht weiter, aber ich hänge an genau der selben Stelle. Beim Aufruf von

    i386-linux-con_flash /dev/tty.usbserial-AXTLU32S /Pfad/zu/meiner/test.hex

    bleibt das Terminal mit dieser Meldung hängen:

    Open /dev/tty.usbserial-AXTLU32S -->

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von m.a.r.v.i.n
    Registriert seit
    24.07.2005
    Ort
    Berlin
    Beiträge
    1.247
    Hallo,
    habt ihr es mal mit /dev/cu.usbserial- anstelle /dev/tty.usbserial- versucht. Irgendwo hatte ich mal gelesen das tty Device Hardware Handshake verwendet, das cu Device ohne Handshake.


  6. #6
    Hallo m.a.r.v.i.n!
    Das funktioniert!
    Vielen herzlichen Dank!
    Ist Dir jetzt auch geholfen, jck7e?

    Der Vollständigkeits halber: Mein Aufruf im Terminal heißt jetzt:
    i386-linux-con_flash /dev/cu.usbserial-AXTLU32S /Pfad/zu/meiner/test.hex
    Mein System: OS X 10.7.5

Ähnliche Themen

  1. Asuro Flash Tool Linux amd64
    Von Ubuntuxer im Forum Asuro
    Antworten: 12
    Letzter Beitrag: 25.02.2008, 18:30
  2. ASURO flash tool für Pocket Pc (PPC)
    Von bigfatsmile im Forum Asuro
    Antworten: 2
    Letzter Beitrag: 27.11.2007, 23:33
  3. Asuro Flash Tool 1.5
    Von MadMan2k im Forum Asuro
    Antworten: 0
    Letzter Beitrag: 28.09.2006, 12:29
  4. Asuro Flash Tool Probleme
    Von hoefflch im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 31.05.2006, 19:11
  5. Problem mit ASURO Flash Tool
    Von NX-5 im Forum Asuro
    Antworten: 15
    Letzter Beitrag: 13.05.2005, 21:03

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •