-
        

Ergebnis 1 bis 7 von 7

Thema: Boosternachbau, Mosfet-Kurzschluss?

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    19.12.2009
    Beiträge
    30

    Boosternachbau, Mosfet-Kurzschluss?

    Anzeige

    Hallo zusammen,

    ich versuche gerade einen Booster für meine Modellbahn zu bauen, bis jetzt mit mäßigem Erfolg. Gespeist wird das ganze von dem Trafo der Modellbahn. Der Atmega wird ebenfalls über einen 7805 versorgt (nicht in der Zeichnung). Beginnt nun der Atmega sein Signal zu senden, startet er sich nach sehr kurzer Zeit neu und der IRF9640 beginnt warm zu werden. Ich vermute, dass es zu einem Kurschluss am IRF9640 kommt, kann gerade aber absolut nicht nachvollziehen wieso. Könntet ihr mal einen Blick auf meinen Schaltplan werfen?Klicke auf die Grafik für eine größere Ansicht

Name:	Schaltplan Booster.jpg
Hits:	46
Größe:	15,4 KB
ID:	23032

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    08.02.2012
    Beiträge
    127
    Ich tippe mal darauf, dass der Gatewiderstand viel zu hoch ist. Da wird der Mosfet nicht durchschalten.
    Warum möchtest du einen P-Channel Mosfet nehmen?
    Der Widerstand des Mosfets mit 0,5Ohm ist auch recht hoch.
    Rein rechnerisch, wenn der Mosfet voll durchschalten _würde_, (mal den Fall angenommen, der Mosfet wäre auf dauer - ein) hättest du bei 10A einen Spannungsabfall von 5V und eine Abwärme abzuführen von 50W, wenn ich micht verrechnet habe.
    Dass dein Mosfet heiß wird, ist also kein Wunder. (Schaltvorgänge jetzt mal nicht mit eingerechnet.)

  3. #3
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    @Zameer: Gatewiderstand? Welcher Gatewiderstand? Der NPN-Transistor zieht die Gates direkt auf LOW, und da ein FET Spannungsgesteuert ist, würde ein vorhandener Gatewiderstand den Schaltvorgang nur minimal verlangsamen.
    Aber mit den 50W Verlustleistung hast du recht. Das Problem von neo98 ist, dass er den Mittelkontakt zur Signalisierung kurz auf Low ziehen muss, mit einem P-FET geht das noch relativ einfach. Um die Verlustleistung auf ein normales Maß zu reduzieren, bräuchte er einen N-FET und müsste dann aber über eine Ladungspumpe eine Hilfsspannung zum Einschalten des Highside-FETs erzeugen.


    Nun zum eigentlichen Problem: Die Schaltung ist fehlerhaft. Der obere FET ist falsch herum eingebaut (Source mit dem mittleren Bulk-Kontakt verbunden, ergo hast du Drain und Source vertauscht). Da die Body-Diode im FET bei Rückwärtsbetrieb leitet, kann damit durch den oberen FET permanent Strom fließen, der dann durch den unteren FET kurzgeschlossen wird.

    Außerdem überschreitest du die zulässige Gatespannung der FETs. Diese beträgt laut Datenblatt max +-20V, deine 18V Wechselspannung erreicht Spitzenwerte von rund 25V. Das kann dir die FETs früher oder später zerstören.

    Und schließlich bekommst du zum Zeitpunkt des Umschaltvorganges ein "kleines" Problem, weil kurzfristig beide FETs leitend werden. Dann hast du einfach Mal so einen Kurzschluss und zwischen VCC und GND.

    Gegenmaßnahmen: Oberen FET richtig gepolt einbauen. Eine Zwischenspannung erzeugen oder die Gates durch eine Kombination von Z-Diode und Widerständen schützen. Und schließlich die beiden Gates unabhängig voneinander ansteuern, um selbst programmatisch eine Totzeit einzubauen. Alternativ wäre auch der Aufbau einer Verriegelungsschaltung möglich, aber das ist aufwändiger.

    mfG
    Markus
    Geändert von markusj (13.08.2012 um 11:08 Uhr)
    Tiny ASURO Library: Thread und sf.net Seite

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    08.02.2012
    Beiträge
    127
    Abgesehen vom umgedrehten FET, sehe ich nicht, dass der obere FET doch nur über den 10k Widerstand "geladen".
    Ist der nicht zu groß? Je nach Frequenz kommt der obere FET doch garnicht zum durchschalten.

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    19.12.2009
    Beiträge
    30
    Ah da ist an meiner Zeichnung was falsch. Das soll +18 Volt heißen, kommt ja aus dem Gleichrichter raus.

    Ich komm nicht ganz mit bei dem was du sagt (bin auch nicht so fit in dem Thema...). So wie ich es jetzt eingebaut habe liegen doch die +18V am IRF9640 an Source an, und da dürfte die Body-Diode nicht leiten, weil Sperrrichtung. Oder bin grad vollens neben der Spur? Das Symbol in der Zeichnung stimmt nicht ganz mit dem "richtigen Symbol" im Datenblatt überein, hatte auf die schnelle nichts anderes zur Verfügung.

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    @Zameer:
    Je nach Frequenz. Aber der Widerstand verzögert das ein/abschalten der beiden FETs nur. Durchschalten tun die aber trotzdem, und die geringe Gatekapazität wird auch in brauchbarer Zeit umgelade.

    @neo98:
    Ok, dann überleben die Gates das.
    Zum Schaltplan: Ich weiß nicht, womit du deine Schaltpläne erstellst, aber das Programm ist wohl ziemlich schlecht, wenn selbst bei so einfachen Bauteilen wie einem FET das Schaltungssymbol falsch ist. Bei einem P-MOSFET geht die Verbindung vom Bulk-Kontakt (der mit dem Pfeil) zum Source-Anschluss (Bild). Wenn du aber sagst, dass du das richtig herum gebaut hast ...

    Nachdem die beiden Punkte abgehakt sind: Übrig bleibt von meiner Liste noch das Verhalten beim Umschalten. Problematisch ist vor allem der Teil, bei dem der 10k-Widerstand die Gates wieder aufladen soll, das hatte Zameer gemeint. Wenn du den Transistor abschaltest, werden die Gates der beiden FETs langsam über die 10kOhm auf 18V aufgeladen. Dabei gibt es einen relativ großen Spannungsbereich, in dem beide FETs leitend sind. Damit gibt es einen Kurzschluss und der Strom wird nur durch die Leitfähigkeit der beiden FETs begrenzt. Der Spitzenwert ist dabei offenbar so hoch, dass die Spannung des Trafos einbricht und der AVR in den Reset geht.

    Warum orientierst du dich eigentlich nicht an den funktionierenden Booster-Schaltungen die andere im Netz veröffentlicht haben?

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  7. #7
    Benutzer Stammmitglied
    Registriert seit
    19.12.2009
    Beiträge
    30
    So, hab heute morgen nochmal ein bisschen dran rumgelötet und den 10k gegen ein 220 Widerstand ersetzt. Jetzt läuft das ganze für meine Zwecke eigentlich ausreichend gut genug. Der Mosfet wird jetzt auch nicht mehr übermäßig warm und mit Kühlkörper dürfte eigentlich nichts mehr passieren.

    Diese Schaltung ist auch nicht ganz von mir, nur wirklich minimal abgeändert, aber ist wohl nicht die beste Lösung. Hab auch schon andere gefunden, wollte aber erstmal dass hier aussprobieren einfach zum Testen. Was hier natürlich fehlt ist ein Schutz gegen Kurzschlüsse auf den Gleisen. Dafür werde ich wohl doch einen aufwändigeren Booster bauen müssen...

    Danke für die Hilfe!

Ähnliche Themen

  1. MOSFET für 230V PWM/ geeigneter MOSFET Treiber
    Von malthy im Forum Suche bestimmtes Bauteil bzw. Empfehlung
    Antworten: 16
    Letzter Beitrag: 18.06.2009, 18:24
  2. Kurzschluss - war's das?
    Von pinsel120866 im Forum Asuro
    Antworten: 19
    Letzter Beitrag: 05.01.2008, 15:05
  3. kurzschluss im asuro?
    Von azur im Forum Asuro
    Antworten: 3
    Letzter Beitrag: 05.02.2006, 18:57
  4. H-Brücke Kurzschluss
    Von .Johannes. im Forum Motoren
    Antworten: 9
    Letzter Beitrag: 19.12.2005, 08:26
  5. Kurzschluss
    Von franzl im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 01.10.2005, 10:39

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •