-         

Ergebnis 1 bis 5 von 5

Thema: "Magician Roboduino" Baubericht, Erfahrungen usw...

  1. #1
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.118
    Blog-Einträge
    1

    "Magician Roboduino" Baubericht, Erfahrungen usw...

    Anzeige

    Dagu Magician Chassis und Magician-Controller


    Mein Magician brachte mich oft in Weissglut und Verzweiflung! Zuerst lichtdurchlässige Segmentscheiben als Speedkontrolle, dann machte mich das das Controllerboard fertig.
    Anfangs dachte ich an Programmierfehler, Fehler bei der Berechnung der Spannungsteiler für die Fronttaster zwecks Analogauswertung bei Frontkollision.
    Natürlich testete ich erst alles unter Laborbedingungen, dann den Magician programmiert und getestet und nix ging. Natürlich war es die 5-Volt Stabilisierung, die zusammenbrach und damit auch falsche Spannungswerte am Analogeingang zw. Auswertung.
    Somit versorgte ich den Magician mit einen Netzteil, nun stimmten die Spannungen an der Kollisionsauswertung, aber kein Motor drehte sich mehr... komisch???

    Ich dachte das es irgendwelche Impulsstörungen aus meinem Schaltnetzteil waren, also eine eigene Stabilisierung / Regelung gebaut, um später nicht mit 4 AA Batterien sondern mit 6 oder 8 Stück zu fahren.

    Dann hat der OnBoard-5v-Regler mehr Sicherheit beim Regeln. Nun ist der Nachteil das die Motoren direkt mit der Batteriespannung betrieben werden, wenn man das Board nicht modifiziert.

    So setzte ich einen 7,5 V Regler ein, um die Motorspannung von normal 6 V nicht allzuviel zu erhöhen. Aber gedacht, leider bedachte mich mein Elektroniklieferant anstatt der angeforderten 7,V und 9V Regler ausschliesslich nur mit 9V Regler wohl aber als 7,5V verpackt.

    Das Ergebnis war das wieder sich kein Motor drehte obwohl die Spannungen stimmten, nach den Tausch der Spannung auf das org. 6V Batteriepack liefen die Antriebe wieder, nur die 5V waren nicht stabil.
    Dann nahm ich ein 10er Batteriepack und erhöhte dann die 6V in ca.1,5V Sprüngen und siehe da bei einer Spannung zw. 8..9 V versagten die Motoren.
    In der Beschreibung nochmals nachgelesen und dort wird ab > 9V Batteriespannung keine Motorsteuerung mehr garantiert. Komische Schaltungslösung.


    So werde ich jetzt den Regler vom Board entfernen so weit es geht und über Zwei getrennte 5V Regler an einem 9V Batterie / Akkupack (6 x AA Batterie/ 8 x AA - Akku) jeweils separat 5 Volt für die Motoren VDD und den Prozessor VCC einspeisen.

    Ich hoffe das meine Erfahrungen anderen helfen, die damit auch Probleme haben und noch daran knobeln sie zu Lösen

    Gerhard
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

  2. #2
    RN-Premium User Roboter Genie Avatar von 5Volt-Junkie
    Registriert seit
    06.03.2008
    Alter
    30
    Beiträge
    946
    Hallo Gerhard,

    vielen Dank für dein Bericht, der dem einen oder anderen sicher helfen wird bzw. auf einige Ideen bei ihrere Fehlersuche helfen.
    Was Du uns aber verschwiegen hast, sind die Bezeichnungen der Bauteile (Spannungsregler, Motorsteuerung etc.)

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.118
    Blog-Einträge
    1
    Ich habe "nix verschwiegen" , weil die Unterlagen soweit noch nicht fertig sind, nur eben Skizen und Kopfarbeit. Es wird alles Stück für Stück auf meiner Wewbseite nachzulesen/anzusehen sein, nurt fehlt etwas Zeit das immer schnell zu aktualisieren...habe aussser meinem Hobby auch andere Pflichten (leider)

    Gruss Gerhard
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    25.05.2012
    Beiträge
    13
    Das ungünstige Verhalten wird sicher daran liegen das das Ding von Chinesen als Kreuzung zwischen den ASURO und Arduino / Roboduino Schaltungen zusammengeschustert wurde.
    Da war wohl auch nur ein Bastler am Werk. Wie bei so vielen anderen ähnlichen Teilen auch

    Billigzeugs eben, da würde ichs lieber gleich komplett selbst machen und auf Lochrasterplatine aufbauen, da hat man mehr von

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von oderlachs
    Registriert seit
    17.05.2010
    Ort
    Oderberg
    Alter
    67
    Beiträge
    1.118
    Blog-Einträge
    1
    Nun ja LG, der Fehler war eigentlich meinerseits, weil ich die Beschreibung wohl zu oberflächlich gelesen hatte, anders was will man von dem Preis erwarten. Schau Dir unsere (teuren) AVR - , Arduino- usw.. "-Fachbücher", da wimmels so von "Dreckfuhlern" die dem Anfänger nicht gerade wohlwollend zu Gute kommen.
    Dort wird schon in den Grundrechenarten falsch gerechnet usw...

    Edit : Für Interessenten HIER meine Projekt-Code usw., aber noch in Bearbeitung !!

    Baubericht und Webseite aktualisiert am : 05.08.2012

    Gerhard
    Geändert von oderlachs (05.08.2012 um 12:49 Uhr) Grund: Nachtrag
    Arduinos, STK-500(AVR), EasyPIC-40, PICKIT 3 & MPLABX-IDE , Linux Mint

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 15.06.2011, 22:18
  2. Antworten: 6
    Letzter Beitrag: 02.09.2010, 19:32
  3. "Soft-Reset?" und "Finger-Interrupt?"
    Von trapperjohn im Forum Asuro
    Antworten: 8
    Letzter Beitrag: 11.06.2008, 00:02
  4. Suche Erfahrungen mit dem "AVRDRAGON"
    Von MrQu im Forum AVR Hardwarethemen
    Antworten: 0
    Letzter Beitrag: 02.02.2007, 08:27
  5. erfahrungen mit "geh"robotern?
    Von Cabal im Forum Mechanik
    Antworten: 4
    Letzter Beitrag: 14.03.2004, 12:43

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •