-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: L298 / L297 Ansteuerung

  1. #1
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1

    L298 / L297 Ansteuerung

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo zusammen,

    ich stehe wiedereinmal vor einem mysteriösen Problem.
    Ich habe meine Motorsteuerung bereits auf eine Platine gelötet. Als Schaltplanvorlage habe ich den Schaltplan hier im Forum genutzt:

    http://roboternetz.de/bilder/schaltungstep298.gif

    Nun wollte ich meinen bipolaren Motor QSH4218 ansteuern... vorher habe ich natürlich die Spulen im Motor durchgemessen um sie nicht falsch an den
    Treiber anzuschließen.
    Nun zu meinem Problem.
    Wenn ich den Motor mit Spannung (z.B. 12V) betreiben will dreht er sich nicht. Wenn man die Motorachse anfasst, bemerkt man aber ein zucken des Motors ohne dass er sich einen Schritt dreht.

    Mein Netzteil liefert 1,5A....das sollte doch wohl reichen.

    Habt ihr eine Idee???

    Danke für eure Hilfe

  2. #2
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Sieht so aus, als geht es nicht. Das Zucken spricht ein wenig dafür, das nur die eine Spule Strom kriegt. Um genaueres zu sagen müßte man es nachmessen. Das sollte gehen, wenn man versucht den Motor ganz langsam laufen zu lassen, also mit vielleicht 1 Schritt je Sekunde - zum nachmessen reicht dann ein DMM oder 2 LEDs mit Vorwiderstand.

  3. #3
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1
    Genau das habe ich schon versucht. Dabei ist folgendes herausgekommen... Alle Spulen bekommen Strom!!! Die Spannung an den Spulen fällt nicht ab und ist gleich hoch???
    Wenn ich LEDs anschließe passiert folgendes... Die LED blinken in der richtigen Reihenfolge... die Spannung wird aber natürlich über einen seperaten GND-Kontakt zurückgeführt.
    Also schließe ich dadraus, dass die Spannung in der Motorschaltung nicht über die Spule zurückgeführt wird.
    Geändert von Wombatz (09.05.2012 um 07:58 Uhr)

  4. #4
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2004
    Ort
    Kreis Starnberg
    Alter
    52
    Beiträge
    1.819
    Sieht so aus, als ob eine Motorspule einen schlechten Kontakt hat. Das kann innerhalb des Motors sein oder am Anschluss, manchmal brechen auch die Kupferdrähte in den Anschlußlitzen, speziell wenn sie häufig gebogen (Vibration) weden. Am besten Du sieht Dir erstmal alles genau an und verbessert eventuelle Schwachpunkte, die in provisorischen Aufbauten häufig sind. Wenn Du nichts findest, versuch durch Bewegen der Anschlußleitungen und Stecker den Fehler einzukreisen.

  5. #5
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1
    Das werde ich auf jeden Fall einmal überprüfen. Jedoch kann ich mir nicht so richtig vorstellen, dass das die Lösung ist. Ich messe die Spannung direkt an den Pins des L298 und dort ist die
    Spannung immer die selbe. Hier baut sie sich nicht ab. Wenn der L298 den Output1 bestromt, muss der Output2 GND sein.
    Das selbe gilt für Output3 und 4.
    Aus diesem Grunde denke ich das das Problem in der Steuerung liegen muss.

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    12.07.2007
    Ort
    Eisenach
    Beiträge
    409
    Hallo,
    den Spulenstrom hast du mit den Sense-Widerständen auch auf 1A laut Datenblatt des Motors eingestellt?

  7. #7
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1
    Wie stellt man denn den Spulenstrom ein. Ich habe lediglich 0,5 Ohm Widerstand genommen!
    Das kann natürlich der Fehler sein.
    Aber laut Datenblatt des L298 sollte das eigendlich genug sein
    Geändert von Wombatz (09.05.2012 um 13:57 Uhr)

  8. #8
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    12.07.2007
    Ort
    Eisenach
    Beiträge
    409
    Schau hier
    http://www.rn-wissen.de/index.php/Schrittmotoren
    fast in der Mitte in der Tabelle unterhalb der Schaltung.
    Dort wird beschrieben wie groß Vref in Abhängigkeit der Sense-Widerstände werden muß um deinen geforderten Spulenstrom zu erreichen.

  9. #9
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1
    Ach so...das war mir schon bewusst, ich dachte man müsste den Sense Widerstand genau berechnen.
    In dem Artikel geht es ja nur um die Berechnung der Spannung am Poti VREF. Also ich schaue nochmal weiter.
    Trotzdem danke für die schnellen Antworten.

  10. #10
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2004
    Ort
    Kreis Starnberg
    Alter
    52
    Beiträge
    1.819
    Soweit ich es jetzt verstanden habe, misst Du an allen Motoranschlüssen eine Spannung, die in der Nähe der positiven Betriebsspannung (12V) liegt. Im nächsten Schritt wäre es sinnvoll, die Spannung an den Sense-Anschlüssen des L298 (Pin 1 und Pin15) zu messen. Wenn hier die Spannung auch zu hoch ist, nochmals die Widerstände (Wert messen) und deren Masseverbindung genau überprüfen. Wenn die Spannung an den Sense -Anschlüssen etwa Masse ist, könnte der L298 einen Knacks haben.

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. l298 / l297 ansteuerung zu ruckelig
    Von synergy1337 im Forum Elektronik
    Antworten: 21
    Letzter Beitrag: 20.08.2011, 22:10
  2. doppelte Schrittmotor Ansteuerung L297 und L298
    Von Lenox im Forum Elektronik
    Antworten: 63
    Letzter Beitrag: 01.02.2007, 15:05
  3. Schrittmotor Ansteuerung L297/L298
    Von berg3 im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 21.12.2006, 22:52
  4. Problem mit der Ansteuerung L298/L297
    Von SMR im Forum Motoren
    Antworten: 2
    Letzter Beitrag: 02.01.2006, 19:55
  5. Ansteuerung des L298-L297
    Von Spurius im Forum Motoren
    Antworten: 1
    Letzter Beitrag: 29.11.2005, 12:02

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •