-
+ Antworten
Seite 3 von 3 ErsteErste 123
Ergebnis 17 bis 18 von 18

Thema: Probleme mit der Programmierung

  1. #17
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    01.03.2008
    Ort
    Niederlanden
    Beiträge
    1.128
    Zitat Zitat von maikel510 Beitrag anzeigen
    hallo,
    also ich hab folgendes problem ich hab meinen asuro fertig gebaut flashen,etc klappt eigentlich auch, aber ich hab ein problem mit dem programm. ich hab mir 2 ideen überlegt um ein projekt mit dem asuro zu starten: 1.der asuro soll eine art wohnung absuchen. dafür wollte ich eine wohnung als modell bauen und sie weiß anstreichen oder so damit er an der wand entlang fährt und in dem raum einen schwarzen gegenstand oder einen schwarzen fleck auf dem boden sucht. ich wollt ihn in einer art halbkreisbahn an der wand entlang laufen lassen und sobald er mit einem taster aufkommt fährt er etwas zurück oder dreht sich und fährt noch einen halbkreis und so weiter.
    2. er soll als eine arte einparkroboter funktionieren und mithilfe von annäherungssensoren oder ähnlichem in eine parklücke fahren
    zu dieser idee hab ich gleich mal ein paar fragen: ist es schwer? hat jemand erfahrungen damit gesammelt? wie würde ich da preislich liegen?
    zu meiner 1. idee hab ich schon 2 programme geschriebe aber da hab ich auch probleme xD bei dem ersten fährt er nur im kreis, die version war allerdings auch nur eine rohfassung die hab ich sofort abgebrochen:

    Code:
    #include <asuro.h>
    #include <myasuro.h>
    
    int main () 
    {
    
    Init();
        
    while(1)
    {
            MotorDir(FWD,FWD);
            MotorSpeed(120,90);
            Msleep(300);
    
    unsigned char taste;
    taste= PollSwitch();
    if(taste=32)
    {        MotorDir(BREAK,FWD);
            MotorSpeed(BREAK,100);
            Msleep(100);
    }
    else if(taste!=32)
    {
    MotorDir(RWD,FWD);
    MotorSpeed(100,100);
    Msleep(100);
     }
    else   // Diese Möglichheit besteht nicht: taste ist 32, oder es ist nicht 32. Eine andere Wahl gibt es nicht.
     {}
        
    }
    return (0);
    
       }
    Als erste Program Versuch ist das OK. Ich sehe hier kein problem.

    bei meinem 2ten programm steht er nur da die statusled leuchtet gelb dir vordere und die backled leuchten stark:
    Code:
    #include <asuro.h>
    #include <myasuro.h>
    
    int main (void) 
    {
    
        unsigned int data [2];
        Init();
        FrontLED(ON);
        while(1)
        {
            LineData(data);
            if(data[0]==data[1])   // data[links] ist fast immer nie gleich an data[rechts]! Nur in sehr seltsamme fallen.
            {
                MotorDir(FWD,FWD);
                MotorSpeed(150,110);
                Msleep(300);
    
                unsigned char taste;
                taste= PollSwitch();
                if(taste=32)
                {        
                MotorDir(BREAK,FWD);
                MotorSpeed(BREAK,100);
                Msleep(100);
                }
                else if(taste!=32)
                {
                MotorDir(RWD,FWD);
                MotorSpeed(100,100);
                Msleep(100);
                } [color=red][b]
                else //Wieder eine Wahl das nicht existiert! Weglassen
                {
                return 0;
                }
            }
            else  // hier ist data[0]!=data[1] (nicht gleich). Deshalb geht er hier fast immer in einer Endloss-schleife und fläckert ganz schnell die BackLeds an/aus! Und kommt nie wieder raus. Weil 10 nicht 0 ist.        {
            while(10)
            {
            BackLED(ON,OFF);
            BackLED(OFF,ON);
            StatusLED(YELLOW);
            }
             } 
    
        }
    
    
    return 0;
        
     }
    bitte helft mir oder gebt mir anregungen was ich sonst noch aus meinem asuro mache kann es ist ein schulprojekt ich kenn mich nicht so wirklich damit aus und verzweifle weil mir nichts mehr einfällt
    Deine letzte Code geht gleich in einer Endloss schleife weil de Responz von die Linien Phototransistoren verschiedene werten liefern bei gleichen Beleuchtung. Du muss erst diese sensoren zu einander Kalibrieren bis du darauf entscheidungen macht.
    Geändert von Valen (03.05.2012 um 21:30 Uhr)

  2. #18
    Benutzer Stammmitglied Avatar von Spacy Bar
    Registriert seit
    10.05.2014
    Beiträge
    34
    Was mich auch wundert ist, dass bei dir das Init() fehlte, du nur die Anführungszeichen geändert hast und es jetzt klappt.
    Kannst du dir/mir das erklären?

    LG
    Spacy Bar
    Geändert von radbruch (06.06.2014 um 18:33 Uhr) Grund: veraltet

+ Antworten
Seite 3 von 3 ErsteErste 123

Ähnliche Themen

  1. [ERLEDIGT] Probleme mit Programmierung von RN-AVR Universal
    Von alex2603 im Forum Controller- und Roboterboards von RobotikHardware.de
    Antworten: 13
    Letzter Beitrag: 19.03.2012, 16:17
  2. Probleme bei Programmierung
    Von freekwave im Forum Sonstige Roboter- und artverwandte Modelle
    Antworten: 17
    Letzter Beitrag: 30.12.2011, 11:40
  3. Probleme bei AVR Butterfly-Programmierung
    Von Youngtimer im Forum AVR Hardwarethemen
    Antworten: 4
    Letzter Beitrag: 21.11.2007, 19:01
  4. Probleme bei der Programmierung des Butterflys
    Von Heiko R. im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 19
    Letzter Beitrag: 28.10.2005, 09:21
  5. Probleme mit IR/RC5 Programmierung
    Von Lutz im Forum Controller- und Roboterboards von Conrad.de
    Antworten: 8
    Letzter Beitrag: 09.03.2005, 18:31

Berechtigungen

  • Neue Themen erstellen: Ja
  • Themen beantworten: Ja
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •