-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Probleme mit der Programmierung

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    23.04.2012
    Beiträge
    7

    Frage Probleme mit der Programmierung

    Anzeige

    Hallo liebe Community,

    Ich habe gestern abend meinen Asuro fertiggestellt und der Selbsttest hat auch wunderbar geklappt, also war das erste mal auf einer Platine gar nicht mal so schlecht

    Dann jetzt mein Problem:

    Die Bsp: im handbuch sind ja fürn A.... Selbst wenn man die 1:1 übernimmt laufen die zum teil nicht da ein ";" oder so fehlt.

    Naja dann wollte ich mal ein ganz einfaches und simples Programm schreiben das die Statusled solange Grün ist bis ein Kollisoonstaster gedrückt wird, dann soll sie Rot werden.
    Wie gesagt ganz simpel. habe es mit einer If/else funktion versucht:

    #include “asuro.h”
    int main(void) {
    if (PollSwitch()==0)
    {StatusLED(GREEN);}
    else
    {StatusLED(RED);}
    return 0;
    }
    Das Problem ist wenn ich das Make Tool drüberlaufen lasse das die fehler finden soll zeig er mir das an:

    > "C:\ASURO_src\FirstTry\Test-all.bat"

    C:\ASURO_src\FirstTry>make all
    set -e; avr-gcc -MM -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst test.c \
    | sed 's,\(.*\)\.o[ :]*,\1.o \1.d : ,g' > test.d; \
    [ -s test.d ] || rm -f test.d
    test.c:1:10: error: #include expects "FILENAME" or <FILENAME>
    -------- begin --------
    avr-gcc --version
    avr-gcc (WinAVR 20100110) 4.3.3
    Copyright (C) 2008 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    avr-gcc -c -mmcu=atmega8 -I. -g -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -Wall -Wstrict-prototypes -Wa,-ahlms=test.lst test.c -o test.o
    test.c:1:10: error: #include expects "FILENAME" or <FILENAME>
    test.c: In function 'main':
    test.c:3: warning: implicit declaration of function 'PollSwitch'
    test.c:4: warning: implicit declaration of function 'StatusLED'
    test.c:4: error: 'GREEN' undeclared (first use in this function)
    test.c:4: error: (Each undeclared identifier is reported only once
    test.c:4: error: for each function it appears in.)
    test.c:6: error: 'RED' undeclared (first use in this function)
    make: *** [test.o] Error 1

    > Process Exit Code: 2
    > Time Taken: 00:00
    Ich verstehe das garnicht denn es ist doch richtig so oder? Besonders das: "test.c:1:10: error: #include expects "FILENAME" or <FILENAME>" wundert mich etwas da es ja immer das selbe ist mit #include “asuro.h”

    Ich hoffe ihr könnt mich aufklären und mir sagen was ich falsch mache, denn aus der Betriebsanleitung werde ich nciht schlau kennt ihr auch eine Lektüre die sinnig wäre etwas besser mit der Programiring klar zu kommen?
    Vielen Dank für eure hilfe

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Karlsruhe
    Alter
    29
    Beiträge
    1.221
    Anführungszeichen richtig (Shift+2)? Und zu deinem Code: Der funktioniert nicht, du musst das ganze noch in eine Endlosschleife packen. Sonst wird die Fallunterscheidung nur genau einmal ausgeführt.

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    23.04.2012
    Beiträge
    7
    Zitat Zitat von markusj Beitrag anzeigen
    Anführungszeichen richtig (Shift+2)? Und zu deinem Code: Der funktioniert nicht, du musst das ganze noch in eine Endlosschleife packen. Sonst wird die Fallunterscheidung nur genau einmal ausgeführt.

    mfG
    Markus
    Danke Markus.

    Es waren wirklich die falschen Anführungszeichen -.- hätte ich auch irgendwie selber drauf kommen können aber naja.
    Das mit der endlosschleife ist mir hinterher auch noch eingefallen. Habe es grade mal geflasht und es klappt super danke.

    Habt ihr denn noch einen Tipp für ein gutes Buch zum erlernen der Programiersprache?

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    hallo,

    wenn du mehr über die asuro programmierung und erweiterungen lernen willst würde ich dir "mehr spaß mit asuro" empfehlen. ich habe beide bänder und kann nicht meckern. (die platinen für die erweiterungen liegen bei jedem band bei)


    mfG Mattze

  5. #5
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Karlsruhe
    Alter
    29
    Beiträge
    1.221
    Nur zum Programmieren lernen: Tutorial von µC.net und hier im Wiki, außerdem gibt es ein gutes Wikibook (http://de.wikibooks.org/wiki/C-Programmierung).

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    23.04.2012
    Beiträge
    7
    Danke euch beiden werde dann mal das Buch: Mehr Spaß mit Asuro holen da ich die Programiersprache sonst wohl nicht brauchen werde.

    Dann noch eine andere frage, mein asuro fährt sehr langsam auch wenn ich den motorspeed auf 255 stelle und ein motor hängt immer etwas hinterher also ist langsamer, außerdem fährt er wie in impulsen also gibt ruckwartig gas dann wieder etwas langsamer und dann wieder schneller, woran kann das liegen?

  7. #7
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Karlsruhe
    Alter
    29
    Beiträge
    1.221
    Irgendwo Verklemmungen in der Mechanik? Abweichungen zwischen den beiden Seiten sind normal (und können via Software ausgebügelt werden)

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    23.04.2012
    Beiträge
    7
    Zitat Zitat von markusj Beitrag anzeigen
    Irgendwo Verklemmungen in der Mechanik? Abweichungen zwischen den beiden Seiten sind normal (und können via Software ausgebügelt werden)

    mfG
    Markus
    wenn ich die räder von hand drehe merke ich kein großen unterschied und sind meiner meinung nach aus recht leichtgängig. vielleicht werde ich die motoren nochmal ab machen und neu ankleben vielleicht bringt das dann was. Wie müsste das Programm zum gradeausfahren denn aussehen?

  9. #9
    Neuer Benutzer Öfters hier
    Registriert seit
    23.08.2011
    Beiträge
    27
    Hallo,

    hab hier mal die beiden Motoren mit mittlerer Geschwindigkeit fahren lassen:
    Code:
    #include “asuro.h”
    int main(void) 
    {
    Init();		
    
    MotorDir(FWD,RWD);	//Parameter sind FWD, RWD, FREE, BREAK, jeweils für li und re
    MotorSpeed(120,120); //0…255 jeweils für li und re 
    while(1);			//Endlosschleife
    return 0;			//Ende
    }
    ich hoffe es hat dir geholfen

    mfG Mattze

    Edit:
    Versuch mal die Motoren ein bisschen nachzuölen. Wenn diese einen hohen Piepston "aussenden" laufen sie meist zu schwer.
    Ich habe mir die Arbeit gemacht und eine kleine Präsentation über die Befehle gestaltet. Bei Fehlern oder Anregungen bitte eine PN, danke!
    Angehängte Dateien Angehängte Dateien
    Geändert von Mattze96 (24.04.2012 um 16:06 Uhr) Grund: Datei angefügt

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    23.04.2012
    Beiträge
    7
    Zitat Zitat von Mattze96 Beitrag anzeigen
    Hallo,

    hab hier mal die beiden Motoren mit mittlerer Geschwindigkeit fahren lassen:
    Code:
    #include “asuro.h”
    int main(void) 
    {
    Init();		
    
    MotorDir(FWD,RWD);	//Parameter sind FWD, RWD, FREE, BREAK, jeweils für li und re
    MotorSpeed(120,120); //0…255 jeweils für li und re 
    while(1);			//Endlosschleife
    return 0;			//Ende
    }
    ich hoffe es hat dir geholfen

    mfG Mattze
    Danke für die mühe aber hat leider nicht geholfen denn wie ich die motoren ansteuer weiß ich nur nicht wie das programm aussehen muss das er auch wirklich gradeaus fährt, also beide räder gleich schnell sind, da wenn man beiden Motoren den selben wert gibt das nicht gewärleistet ist

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. [ERLEDIGT] Probleme mit Programmierung von RN-AVR Universal
    Von alex2603 im Forum Schaltungen und Boards der Projektseite Mikrocontroller-Elektronik.de
    Antworten: 13
    Letzter Beitrag: 19.03.2012, 16:17
  2. Probleme bei Programmierung
    Von freekwave im Forum Sonstige Roboter- und artverwandte Modelle
    Antworten: 17
    Letzter Beitrag: 30.12.2011, 11:40
  3. Probleme bei AVR Butterfly-Programmierung
    Von Youngtimer im Forum AVR Hardwarethemen
    Antworten: 4
    Letzter Beitrag: 21.11.2007, 19:01
  4. Probleme bei der Programmierung des Butterflys
    Von Heiko R. im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 19
    Letzter Beitrag: 28.10.2005, 09:21
  5. Probleme mit IR/RC5 Programmierung
    Von Lutz im Forum Controller- und Roboterboards von Conrad.de
    Antworten: 8
    Letzter Beitrag: 09.03.2005, 18:31

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •