-         

Ergebnis 1 bis 8 von 8

Thema: Problem mit Schrittmotorsteuerung ( Motoren Rauschen, Mikroschritt)

  1. #1
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    23.04.2007
    Ort
    stuttgart
    Beiträge
    1.127

    Problem mit Schrittmotorsteuerung ( Motoren Rauschen, Mikroschritt)

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo,

    habe hier eine Schrittmotorsteuerung mit TB6560AHQ Treibern rumliegen. (So eine: http://www.cncshop.at/index.php?a=3578, die gibt es auch tonnenweise im ebay)
    Wenn ich die Motoren enable und Mikroschritt aktiviert ist, Rauschen die Motoren recht laut. Es ist kein Fiepen mit definierter Frequenz wie bei PWM sondern eher ein weißes Rauschen.
    Kann das jemand erklären wo das herkommt, bzw ist das normal? Und kann man das eventuell irgendwie Filtern ?

    Danke schon mal
    meine projekte: robotik.dyyyh

  2. #2
    Moderator Roboter Genie
    Registriert seit
    26.08.2004
    Beiträge
    1.228
    Hallo goara,

    schau mal hier: http://www.heise.de/hardware-hacks/a...artikelseite=2

    Laut Heise haben die Chinesen wohl den Kondensator für's Timing falsch gewählt (Pin7 am TB6560, "Cosc"). Statt der verbauten 1nF sind wohl 220-330pF besser und verhindern das Pfeifen.

    Gruß
    Basti

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    22.07.2009
    Beiträge
    405
    HIER steht auch viel wissenswertes zur TB6560 Steuerung.
    Geändert von dussel07 (22.04.2012 um 10:25 Uhr)

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    23.04.2007
    Ort
    stuttgart
    Beiträge
    1.127
    Danke für die Links,
    Das Problem mit dem Timing habe ich nicht, da ich sowieso nur relativ langsam verfahren will, und somit die frequenz und den dutycycle entsprechend anpassen kann und auch kein Mach3 benutze. Das hat aber ja nichs mit dem Stillstandpfeifen zu tun.
    Habe die Kondensatoren gemessen, die sind tatsächlich falsch, werde das mal abändern.
    Und das mit den Optokopplern ist ja mal echt hart. So einen Schwachsinn habe ich schon lange nicht mehr gesehen. Werde sie überbrücken und noch ne Optokopplerplatine vorschalten.
    meine projekte: robotik.dyyyh

  5. #5
    Moderator Roboter Genie
    Registriert seit
    26.08.2004
    Beiträge
    1.228
    Probier das mal aus. Wenn man den Aussagen im µC.net vertrauen kann, dann ist das Pfeifen mit dem richtigen C weg.

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    23.04.2007
    Ort
    stuttgart
    Beiträge
    1.127
    OK, habe es jetzt mal getestet und die Kondensatoren durch 220pF ersetzt. Das Rauschen ist viel leiser geworden. Weg ist es aber immer noch nicht. Aber so ist es erträglich.
    Geändert von goara (24.04.2012 um 16:07 Uhr)
    meine projekte: robotik.dyyyh

  7. #7
    Moderator Roboter Genie
    Registriert seit
    26.08.2004
    Beiträge
    1.228
    220nF oder 220pF?

  8. #8
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    23.04.2007
    Ort
    stuttgart
    Beiträge
    1.127
    sorry pico, habe es korrigiert...
    meine projekte: robotik.dyyyh

Ähnliche Themen

  1. Motorsteuerung L298/L297 und Mikroschritt?
    Von Gizmor im Forum Motoren
    Antworten: 5
    Letzter Beitrag: 21.05.2009, 16:38
  2. Problem mit Schrittmotorsteuerung L297 & L298
    Von mumbelmann im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 08.03.2009, 12:51
  3. Mikroschritt-Steuerung für Schrittmotor in C (WinAVR)
    Von Viktor im Forum C - Programmierung (GCC u.a.)
    Antworten: 2
    Letzter Beitrag: 24.12.2007, 13:48
  4. RNBFRA Mikroschritt
    Von tomcat im Forum Bauanleitungen, Schaltungen & Software nach RoboterNetz-Standard
    Antworten: 2
    Letzter Beitrag: 28.03.2006, 16:26
  5. Problem mit Schrittmotorsteuerung
    Von Baumschubser im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 21.05.2005, 18:23

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •