-         

Ergebnis 1 bis 4 von 4

Thema: Problem mit Atmega168 AD-Wandler

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    29.12.2007
    Beiträge
    9

    Problem mit Atmega168 AD-Wandler

    Anzeige

    Hallo zusammen,

    ich bin gerade dabei ein Programm, dass bei dem Atmega8 lief, auf den Atmega168 zu übertragen.
    Aber offensichtlich will der AD-Wandler nicht.
    Die Konfiguration lautet :
    Config Adc = Single , Prescaler = Auto , Reference = Internal
    Start Adc

    Beim Atmega8 messe ich an Aref =2,55V so wie es sein soll.
    Beim Atmega168 jedoch nur etwa 1,1V.

    Was mache ich falsch?

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    12.01.2007
    Ort
    westliches Pannonien
    Beiträge
    123
    Hallo!

    Zitat Zitat von bondia Beitrag anzeigen
    Beim Atmega168 jedoch nur etwa 1,1V.

    Was mache ich falsch?
    Du liest das Datenblatt nicht!

    MfG

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    29.12.2007
    Beiträge
    9
    Stimmt. Danke für den Hinweis.
    Irgendwie habe ich schon geahnt, dass die interne Referenzspg. auf 1,1V gesenkt wurde.
    Aber das machte für mich keinen Sinn.

  4. #4
    Benutzer Stammmitglied
    Registriert seit
    09.03.2012
    Beiträge
    51
    Zitat Zitat von bondia Beitrag anzeigen
    Stimmt. Danke für den Hinweis.
    Irgendwie habe ich schon geahnt, dass die interne Referenzspg. auf 1,1V gesenkt wurde.
    Aber das machte für mich keinen Sinn.
    Hier steht noch mehr interessantes Zeug drin
    http://www.atmel.com/Images/doc2553.pdf

Ähnliche Themen

  1. AD-Wandler Problem
    Von Profdok im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 12.11.2007, 06:56
  2. Problem mit Timer und Atmega168
    Von applican im Forum C - Programmierung (GCC u.a.)
    Antworten: 3
    Letzter Beitrag: 26.07.2007, 02:25
  3. Problem DA-Wandler
    Von Olle_Filzlaus im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 29.04.2007, 17:40
  4. AD-Wandler problem
    Von Superhirn im Forum C - Programmierung (GCC u.a.)
    Antworten: 9
    Letzter Beitrag: 27.12.2006, 16:51
  5. A/D Wandler Problem
    Von Razer im Forum C - Programmierung (GCC u.a.)
    Antworten: 11
    Letzter Beitrag: 04.03.2006, 17:57

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •