-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Asuro unter Ubuntu 11.10 flashen

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13

    Asuro unter Ubuntu 11.10 flashen

    Anzeige

    Hallo Gemeinde,

    ich bin leider ein absolut blutiger Anfänger, sowohl beim Asuro als auch bei der Benutzung von Linux.


    Der Asuro ist zusammengebaut und der Selbsttest hat auch einwandfrei funktioniert.
    Ich benutze Ubuntu 11.10 (64-bit)

    Die Dateien asurocon und asuroflash hab ich in das Verzeichnis /usr/bin kopiert. In der Anleitung steht /usr/local/bin - dieses gibt es unter ubuntu 11.10 nicht.

    Über:

    sudo cat /proc/tty/driver/usbserial
    komme ich auf

    usbserinfo:1.0 driver:2.0
    0: module:qcserial name:"Qualcomm USB modem" vendor:05c6 product:9204 num_ports:1 port:1 path:usb-0000:00:1d.0-1.6
    1: module:ftdi_sio name:"FTDI USB Serial Device" vendor:0403 product:6001 num_ports:1 port:1 path:usb-0000:00:1a.0-1.2
    danach wechsle ich mit cd /usr/bin ins Bin verzeichnis und versuche dort

    chmod a+x asurocon
    danach tut sich nichts und das terminal wartet ganz normal auf einen neuen befehl, danach mach ich mich an die rpm-dateien: und erhalte folgende meldung nachdem ich

    alex@alex-ThinkPad-L412:~/Documents/ASURO/Compiler$ sudo alien -i avr-binutils-2.13.90.030512-1.i386.rpm
    eintippe
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "de:en",
    LC_ALL = (unset),
    LC_MESSAGES = "de_DE.UTF-8",
    LC_COLLATE = "de_DE.UTF-8",
    LC_CTYPE = "de_DE.UTF-8",
    LANG = "de_DE.cp1252@euro"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Warning: Skipping conversion of scripts in package avr-binutils: postinst prerm
    Warning: Use the --scripts parameter to include the scripts.
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "de:en",
    LC_ALL = (unset),
    LC_MESSAGES = "de_DE.UTF-8",
    LC_COLLATE = "de_DE.UTF-8",
    LC_CTYPE = "de_DE.UTF-8",
    LANG = "de_DE.cp1252@euro"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    avr-binutils-2.13.90.030512-1.i386.rpm is for architecture i386 ; the package cannot be built on this system
    heißt das, dass ich notgedrungen eine 32-bit linux version installieren muss, da ich ja eine 64-bit-version habe?

    Vielen Dank und beste Grüße

    Alex

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Tiny ASURO Library: Thread und sf.net Seite

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13
    ok, ich bin nun stepbystep alles durchgegangen,

    hängen tu ich nur wenn ich asuroflash aufrufen will.

    dann bekomme ich folgende fehlermeldung:

    (process:11101): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

    (asuroflash:11101): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:11101): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:11101): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:11101): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    Segmentation fault
    weißt du (ihr) was das bedeutet?

  4. #4
    Neuer Benutzer Öfters hier Avatar von BerndJM
    Registriert seit
    17.03.2012
    Ort
    Neckarmühlbach
    Alter
    59
    Beiträge
    21
    Hi,
    das Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap" ist eine recht häufige Geschichte siehe z.B. hier. Das Programm sollte aber trotzdem starten und auch funktionieren.
    Welche Version von asuroflash benutzt du?

    Grüßle Bernd
    Theoretisch gibt es keinen Unterschied zwischen Theorie und Praxis ...

  5. #5
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13
    Hi,

    also das Programm startet nicht, zumind. seh ich es nicht im systemmonitor =(

    welche version: http://download.gna.org/asuro-tools/ hier habe ich asuroflash-1.6.2.tar.bz2 gedownloadet und dann die datei in usr/bin kpoiert. bzw, die dort vorhandene datei überschrieben.

  6. #6
    Neuer Benutzer Öfters hier Avatar von BerndJM
    Registriert seit
    17.03.2012
    Ort
    Neckarmühlbach
    Alter
    59
    Beiträge
    21
    Hmmm,
    welche Datei hast du nach /usr/bin kopiert? die .tar.bz2 ?
    Das kann nicht funktionieren.

    Bei mir war der Vorgang folgendermaßen:
    • asuroflash-1.6.2.tar.bz2 in ein Verzeichnis nach Wahl entpacken
    • in dieses Verzeichnis wechseln
    • mit sudo scons install die Installationsprozedur aufrufen
      • scons ist was ähnliches wie "make" - mußt du ggf. nachinstallieren - sudo apt-get install scons

    • dabei wird eine ausführbare Datei "asuroflash" in diesem Verzeichnis erstellt
    • und die Datei "asuroflash" nach /usr/local/bin kopiert
    • fertig



    Grüßle Bernd
    Theoretisch gibt es keinen Unterschied zwischen Theorie und Praxis ...

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13
    genausogemacht und dann kommt beim asuführen die meldung wie oben. und das programm startet nicht ? die asuroflashdatei ist dann 200,8 KB groß

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13
    **push =)

    Hallo leute,

    ist hier noch einer mit einem Tipp für mich? ich glaube ich werde notgedrungen Windows installieren um das dort alles zu starten xD

  9. #9
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Wie rufst du es auf? Bei Bernd funktioniert es offenbar ...

    mfG
    Markus
    Tiny ASURO Library: Thread und sf.net Seite

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    28.02.2012
    Beiträge
    13
    ich wechsle in /usr/local/bin und dann tipp ich asuroflash ein

    danach erhalte folgenden text:

    derwisch:/usr/local/bin$ asuroflash

    (process:5737): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.

    (asuroflash:5737): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:5737): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:5737): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (asuroflash:5737): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. AVR Lab unter Ubuntu
    Von Moebius im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 15.02.2011, 07:53
  2. Bascom unter Ubuntu 8.10 (Wine)
    Von stromflo im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 10
    Letzter Beitrag: 07.12.2009, 23:23
  3. AVR Programmierung unter Ubuntu
    Von Barthimaeus im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 10
    Letzter Beitrag: 20.09.2008, 00:53
  4. USB-ISProgrammer unter Ubuntu Linux
    Von goara im Forum Allgemeines zum Thema Roboter / Modellbau
    Antworten: 0
    Letzter Beitrag: 01.04.2008, 11:37
  5. Antworten: 12
    Letzter Beitrag: 06.01.2006, 16:36

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •