-         

Ergebnis 1 bis 5 von 5

Thema: USB - RS232 Adapter Problem

  1. #1

    USB - RS232 Adapter Problem

    Anzeige

    Hallo,

    ich bin noch ein ziemlicher Neuling im Bereich Elektronik/Robotik. Aus einem Fernstudienkurs habe ich ein BASIC Stamp 1 Project Board und dieses USB-RS232 Adapter. Nun will ich einen fahrenden Roboter bauen, der mit diesen Motoren angetrieben wird.
    Es funktioniert auch alles soweit einwandfrei. Wenn ich aber mein Programm auf den µC übertrage, das Adapter trenne, den Roboter teste und dann wieder an den PC anschließe, stürzt das Adapter scheinbar ab. Erst wenn ich den PC neu starte, funktioniert es wieder.
    In dem Fernstudienkurs damals wurde gesagt, dass das passieren kann, wenn die Motoren während der Übertragung des Programms angeschlossen sind. Ich habe aber immer darauf geachtet, sie von der Schaltung zu trennen, während das Board über das Adapter mit dem PC verbunden ist.
    Ich kann mir gut vorstellen, dass ich einen blöden Anfägerfehler mache. Aber dann gibt es doch bestimmt auch eine einfache Lösung?!

    Beste Grüße
    Jan

  2. #2
    Erfahrener Benutzer Roboter-Spezialist Avatar von -schumi-
    Registriert seit
    30.12.2009
    Ort
    Wasserburg am Inn / Bayern
    Alter
    23
    Beiträge
    449
    Herzlich willkommen Janschko :-D

    Hast du denn schon mal einen anderen Adapter probiert? Denn die Prolific (<- der Chip der in deinem Adapter drinsteckt) Teile.. Naja, ich sags mal so: Wenn man die Wahl zwischen einen FTDI und einem Prolific hat nimmt man mit Sicherheit den FTDI.

    Und das mit den Motoren ist Käse. Was höchstens noch sein könnte, dass er abstürzt wenn du ihn ansteckst und die Motoren noch laufen. Aber auch dann ist die Schaltung schlecht designed.

    Zeig mal einen Plan deiner Roboter-Schaltung.

    Viele Grüße
    -schumi-

  3. #3
    Erfahrener Benutzer Roboter Experte Avatar von ePyx
    Registriert seit
    14.05.2008
    Ort
    Falkensee
    Beiträge
    700
    Zitat Zitat von -schumi- Beitrag anzeigen
    Wenn man die Wahl zwischen einen FTDI und einem Prolific hat nimmt man mit Sicherheit den FTDI.
    Hab bisher mit keinem von beiden ernsthafte Probleme gehabt.

    Wie werden die Motoren denn versorgt? Der Adapter wird sicherlich nicht isoliert oder galvanisch getrennt sein, was bei USB große Probleme machen kann. Genauso blöd ist es, wenn Windows den USB-HUB abklemmt weil zuviel Strom gezogen wird/wurde. Dann ist ebenfalls bis zum Neustart alles tot.
    Grüße,
    Daniel

  4. #4
    Erfahrener Benutzer Roboter-Spezialist Avatar von Thegon
    Registriert seit
    21.01.2011
    Beiträge
    562
    Schließt du den Adapter denn am USB anschluss oder am RS232 Anschluss ab?

    Wenn du ihn per USB absteckst, dann könnte ich es mir noch irgentwie vorstellen dass es da Probleme mit dem Adapter/Treibern oder sonst was geben könne, ich kenne den Adapter auch nicht.

    Aber wenn du die RS232 Schnittstelle abklemmst dann dürde das überhaupt nichts machen, sofern du keine Flusskontrolle hast sollte der Computer einfach fröhlich ins Leere senden und nicht einmal mitbekommen, dass sich etwas getan hat.

    Mfg Thegon

  5. #5
    Zitat Zitat von -schumi- Beitrag anzeigen
    Was höchstens noch sein könnte, dass er abstürzt wenn du ihn ansteckst und die Motoren noch laufen. Aber auch dann ist die Schaltung schlecht designed.
    Wie gesagt, ich habe die Motoren sogar immer von der Schaltung getrennt, bevor ich das Adapter an das Board angeschlossen habe.
    Die Schaltung ist eigentlich bisher nicht sonderlich spektakulär. Ich steuere lediglich die zwei Motoren über einen L293D an.
    Ich werde aber gleich nochmal ein bisschen rumprobieren, ob es definitiv nur zum Absturz kommt, wenn die Motoren zuvor in Betrieb waren.

    Zitat Zitat von ePyx Beitrag anzeigen
    Wie werden die Motoren denn versorgt? Der Adapter wird sicherlich nicht isoliert oder galvanisch getrennt sein, was bei USB große Probleme machen kann. Genauso blöd ist es, wenn Windows den USB-HUB abklemmt weil zuviel Strom gezogen wird/wurde. Dann ist ebenfalls bis zum Neustart alles tot.
    Die Motoren werden über ein 9V DC Netzteil, das an das Projectboard angeschlossen ist mit Strom versorgt.

    Zitat Zitat von Thegon Beitrag anzeigen
    Schließt du den Adapter denn am USB anschluss oder am RS232 Anschluss ab?
    Am RS232 Anschluss des Boards. Es bleibt über USB ständig mit dem PC verbunden.


    Wie gesagt, ich werde jetzt nochmal ein bisschen rumprobieren, unter welchen Bedingungen ich den Absturz reproduzieren kann.

Ähnliche Themen

  1. Rn-Control (RS232) mit einem USB-to-RS232- Adapter unter Win7 64 bit
    Von Liquidator im Forum Schaltungen und Boards der Projektseite Mikrocontroller-Elektronik.de
    Antworten: 4
    Letzter Beitrag: 18.04.2011, 00:16
  2. USB zu RS232 Adapter
    Von Zentauro im Forum Suche bestimmtes Bauteil bzw. Empfehlung
    Antworten: 4
    Letzter Beitrag: 13.05.2009, 22:32
  3. Ponyprog Problem RS232 to USB Adapter
    Von facile im Forum C - Programmierung (GCC u.a.)
    Antworten: 2
    Letzter Beitrag: 02.12.2008, 20:09
  4. RS232 mit Adapter(n)
    Von 7eddi im Forum PC-, Pocket PC, Tablet PC, Smartphone oder Notebook
    Antworten: 3
    Letzter Beitrag: 31.05.2007, 15:17
  5. RS232-USB-Adapter
    Von harry5000 im Forum PC-, Pocket PC, Tablet PC, Smartphone oder Notebook
    Antworten: 4
    Letzter Beitrag: 26.01.2007, 11:45

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •