-         

Ergebnis 1 bis 7 von 7

Thema: Servosteuerung mit NE555 Problem

  1. #1

    Servosteuerung mit NE555 Problem

    Anzeige

    Hallo Forum

    Ich habe mir eine Servosteuerung gebaut mit Hilfe dieser Schaltung gebaut.
    Als Multivibrator geht das ja nicht. Die Frequenz war zu hoch. Daher ein Puls mit PWM.

    http://www.aero-hg.de/servotester.html

    Klicke auf die Grafik für eine größere Ansicht

Name:	SERVOT1a.gif
Hits:	30
Größe:	6,3 KB
ID:	21541

    So weit so gut. Eine Platine für den Puls von 50 Hz und eine weitere Platiene für die 1-2ms PWM.
    Ich kann 2 Servos an die Platine hängen und alles geht super.

    Dann habe ich eine Platine mit 10 NE555 für die Servos gebaut. (10 PWMs Parallel an die Versorgung)
    Der 50 Hz Tackt ist weiterhin Extern.
    Jetzt habe ich erhebliche Probleme mit 2 Servos an einem NE555. Die übersteuern und sind am zittern.
    Wenn ich zwei Servos an 2 NE555 hänge, ist das überregeln und das Zittern geringer.

    Ich stehe nun auf dem Schlauch. Ich finde nicht das Problem. Ich habe die Spannung von 5V mit einem 7805 erstellt und noch 200yF als Elko dahinter gehangen. Hat nicht geholfen.


    Wer hat da eine Idee was da los ist.

    Gruß Jörg

  2. #2
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.544
    Wilkommen im Forum.
    Wie sieht der Plan genau aus? Ich vermute das du die ganzen Servos an eine Versorgung angeschlossen hast. EinServo hat einen sehr hohen Einschaltstrom. Dadurch kann die Spannung kurzzeitig einbrechen, das reicht aber aus damit die Servos zittern. Eine 2te Möglichkeit wäre noch das die Servos zu stark belastet werden.

    MfG Hannes

  3. #3
    Erfahrener Benutzer Roboter Experte Avatar von ePyx
    Registriert seit
    14.05.2008
    Ort
    Falkensee
    Beiträge
    700
    Du kannst ja mal das Folgende ausprobieren :

    http://www.aero-hg.de/IMPEDANZIMPULS.html

    Damit schaltet der Autor, von dem auch deine Schaltung stammt, laut seinen Aussagen 30 Servos parallel.
    Grüße,
    Daniel

  4. #4
    Hallo Hannes
    Ich habe je 5 NEs an einem 7805 hängen. Das ganze hängt an einem Labornetzteil mit genügend Leistung. Der Strommesser zeigt mir im Normalbetrieb bei 2 Servos ca. 180 bis 200 mA an. Sollte eigentlich alles dafür reichen. Belastet sind die Servos nicht. Beim zittern geht der Sr
    trom auf 500 bis 600 mA hoch. Das passiert auch nur auf der Plaine mit den 10 NE555, die alle nicht belastet werden. Ich habe nur 2 Abgänge mit den Servos verbunden.

    Hallo Daniel.
    Das werde ich heute mal ausprobieren. Die Lösung hört sich gut an.

    Gruß Jörg

  5. #5
    Erfahrener Benutzer Roboter Experte Avatar von ePyx
    Registriert seit
    14.05.2008
    Ort
    Falkensee
    Beiträge
    700
    180 bis 200 mA sind aber schon sehr viel. Das sollten die Servos doch eigentlich nur im Einschaltmoment ziehen, oder?
    Grüße,
    Daniel

  6. #6
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.544
    Die Servos ziehen beim Verfahren kurzzeitig, je nach Typ, mehrere Ampere. Ich würde noch einige Kondensatoren davorsetzen (Elkos). Den Spitzenstrom wird die Anzeige im Netzteil nicht anzeigen, das ist einfach zu langsam. Für Motoranlaufströme gibt es Messgeräte mit der "In Rush" Funktion (Aktuell fällt mir das Fluke 337 ein)

    http://www.fluke.com/fluke/usen/elec...70328&trck=330
    http://support.fluke.com/find-sales/...629613_C_w.pdf

    MfG Hannes

  7. #7
    Hallo zusammen

    Södele Ich habe die 7805 durch 7806 getauscht. Das hat schon mal 40% Verbesserung ergeben. Also habe ich die Transistoren für die Signalverstärkung eingebaut. (3D Platinen sehen schon komisch aus) Top Sache. Alles läuft.

    Danke für eure Hilfe.
    Gruß Jörg

Ähnliche Themen

  1. Servosteuerung (per PC)
    Von geforce im Forum C - Programmierung (GCC u.a.)
    Antworten: 4
    Letzter Beitrag: 10.05.2008, 10:04
  2. Antworten: 8
    Letzter Beitrag: 13.10.2007, 20:16
  3. Problem mit Taktgenerierung (NE555)
    Von blizzard im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 09.04.2007, 00:40
  4. Antworten: 1
    Letzter Beitrag: 25.02.2007, 13:22
  5. Servosteuerung
    Von orton im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 28.06.2006, 22:59

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •