-         

Ergebnis 1 bis 5 von 5

Thema: L293D ohne Last -> defekt

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    31.08.2007
    Beiträge
    17

    L293D ohne Last -> defekt

    Anzeige

    Hallo Robotikfans,

    ich benutze zur Ansteuerung eines Schrittmotors einen L293D.
    Übergeordnet arbeitet ein Atmel Prozessor welcher eine L297 ansteuert.
    Der L297 versorgt seinerseits den L293D.
    Der Schrittmotor hat einen Spulenwiderstand von 90 Ohm. Dadurch ist sichergestellt dass er bei 12V Betriebsspannung gerade 130 mA fliessen können.

    Beim Testen der Schaltung, versehentlich ohne Motor, wurde der L 293D sehr heiss.
    Der Baustein war danach nicht mehr richtig zu gebrauchen. Der Motor kann etwa 1 Minute betrieben werden. Danach sind die Bewegungen unkoordiniert so dass kein Drehmoment aufgebaut werden kann.

    Wird ein L293D beim Betrieb im Leerlauf d.h. ohne Motor beschädigt ?

    Ich kann mir das Verhalten bisher nicht erklären.
    Es gibt keine induktiv erzeugten Spannungsspitzen. Werden zwei Transitoren kurzgeschlossen ?

    habt ihr eine Erklärung oder sogar einen Rat was ich machen kann ?

    viele Grüsse

    Christian

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von BMS
    Registriert seit
    21.06.2006
    Ort
    TT,KA
    Alter
    26
    Beiträge
    1.192
    Hallo,
    ohne Last dürfte der L293D so gut wie keine Wärmeentwicklung haben.
    Möglicherweise hast du ihn falsch beschaltet?
    Und wie versorgst du den Motortreiber?
    Meist hilft ein Schaltplan bei der Fehlersuche.
    Grüße, Bernhard

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    10.11.2010
    Beiträge
    23
    Hallo autoguide,

    ich möchte erst mal auf deine Theorie auf mit dem 130mAh eingehen. Der Strom wird nur im Haltemoment fließen, da sich der "Spullenwiderstand" nicht Konstant ist da er von der Frequenz abhängig ist. Kurz um kann man sagen, dass der Widerstand höher wird umso höher die Drehzahl des Motors ist. Aus diesem Grund nimmt auch das Drehmoment des Motors mit steigender Drehzahl ab.

    Nun hätte ich noch eine. Hast du den L293 richtig abgesicher hast? Laut Datenblatt hat das IC zwar interne Freilaufedioden aber diese sind nicht besonder gut ich würde dir empfehlen paralel zu dem Motoren noch Varistoren zu befestigen.

    Da du gesagt hast es sind Schrittmotoren wäre noch die Frage ob sie 4 oder 6 Anschlüße haben? Und hast du auch auf die richtigen Phasen Anschluss geachtet?

    Zum Thema ohne Last zu Betreiben ist das immer so eine Sache, ich kann dir nur sagen, dass ich in der Arbeit ein IC habe für einen Schrittmotor und dieses ist so empfindlich, dass es schon kaputt geht wenn es nur das Wort "Lastfreiebetrieb" hört. Wenn du das IC davor schützen willst kannst du Paralle zu dem Ausgänge auf die Platine noch je eine 1k Ohm Widerstand zaubern um einen kleinen Last zu Simulieren.

    Gruß
    SchmidtBot

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    12.07.2007
    Ort
    Eisenach
    Beiträge
    409
    Hallo,
    Beim Testen der Schaltung, versehentlich ohne Motor, wurde der L 293D sehr heiss.
    Der Baustein war danach nicht mehr richtig zu gebrauchen. Der Motor kann etwa 1 Minute betrieben werden. Danach sind die Bewegungen unkoordiniert so dass kein Drehmoment aufgebaut werden kann.
    Um heiß zu werden muss ja eine ganz schöne Leistung am L293D abgefallen sein. Evtl. Schaltungsfehler oder ungewollter Schluss am Ausgang (nicht offen). Wenn der Motor ca 1 Minute läuft wird da der L293D auch heiß, oder danach wenn sich der Motor unkoordiniert verhält?
    Im DB kann ich keinen Hinweis darauf finden, dass zwingend ein Motor angeschlossen sein muss.

  5. #5
    Erfahrener Benutzer Begeisterter Techniker Avatar von Ostermann
    Registriert seit
    27.08.2009
    Ort
    Aachen
    Beiträge
    240
    H-Brücken können im Allgemeinen auch ohne Last (offene Ausgänge) betrieben werden. Speziell beim L298 und L293 macht das absolut nichts aus. Das Problem muss also woanders liegen...

    Mit freundlichen Grüßen
    Thorsten Ostermann
    --
    Wir bewegen Ihre Ideen!
    Intelligente Lösungen mit elektrischen Antrieben.
    http://www.mechapro.de

Ähnliche Themen

  1. RN-Control 1.4 - ohne Motor wird der L293D heiß und kaputt!!
    Von Chiky im Forum Schaltungen und Boards der Projektseite Mikrocontroller-Elektronik.de
    Antworten: 5
    Letzter Beitrag: 24.12.2010, 00:09
  2. L293D Defekt ??
    Von cardhu im Forum Elektronik
    Antworten: 7
    Letzter Beitrag: 26.02.2009, 12:39
  3. Motortreiber L293D wurde heiss - Nun defekt?
    Von Brantiko im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 14.09.2007, 14:01
  4. Motortreiber L293D ohne Controller?
    Von squelver im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 25.03.2007, 18:49
  5. Strom messen am L293D - ohne yC
    Von seed im Forum Elektronik
    Antworten: 5
    Letzter Beitrag: 21.04.2005, 22:40

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •