-         

Ergebnis 1 bis 6 von 6

Thema: Problem mit Baudrate

  1. #1
    Gast

    Problem mit Baudrate

    Anzeige

    Hallo,
    ich habe den Bascom Compiler und das STK500.
    Auf dem STK alles in Standardeinstellung. Also interner
    Takt mit ausgelesenen 3686400 Hz.
    (Oscillatorbytes 00 01)
    In meinem Basictestprogramm gebe ich den Crystal mit
    3690000 an und die Baudrate mit 9600.
    Soweit so gut. Im Terminalfenster erscheinen nach Übertragen
    des Programmes wilde Zeichen, die offensichtlich auf eine
    falsche Baudrate hindeuten Stelle ich die Baudrate im Terminalfenster
    auf 4800 Baud ein, klappt alles wunderbar.
    Den Com-Port habe ich auch gewechselt.
    Hat irgendjemand eine Idee warum das so ist?????
    Ist eine Einstellung auf dem Board falsch?

    Danke schon mal im Voraus.

    Marcus

  2. #2
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    17.10.2004
    Ort
    PB
    Beiträge
    123
    Hallo!

    Hast du die Baudrate auch für deinen COM-Port so eingestellt?
    Ich vermute, dass die Baudrate an deinem COM-Port auf 4800 Baud eingestellt ist und es somit mit 9600 Baud nicht funktioniert.
    Solltest du vielleicht mal nachprüfen.

    Grüße,
    Jonas

  3. #3
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    09.06.2004
    Ort
    Aachen
    Beiträge
    2.674
    Würde ich auch vermuten.
    Hast du es mal mit dem Hyper-Terminal ausprobiert?

    MFg Moritz

  4. #4
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    08.08.2004
    Ort
    durmersheim international
    Alter
    57
    Beiträge
    159
    hi,
    sind die fuse-bits auf die 3,68 mhz eingestellt?
    3,68 MHz gehören meines wissens in die liga ext. quarz.
    interner oszillator lässt sich (mega8 / 16 / 32) nur auf 1,2,4 oder 8 mhz einstellen.
    ich verwende immer die 3,68mhz quarze, da funtzt die serielle ausgabe mit der angegebenen baudrate 1A.
    gruss, harry
    der kopf ist rund damit das denken seine richtung ändern kann...

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von darwin.nuernberg
    Registriert seit
    08.08.2004
    Ort
    A, A
    Alter
    53
    Beiträge
    1.305
    Blog-Einträge
    1
    Ich hatte ähnliche Problem mit Mega32,
    Lag auch an den Fusebits, welche die externe Taktung nicht aktivierten.

    Mit dem Hyperterminal werden allerdings die Einstellungen der Schnittstelle direkt geändert, damit hatte ich auch noch nie Probleme (und ich arbeite viel mit 9600er Datenanbindungen echt wahr).

    Die Ausgelesene Frequenz scheint mit eher wie hier bereits vermutet, von externer Natur sein, diese muß aber doch nicht auch die CPU antakten.

    (wenn ich ein Bier habe, heisst das doch nicht dass ich es getrunken habe) -lol-

    Also check nochmal die Fusebits und änder nicht zuviel auf einmal. Am besten lass eine Seite (PC oder Atmel) so wie sie ist und ändere nur einen Parameter nach dem anderen. Stur dabei bleiben. Sonst bust man sich die eigenen Stolperfallen.
    Gruss
    Darwin (meine Projekte sind auf meiner Pinnwand zu finden)

  6. #6
    Gast

    Es waren die Fuse-Bits

    Zitat Zitat von harryup
    hi,
    sind die fuse-bits auf die 3,68 mhz eingestellt?
    3,68 MHz gehören meines wissens in die liga ext. quarz.
    interner oszillator lässt sich (mega8 / 16 / 32) nur auf 1,2,4 oder 8 mhz einstellen.
    ich verwende immer die 3,68mhz quarze, da funtzt die serielle ausgabe mit der angegebenen baudrate 1A.
    gruss, harry
    Hallo Harry,

    es waren die Bits. Der Mega16 lief intern mit 1MHz.
    Geändert und schon fluppts.
    Danke,

    Marcus

Benutzer, die dieses Thema gelesen haben: 0

Derzeit gibt es keine Benutzer zum Anzeigen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •