-
        

Ergebnis 1 bis 6 von 6

Thema: Nicht alle LED's an PORT C funktionieren

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    16.01.2005
    Beiträge
    9

    Nicht alle LED's an PORT C funktionieren

    Anzeige

    Erst einmal Hallo zusammen,
    ich habe meinem ersten AVR-Board ein Problem.
    Ich nutze folgenden Code, um die LED'S an PORT C anzusteuern:

    Code:
    $crystal = 1000000
    $regfile = "m16def.dat"
    
    Dim I As Integer
    Dim N As Integer
    Config Portc = Output
    For N = 1 To 100
      For I = 0 To 7
       Portc.i = 0
       Waitms 100
       Portc.i = 1
      Next I
    Next N
    Nun leuchten aber nur die LED's 1,2,7,8 die LED's 3,4,5,6 bleiben dunkel.
    Elektrisch sollte es funktionieren. Ich habe den MEGA 16 demontiert und die Pin's mit nem Draht auf Masse gelegt. Alle LED's leuchten dann.
    Auch einen anderen M16 habe ich ausprobiert. Das gleiche Ergebnis.
    Was habe ich falsch gemacht? Warum leuchten die mittleren LED's nicht?
    Ich danke Euch für die Hilfe

    Gruß Ingo

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    01.03.2004
    Ort
    Bielefeld (JA, das gibt es!)
    Alter
    29
    Beiträge
    1.614
    was heißt denn demontiert?
    Ich will Microsoft wirklich nicht zerstören. Das wird nur ein gänzlich unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds, Entwickler von Linux

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    16.01.2005
    Beiträge
    9
    Ich habe den Chip gesockelt montiert. Also ersten raus und zweiten rein

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    26.11.2003
    Ort
    Langen / Hessen
    Alter
    52
    Beiträge
    393
    Du musst das JTAG an deinem ATmega16 abschalten, solange das JTAG aktiviert ist (STandarteinstellung beim Ausliefern) funktioniert der PortC nicht komplett.

    Gruss Clemens
    Erfolg kommt NUR im Duden vor Leistung
    Grüße Euer LuK-AS

    Autonome Robotik www.CWNet.de
    Tauchroboter www.T-Bot.de

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    01.03.2004
    Ort
    Bielefeld (JA, das gibt es!)
    Alter
    29
    Beiträge
    1.614
    und die pins mitm draht auf masse? (dies ist ein nicht sichbarer leertext)
    Ich will Microsoft wirklich nicht zerstören. Das wird nur ein gänzlich unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds, Entwickler von Linux

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    16.01.2005
    Beiträge
    9
    Hallo Luk-AS,
    vielen Dank für den Tipp.
    Hatt geklappt.

    Bis dann
    Ingo

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •