-
        

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Hat jemand Erfahrungswerte vom IC-MA HALL Winkelsensor ?

  1. #1
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332

    Hat jemand Erfahrungswerte vom IC-MA HALL Winkelsensor ?

    Anzeige

    Hallo Leute, hat jemand bereits Erfahrungen mit dem "IC-MA" Sensor von IC-Haus gemacht ?

    Ich habe meine Schaltung vor kurzen hardwaremäßig in Betrieb genommen und sah folgendes:

    Stromverbrauch liegt bei ca. 30 mA / Trotz Stromsparmodus ? Korrekt ?

    Konnte den genauen Abstand zum Magneten noch nicht ermitteln, hat hier jemand Erfahrungswerte?

    Die Impulse waren hier sehr kurz.
    (Konnte nur einen Magneten über dem Sensor halten.

    Mechanik fehlt noch

    Gruss R.
    Kaum macht man es richtig, schon funktioniert's ...

  2. #2
    Benutzer Stammmitglied
    Registriert seit
    21.12.2011
    Beiträge
    44
    Hallo Ritchie,

    Habe gerade Deine Frage gelesen und nach meinen Erfahrungen kann der Luftspalt zwischen Magnet und iC-MA 1-3mm betragen. Alles hängt allerdings von der Stärke des Magneten ab.

    H2R2

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332
    Hallo H2R2,

    das zeigen auch meine ersten Erfahrungen.
    Kaum macht man es richtig, schon funktioniert's ...

  4. #4
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332
    Hallo H2R2,

    ich habe derzeit weitere Erfahrungen mit dem Sensoren gemacht.

    Es scheint derzeit bei mir so zu sein, das sich zwei gegenüberliegende Sensoren teilweise beeinflussen.
    Wieso (wie), das muss ich noch heraus. Die Magneten, die ich habe sind sehr stark. Haben aber die Magnete 4x4mm aus dem Datenblatt verwendet. Der Abstand ist hierbei ca. 5cm, zwischen den einzelnen Sensoren.

    Es könnte sein das :
    1) das Drehfeld der einen Achse, auf dem zweiten Sensor ankommt.
    2) oder das mechanische Bewegungen der Sensoren, diese Impulse auslösen.

    Bewege ich die linke Achse, habe ich keine Impulse auf der rechten Seite. Was gegen (1) spricht
    Bewege ich die rechte Achse, habe ich auch Impulse auf der linken Seite. Was für 2 spricht.

    Verhältnis liegt bei ca. 1100 Impulse erzeugen 30-40 Impulse auf der Gegenseite.

    Ich dachte nochmals die Montage zu prüfen. Auch scheint der Abstand nicht 100% korrekt zu sein und/oder nicht exact in der Mitte des Sensors zu liegen.

    Die Auflösung ist zwar deutlich besser, aber der Aufwand ist gross dafür.

    Gruss R.
    Kaum macht man es richtig, schon funktioniert's ...

  5. #5
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.545
    Versuche einmal eine Metallplatte/blech/... zwischen den 2 Sensoren zu geben. Das Metall schirmt das Magnetfeld ab.

    MfG Hannes

  6. #6
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332
    Hallo,

    danke für den Tip. Ich werde MU-Blech zwischen die beiden Sensoren montieren, nur das hält magnetische Felder wirklich ab.

    Gruss R.
    Kaum macht man es richtig, schon funktioniert's ...

  7. #7
    Erfahrener Benutzer Robotik Einstein Avatar von 021aet04
    Registriert seit
    17.01.2005
    Ort
    Niklasdorf
    Alter
    29
    Beiträge
    4.545
    Solange es ein Ferromagnetisches Material ist (z.B. kein Niro Stahl) sollte es abschirmend wirken. Wenn der Fehler durch das Magnetfeld zustande kommt sollte es funktionieren.

    http://de.wikipedia.org/wiki/Abschir...lektrotechnik) => Statische und niederfrequente Magnetfelder

    MfG Hannes

  8. #8
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332
    Hi,

    Ein für diese Zwecke geeigneter Werkstoff ist das hochpermeable, sogenannte Mumetall.
    Ich hoffe, das es klappt. Dachte daran das morgen zu testen. Die Montage hat heute erfolgt.

    Gruss R.
    Kaum macht man es richtig, schon funktioniert's ...

  9. #9
    Benutzer Stammmitglied
    Registriert seit
    21.12.2011
    Beiträge
    44
    Hallo Ritchie,

    wenn die zwei iC-MAs sich mit der Fläche gegenüber liegen, so ist eine Abschirmung sinnvoll. Die vier Hall-Sensoren sind gegen Magnetfelder in gleicher Richtung unempfindlich.

    Moduliert der eine Magnet jedoch das Magnetfeld des anderen, so kommen beide durcheinander. Falls Abschirmung nichts bringt, wäre ein Bild zur Lage/Abstand gut.

    Grusss H2R2

  10. #10
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    07.11.2004
    Beiträge
    332
    Hallo H2R2,

    ich habe jetzt insgesamt 4 MU-Blechstreifen zwischen den Sensoren.
    Die Sensoren nochmals komplett mit einem Blech abgeschirmt, damit die Motoren kein Ärger machen. Das Übersprechen ist jetzt weg.

    Ich hatte auch noch ein Problem mit einer "kalten" Lötstelle.
    Hierdurch hat ein Sensor zeitweise von 250 Impulse auf 64 Impulse pro Umdrehung gewechselt.
    (Ein Konfigurationseingang ging auf "open"). Das hat ein Regeln unmöglich gemacht.

    Die Sensoren arbeiten jetzt recht gut.

    Auf einer Strecke von 1900 mm bekomme ich ~2750 Impulse je Sensor.

    Die Regelung kann hierbei die Fahrt sehr gut regeln.

    Jetzt kommt das Kalibrieren der gefahren Strecke dran und der aktuelle ermittelte Winkel.
    Der Robby fährt derzeit 1830 mm statt die gewollten 1900mm.
    Das aber sehr konstant.

    Gruss R.
    Kaum macht man es richtig, schon funktioniert's ...

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Winkelsensor
    Von Samaoui im Forum Sensoren / Sensorik
    Antworten: 33
    Letzter Beitrag: 29.11.2010, 10:24
  2. Winkelsensor für Bremspedal
    Von Asimo im Forum Sensoren / Sensorik
    Antworten: 11
    Letzter Beitrag: 14.07.2009, 08:20
  3. Erfahrungswerte Infrarotkommuniktion
    Von 1093 & 3511 im Forum Asuro
    Antworten: 20
    Letzter Beitrag: 04.01.2007, 14:37
  4. Winkelsensor, Poti oder Lichtschranke?
    Von BlooD im Forum Sensoren / Sensorik
    Antworten: 38
    Letzter Beitrag: 10.09.2005, 17:12
  5. cmps 03 dig. Kompass Erfahrungswerte
    Von JensB im Forum Sensoren / Sensorik
    Antworten: 3
    Letzter Beitrag: 27.12.2004, 03:04

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •