-         

Ergebnis 1 bis 4 von 4

Thema: AVR ISP MKII Probleme nach Firmware Upgrade

  1. #1
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1

    AVR ISP MKII Probleme nach Firmware Upgrade

    Anzeige

    Hallo Leute,

    gerade habe ich ein Firmware Upgrade meines MKII über AVR Studio 5 durchgeführt.... GROßER Fehler....
    Jetzt funktioniert das Gerät nicht mehr.
    Also zuerst sieht alles normal aus... die grüne LED leuchtet. Dann wenn man auf den Mikrocontroller zugreifen will blinkt die rote LED und ein Fehler wird ausgespuckt:

    Timestamp: 2011-10-12 20:47:53.406
    Severity: ERROR
    ComponentId: 20100
    StatusCode: 0

    Programming session setup failed: TCF command: Device:startSession failed: Code:1 ,Service: ,Message from peer:Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xc0, expected 0x00

    Kennt einer diesen Fehler??? Oder weiß jemand woher ich eine alte Firmware bekomme???

  2. #2
    Erfahrener Benutzer Begeisterter Techniker Avatar von Torrentula
    Registriert seit
    10.10.2009
    Ort
    Procyon A
    Alter
    21
    Beiträge
    355
    Auch den Jumper auf dem MKII Board gesetzt, der fuer das Firmware-Upgrade noetig ist? VIelleicht ist etwas beim Upgrade schiefgegeangen und du versuchst es einfach nochmal.

    Viel Erfolg!

    Torrentula
    MfG Torrentula

  3. #3
    Benutzer Stammmitglied Avatar von Wombatz
    Registriert seit
    10.06.2011
    Beiträge
    70
    Blog-Einträge
    1
    Der hat keinen Jumper. Das ist der, der über USB angesteuert wird. Hier kann man keinen Jumper setzen. Trotzdem danke der Antwort.
    Ich habe mal Atmel kontaktiert...Großartige Hilfe:

    Dear Customer,

    Thank you for contacting Atmel Technical Support.

    Red led blinking in AVRISPmkII indicates "Short circuit on target". This is mentioned in AVR studio 5 help --> view help --> AVRISPmkII User Guide --> Hardware description --> Status LED. Hence please check the hardware connections.

    To solve the short circuit problem, Please refer to "Trouble shooting: Point 5: AVRISPmkII reports short-circuit on the target" in the Troubleshooting Guide in the AVRISPmkII User Guide.

    Also, Try Manually Upgrading the firmware for AVRISPmkII. The procedure is given in AVR studio 5 help --> View help --> AVRISPmkII User Guide --> Troubleshooting --> Manual Firmware Upgrade.

    Hope this helps. If the issue still persists, Please get back to us with the following details:

    >> AVR Studio version you're using,

    >> Target device you're using with description of hardware connections

    >> Was the Firmware Upgrade successful, when you tried to upgrade it?

    >> Send us the snapshots of the error messages got when you try to communicate with the tool in AVR studio.

    Best Regards,
    Ineyaa N
    Atmel Technical Support Team

  4. #4
    Erfahrener Benutzer Begeisterter Techniker Avatar von Torrentula
    Registriert seit
    10.10.2009
    Ort
    Procyon A
    Alter
    21
    Beiträge
    355
    Der hat keinen Jumper. Das ist der, der über USB angesteuert wird.
    Ich habe den auch und als ich ein Frimware-Upgrade gemacht habe, musste ich den mkII aufmachen und direkt auf dem Board nen Jumper zwischen Pin 1 und 3 setzen. Danach einfach auf Start frimware upgrade und fertig. Einmal USB-Kabel raus und wieder rein und: Fertig!

    EDIT: Siehe Seite 28 im Handbuch
    MfG Torrentula

Ähnliche Themen

  1. Atmel USB ISP-Programmer MKII mächtig Probleme
    Von JollyJumper8 im Forum AVR Hardwarethemen
    Antworten: 13
    Letzter Beitrag: 03.10.2009, 15:24
  2. Bascom & AVRISP MKII Probleme (Keine Datenübertragung)
    Von abryx im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 02.07.2009, 21:02
  3. RP6 Upgrade
    Von Xtreme im Forum Robby RP6
    Antworten: 14
    Letzter Beitrag: 11.07.2008, 13:21
  4. AVRISP Programmer nach dem UPGRADE
    Von Serge im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 22.07.2007, 00:22
  5. Atmel Mega 8 / USB Firmware von Igor Cesko / Probleme
    Von cupid im Forum AVR Hardwarethemen
    Antworten: 6
    Letzter Beitrag: 02.06.2005, 20:53

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •