-         

Ergebnis 1 bis 6 von 6

Thema: "External routine not found [_HEX2HUM]" bei Verwendung von hexval

  1. #1
    Erfahrener Benutzer Roboter Genie Avatar von malthy
    Registriert seit
    19.04.2004
    Ort
    Oldenburg
    Beiträge
    1.379

    "External routine not found [_HEX2HUM]" bei Verwendung von hexval

    Anzeige

    Moin,

    ich habe ein mir undurchsichtiges Problem mit Bascom 2.0.7.2. Folgender Beispielcode ruft beim Compilieren einen Fehler hervor:

    Code:
    Dim S As String * 2
    
    Dim B As Byte
    
    S = "FF"
    
    B = Hexval(s)
    
    Print B
    Die Fehlermeldung lautet "Error : 211 Line: 12 External routine not found [_HEX2HUM]" Kann es tatsächlich sein, dass eine Lib fehlt? Fehler beim Updaten? Was kann ich tun, um das Problem weiter einzugrenzen?

    Vielen Dank für alle Tipps!
    Malte

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.02.2006
    Beiträge
    1.112
    Wenn das dein gesamtes Programm ist, dann sucht er die _Hex2Num in der MCS.lib.
    Schau mal unter Tools->Lib Manager ob die dort gelistet ist und wenn du sie auswählst, ob dann rechts die _Hex2Num erscheint.
    Hast du die Demo Version?

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von malthy
    Registriert seit
    19.04.2004
    Ort
    Oldenburg
    Beiträge
    1.379
    Hallo,

    Danke, for_ro! Es handelt sich um eine Bascom Vollversion, mcs.lib ist vorhanden und _hex2num auch unter Routines gelistet. Das gepostete Programm ist natürlich nur ein Fetzen zum Demonstrieren des Problems. Ich habe es eben unter 2.0.6.0 auf einem anderen Rechner compiliert, da funktionierte es...

    Könnte jemand so freundlich sein, den Schnipsel oben mal bei sich unter 2.0.7.2. zu compilieren um zu gucken, ob das nur ein Problem mit meiner Installation ist oder genereller Natur? Vielen Dank!

    Gruß!
    Malte

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    16.02.2006
    Beiträge
    1.112
    Sorry, hatte ich vergessen zu erwähnen: Bei mir compiliert er in der 2.0.7.2 ohne Fehler.

  5. #5
    Erfahrener Benutzer Roboter Genie Avatar von malthy
    Registriert seit
    19.04.2004
    Ort
    Oldenburg
    Beiträge
    1.379
    Okay, dann installiere ich einfach mal neu, vllt ist beim letzten Update was schiefgegangen. Danke!

  6. #6
    Erfahrener Benutzer Roboter Genie Avatar von malthy
    Registriert seit
    19.04.2004
    Ort
    Oldenburg
    Beiträge
    1.379
    Neuinstallation hat geholfen. Keine Ahnung was da los war... Malte.

Ähnliche Themen

  1. Bascom Bug "External routine not found [_ADDSIZETOFRAME]"
    Von Wombatz im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 03.10.2011, 19:55
  2. Fehlermeldung " Label not found [_printword]" in V
    Von Andree-HB im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 04.06.2010, 06:34
  3. "PCF 8574 P" Problem bei Verwendung als Input
    Von fitec im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 4
    Letzter Beitrag: 03.03.2009, 22:40
  4. BASCOM - "File not found" problem
    Von starwatcher im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 24.10.2005, 12:28
  5. Neue Bascomdemo V 1.11.7.7: "File not found"
    Von pewona im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 9
    Letzter Beitrag: 28.01.2005, 20:40

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •