-         

Ergebnis 1 bis 10 von 10

Thema: Neue Bascomdemo V 1.11.7.7: "File not found"

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    08.12.2004
    Ort
    Tübingen
    Alter
    51
    Beiträge
    17

    Neue Bascomdemo V 1.11.7.7: "File not found"

    Anzeige

    Ich will demnächst mit der Programmierung von RN Control mittels Bascom beginnen. An Weihnachten lud ich die Vorgängerversion von 1.11.7.7 herunter und machte einen Syntaxcheck eines Demoprogramms: ohne Probleme.
    Mit der neuen Demo kommt immer "File not found" und unten wird angezeigt, daß mehrere "LIB´s" fehlen. Hat dies vielleicht etwas mit der Bemerkung des Entwicklers "The last restriction on the DEMO is that it does not come with the LIB Assembler code.The LIB assem code only comes with the full version." zu tun?
    Da die neue Demo 4kb kann wäre diese schon besser. Hat hier jemand schon Erfahrungen gemacht oder eine Lösung? Für eine Antwort vielen Dank.

  2. #2
    -thomas.n-
    Gast
    Ich habe mir auch die neue Version geladen weil dort der ATtiny2313 unterstützt wird den ich verwnden möchte. Ein altes Programm, welches ich für den Mega16 geschrieben hatte, übersetzt er ohne Fehlermeldung. Dieses habe ich als Grundlage genommen und eingekürzt um erst mal eine LED mit dem Tiny zum blinken zu bringen aber jetzt übersetzt er es nicht mehr. Im Code findet er keine Fehler aber es kommt die Meldung "File not found". An der Zeile $regfile = "ATtiny2313.DAT" liegt es nicht denn wenn ich dort wieder den Mega16 eintrage macht er es trotzdem nicht. Bei mir meldet er aber auch keine fehlenden LIBs. Ist schon eigenartig dieser Fehler. Ich hoffe ich oder jemand anders kommt bald drauf woran das liegt.

    Gruß Thomas

  3. #3
    Ingo_05
    Gast
    Hi,

    ich habe dieses Problem auch. Ich habe den Quelltext abgespeichert und Bascom geschlossen. Dann habe ich ihn neu gestartet und das Programm erschien sofort wieder im Editor. Anschliueßend ließ es sich einwandfrei kompilieren. Soweit ich im Simulator (AVRStudio) sehen konnte, war alles korrekt.
    Anscheinend ist irgendein Pfad oder ähnliches nicht richtig gesetzt, solange Bascom nicht geschlossen wurde. Das passiert nur beim ersten Mal mit einem neuen Quellcode, nach späterem editieren und speichern kommt kein Fehler mehr.

    Gruß

    Ingo

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    08.12.2004
    Ort
    Tübingen
    Alter
    51
    Beiträge
    17
    Also der Fehler "File not found" erscheint beim Compilieren komischerweise jetzt nicht mehr.
    Leider meldet sich Bascom jetzt bei "run to programmer" damit , daß er das .bin file nicht findet. Ich habe festgestellt, daß im Ordner auch kein .bin erstellt wurde. (Es ist aber bei Optionen angekreuzt). Hat dieses Problem sonst noch jemand?

  5. #5
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    20.06.2004
    Beiträge
    1.941
    hallo, ich habe das orignalbascom vollversion und habe die neu version draufgespielt. ich stelle keine fehler fest. alle programme inklusive die des küchenbrettroboters mit puls,pwm,i2c laufen ohne fehler.
    mfg pebisoft

  6. #6
    Gast
    na dann muß ich (falls dies irgendwann mal vorkommt) bei größeren Programmen doch die Vollversion kaufen.

  7. #7
    Neuer Benutzer Öfters hier
    Registriert seit
    08.12.2004
    Ort
    Tübingen
    Alter
    51
    Beiträge
    17
    sorry, war nicht eingelockt

  8. #8
    Gast

    Nachtrag

    Hallo,

    jetzt hatte ich auch einen hartnäckugen Fall von "file not found", sogar, nachdem das Programm fertig kompiliert war. Abhilfe: Ich habe in den Compiler-Options unter output auch "bin-file" aktiviert, obwohl ich es nicht brauche. Seitdem gibt es keine Fehlermeldung mehr. Anscheinend muss immer ein .bin vorhanden sein...
    Zudem hat mindestens ein regfile, nämlich das vom 90S1200, einen Fehler, der ebenfalls zu Fehlermeldungen führt. Es gibt darin einen Parameter noTiny oder ähnlich, der falsch gesetzt ist. Wird der Chip hier als Tiny, also ohne internes RAM, markiert, kann man damit arbeiten.

    Gruß,

    Ingo

  9. #9
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    20.06.2004
    Beiträge
    1.941
    hallo, man kann in einem menue einstellen, welche dateien erzeugt werden sollen, "hex", "bin", "obj" usw. wenn Bascom die dateien in den chip lädt, fragt er immer nach "bin", darum sollte man beim erstellen das häkchen auch bei bin setzen.
    mfg pebisoft

  10. #10
    Neuer Benutzer Öfters hier
    Registriert seit
    08.12.2004
    Ort
    Tübingen
    Alter
    51
    Beiträge
    17
    Wenn die Programme bei der neuen Demo zu groß sind, erscheint beim compilieren unten keine Fehlermeldung mehr, lediglich "file not found" beim Übertragen. Beim RN control Testprogramm das ich deshalb immer mehr gekürzt habe um diesen Fehler wegzubekommen, habe ich festgestellt, daß bei "show compile result" in der letzten Zeile ein Fehler gemeldet wurde "single to small for string" o.ä. Deshalb wurde kein .bin erstellt obwohl die Datei kleiner 4kB war und beim Compilieren keine Fehlermeldung kam.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •