-
        

Ergebnis 1 bis 4 von 4

Thema: Probleme mit UART Kommunikation

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    16.04.2011
    Beiträge
    7

    Probleme mit UART Kommunikation

    Anzeige

    Hallo zusammen,

    Ich lese schon seit längerem hier im Forum und hab auch immer wieder Antworten gefunden, jetzt hab ich aber ein Problem für welches ich keine Lösung gefunden habe.

    Ich versuche jetzt seit längerem eine Kommunikation über UART hinzu bekommen.

    Meine Konfiguration sieht so aus:
    myAVR Board MK2
    Bascom AVR Demo

    Ich habe jetzt einen Programmcode aus dem Lehrbuch abgetippt:
    Code:
    $regfile = "m8def.dat"
    $crystal = 3686400
    $baud = 9600
    
    Dim Variable As Integer
    
    Do
       For Variable = 1 To 2000
          Print "Test"
          Print "A";
          Print "B"
          Print "Variableninhalt" ; Variable
          Print
       Next I
    Loop
    End
    Übertragen kann ich auch alles ohne Probleme.
    Der MK2 wird über COM3 mit einer Baudrate von 9600 angeschlossen, dieser Wert ist auch Bascom eingestellt und steht auch im Gerätemanager.

    Die Fuse-Bits des Controller stehen auf Externen Quarz:

    Klicke auf die Grafik für eine größere Ansicht

Name:	myAVR <a href=MK2 AVR910 Programmer_2011-08-28_17-10-28.png Hits: 3 Größe: 3,7 KB ID: 19817" class="thumbnail" style="float:CONFIG" />

    Wenn ich jetzt den Bascom Terminal öffne bekomme ich nichts angezeigt.
    Hab es schon mit AVR Terminal versucht, kann eine Verbindung herstellen, bekomme aber auch keine Reaktion vom µC.

    Jetzt meine Frage:
    Hab ich irgendwas falsch eingestellt oder vergessen zu aktivieren?

    Ich hoffe ihr habt einen Tipp

    Schon mal Danke für die Hilfe

    Gruß
    curzon161

  2. #2
    Moderator Robotik Einstein Avatar von Kampi
    Registriert seit
    21.11.2009
    Ort
    Monheim, Nordrhein-Westfalen, Germany
    Alter
    28
    Beiträge
    3.517
    Blog-Einträge
    9
    Haste Rx vom Pegelwandler mit Tx vom PC und Rx vom PC mit Tx vom Pegelwandler verbunden und auch GND angeschlossen?
    Und Rx vom Pegelwandler muss an Rx vom Controller. Für Tx dasselbe.

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    16.04.2011
    Beiträge
    7
    Es handelt sich um ein komplett aufgebautes Board:
    http://shop.myavr.de/Systemboards/my...p.php&artID=40

    Also geh ich davon aus das es Werksseitig schon so ist.
    Hab jetzt gerade gesehen das ich den USB-Adapter in UART Modus schalten muss.
    Werde mal versuchen ob ich das hinbekomme.

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    16.04.2011
    Beiträge
    7
    Ha das wars

    Muss mit einer extra Software noch den USB-Adapter in UART Modus schalten.
    Das hat eben nicht funktioniert, weil ich vergessen hatte in dem Extra Programm den COM-Port wieder einzuschalten.
    Der ist nämlich beim schließen des Programmes weg.

    Verdammt und so was kostet einen den Sonntag Nachmittag

    Danke für die Hilfe.

Ähnliche Themen

  1. Problem mit UART Kommunikation
    Von Testus2K im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 11
    Letzter Beitrag: 30.05.2011, 14:41
  2. Protokoll zur UART Kommunikation PC<->AVR
    Von Christoph2 im Forum C - Programmierung (GCC u.a.)
    Antworten: 4
    Letzter Beitrag: 25.06.2010, 17:56
  3. Kommunikation über UART - Problem
    Von filth im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 7
    Letzter Beitrag: 06.09.2009, 18:16
  4. µC Kommunikation via UART?
    Von Killer im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 24.12.2007, 03:22
  5. Uart-Kommunikation zwischen µCs
    Von ProgDom im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 2
    Letzter Beitrag: 20.04.2006, 01:37

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •