-
        

Ergebnis 1 bis 2 von 2

Thema: 644p lässt sich nicht Flashen

  1. #1
    Erfahrener Benutzer Roboter-Spezialist Avatar von MiniMax
    Registriert seit
    26.07.2007
    Ort
    Bremen
    Beiträge
    241

    Frage 644p lässt sich nicht Flashen

    Anzeige

    Hallo Zusammen,
    meine neuste Platine macht Probleme:
    Ich kann zwar die Lock und Fusebits auslesen und schreiben, den Chip löschen oder Identifizieren aber nicht Flashen!
    Als Controller kommt ein 644P zum einsatz, als Umgebung Bascom und als Programmer ein AVR USB Lab im AVRISP mkII Modus.
    Ich habe bereits versucht das ISP kabel zu kürzen - keine Veränderung! Ich hab bereits alles möglich versucht aber keinen Erfolg gehabt ! Habt ihr eine Lösung?
    Gruß
    MiniMax

  2. #2
    Erfahrener Benutzer Roboter-Spezialist Avatar von MiniMax
    Registriert seit
    26.07.2007
    Ort
    Bremen
    Beiträge
    241

    Frage

    So ich habe ihn jetzt mit der STK500V2 Firmware geflashed und es geht

    Aber nun die nächste Frage:

    Wenn ich den 644p Resette sendet er kurz über UART1 Daten und dann nicht mehr. Wenn ich ein Waitms 500 einfüge, sendet er es sogar nur einmal!

    Hier der Code:

    Code:
    $regfile = "m644pdef.dat"
    $crystal = 16000000
    '$baud = 9600                                                ' use baud rate
    '$baud1 = 9600
    $hwstack = 32                                               ' default use 32 for the hardware stack
    $swstack = 10                                               ' default use 10 for the SW stack
    $framesize = 40                                             ' default use 40 for the frame space
    
    Declare Sub Serial0charmatch()
    Declare Sub Serial1charmatch()
    
    Dim UART1in As String * 100 , UART2in As String * 100
    
    Config Com1 = 9600 , Synchrone = 0 , Parity = None , Stopbits = 1 , Databits = 8 , Clockpol = 0
    Config Com2 = 9600 , Synchrone = 0 , Parity = None , Stopbits = 1 , Databits = 8 , Clockpol = 0
    
    
    Config Serialin = Buffered , Size = 100 , Bytematch = 13
    Config Serialin1 = Buffered , Size = 100 , Bytematch = 13
    
    Open "COM1:" For Binary As #1
    Open "COM2:" For Binary As #2
    
    Enable Interrupts
    
     Print #1 , "Fertig"
    Do
    
     Print #1 , "HALLO"
      Waitms 500
    Loop
    
    
    Sub Serial0charmatch()
     Print #1 , "Bin da"
     Input #1 , UART1in Noecho
     Print #1 , UART1in
    
    End Sub
    
    Sub Serial1charmatch()
     Input #1 , UART2in Noecho
     Print #1 , UART2in
    End Sub
    
    
    
    
    
    
    Close #1
    Close #2
    
    End
    Hat einer eine Idee?
    Gruß
    MiniMax

Ähnliche Themen

  1. ASURO lässt sich nicht flashen
    Von wildtobias im Forum Asuro
    Antworten: 11
    Letzter Beitrag: 18.01.2011, 15:22
  2. AVR lässt sich nicht programmieren
    Von Janigut im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 8
    Letzter Beitrag: 20.11.2009, 18:50
  3. ATmega32 lässt sich nicht flashen
    Von Weja im Forum AVR Hardwarethemen
    Antworten: 3
    Letzter Beitrag: 08.10.2006, 16:27
  4. Hilfe! Asuro lässt sich nicht mehr Flashen
    Von Screader im Forum Asuro
    Antworten: 2
    Letzter Beitrag: 21.01.2006, 18:42
  5. UCSRC lässt sich nicht setzen
    Von FoCus im Forum C - Programmierung (GCC u.a.)
    Antworten: 4
    Letzter Beitrag: 25.08.2005, 19:56

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •