-
        

Ergebnis 1 bis 9 von 9

Thema: Atmega2561 fehler bei Programmübertragung

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2008
    Ort
    Pohlheim
    Alter
    27
    Beiträge
    240

    Atmega2561 fehler bei Programmübertragung

    Anzeige

    Hi zusammen,

    ich habe eine Steuerung unserer Heizung mit einem Atmega2561 realisiert. Wenn das Programm eine größe von 50% oder mehr erreicht, bekommt ich beim übertragen immer den Fehler "Diff. at 1FF00". Daraufhin funktionieren dann auch Teile des Programms nicht richtig

    Bin ich mit der Programmgröße unter 50% geht das ganze wie geschmiert...

    hat jemand eine Idee woran das liegen könnte?

    Gruß
    Felix
    Geändert von Felix H. (22.04.2011 um 19:17 Uhr)

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    17.09.2005
    Beiträge
    276
    Klingt so als ob falsche CPU eingestellt ist.
    Und sehr wenig input kommt rüber.
    Programmer ? usw....

    lg
    Gento

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2008
    Ort
    Pohlheim
    Alter
    27
    Beiträge
    240
    Hi,

    der passende Controller ist schon eingestellt. Wie gesagt es geht wenn ich unter 50% bleibe. Programmieren tue ich das ganze über das standard ISP Kabel über den Parallelport.

    Code:
    $regfile = "m2561def.dat"
    $crystal = 8000000
    $baud = 19200
    '$baud1 = 9600
    $hwstack = 200
    $swstack = 200
    $framesize = 200
    In den Fusebits finde ich folgendes verdächtig:

    Fusebit High KL: 00:Bootsize 4096 Words at $F000

    Wozu ist dieses Fusebit gut? Sollte man daran vllt. etwas verändern? Nicht das mir danach der Chip nichtmehr geht =P

    MfG

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    17.09.2005
    Beiträge
    276
    Wir kommen der Sache näher.
    Wie wird geflasht ?
    Per Bootloader ?

    Gento

  5. #5
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2008
    Ort
    Pohlheim
    Alter
    27
    Beiträge
    240
    Hi,

    nein Bootloader ist keiner drauf. Geflasht wird wie bereits erwähnt mit STK200/300 Programmierer. Sprich Parallel-port, 74HC244N, µC.

    Gruß

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2008
    Ort
    Pohlheim
    Alter
    27
    Beiträge
    240
    hat niemand eine idee? Ich bin hier echt am verzweifeln =(

    habe bereits den bootloaderbereich per Fusebits auf 512 Words reduziert. Der Fehler ist trotzdem immernoch an Adresse 1FF00 vorhanden...

  7. #7
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    18.05.2007
    Ort
    Berlin
    Alter
    46
    Beiträge
    765
    Wenn die neueste Version von Bascom schon vorhanden ist und auch unter Bascom geflasht wird, würde ich direkt mal im MCS Forum nachfragen, bzw nachschauen.
    Aber Respekt. Mir hat das flashen schon bei 16k mit Deiner Methode viel zu lange gedauert.
    Wenn das Herz involviert ist, steht die Logik außen vor! \/

  8. #8
    ich hab das selbe problem, habe aber rausgefunden woran es liegt.

    es ist ein bug in bascom, der sich auf so gut wie alle Programmer auswirkt.
    das veraendern des bootloaders bringt nicht wirklich viel.
    beim vergroessern des quellcodes gibt es manchmal das ergebniss das sich der fehlerpunkt um einige bytes nach hinten verschiebt. was man aber nicht umgehen kann

    denk ma da muessen wir auf ne neue version von Bascom warten

    => BUG IN BASCOM

  9. #9
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.02.2008
    Ort
    Pohlheim
    Alter
    27
    Beiträge
    240
    hm interessant... habe mir jetz einen AVRISP MK2 gekauft um das ganze mit AVR studio hochzuladen. Allerdings macht der Programmer nur Probleme und ich bin noch nicht weiter gekommen =( Muss morgen nochmal schauen was da los ist...

Ähnliche Themen

  1. ATMega2561 - Zerstörung
    Von Bääääär im Forum AVR Hardwarethemen
    Antworten: 11
    Letzter Beitrag: 12.04.2008, 15:41
  2. I2C mit 30x atmega8 und 1x atmega2561
    Von DeadDealer im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 3
    Letzter Beitrag: 16.06.2007, 08:54
  3. Programmübertragung Fehler
    Von noppf im Forum C - Programmierung (GCC u.a.)
    Antworten: 1
    Letzter Beitrag: 12.06.2007, 14:32
  4. Fehler bei der Programmübertragung
    Von ThomasKopsch im Forum Basic-Programmierung (Bascom-Compiler)
    Antworten: 18
    Letzter Beitrag: 15.04.2007, 11:43
  5. Programmübertragung mit ISP
    Von robo junior im Forum AVR Hardwarethemen
    Antworten: 2
    Letzter Beitrag: 18.02.2007, 19:40

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •