-
        

Ergebnis 1 bis 4 von 4

Thema: Problem mit linker options und tiny-asuro-Lib

  1. #1

    Frage Problem mit linker options und tiny-asuro-Lib

    Anzeige

    Hallo Forum!

    Mein Asuro ist fertig aufgebaut und getestet. Und nun wollte ich mich mit den ersten eigenen Programmen beschäftigen. Dazu habe ich mir die Tiny-ASURO Library von markus-j runtergeladen. Und zunächst einmal die examples probiert. So weit, so gut.

    Dann habe ich die examples in ein anderes Verzeichnis kopiert. Und seit dem gibt es eine Fehlermeldung, die ich nicht wirklich verstehe.

    Code:
    Linking: main.elf
    avr-gcc -mmcu=atmega8 -I. -gdwarf-2 -g2 -DF_CPU=8000000UL -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -ffunction-sections -fdata-sections -W -Wall -Wextra -Winit-self  -Wno-main  -Wstrict-prototypes -Wundef -Wunreachable-code -msize -Wa,-adhlns=main.o -I. -I../.. -std=gnu99 -MMD -MP -MF .dep/main.elf.d main.o selftest.o --output main.elf -Wl,-Map=main.map,--cref  -L../..   -lm -ltinyasuro -Wl,--gc-sections,--relax -Os
    c:/winavr-20100110/bin/../lib/gcc/avr/4.3.3/../../../../avr/bin/ld.exe: cannot find -ltinyasuro
    make.exe: *** [main.elf] Error 1
    Wohl ein Problem mit dem Linker, richtig? Den Eintrag -ltinyasuro habe ich unter den linker options im makefile gefunden. Und ein nicht richtig gesetzter Pfad? Ich habe aber die gleiche Pfadstruktur wie bei den examples verwendet. Und auch mit den Pfadangaben im makefile probiert. Aber ohne Erfolg.

    Was mach ich falsch? bzw. wo muss ich die Pfadangabe anpassen? Die Dokumentation vom GCC hat mir leider auch nicht weitergeholfen.

    Vielen Dank schon einmal.

    mfg

    Bot-Builder
    Legasteniker on Board!
    gefundene Rechtschreibfehler dienen der Belustigung des Lesers und dürfen von diesem behalten werden.

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Hey Bot-Builder,

    im Makefile gibt es eine Zeile "TINYASURODIR = ../.."
    damit wird auf das Hauptverzeichnis (in dem auch der Ordner examples liegt) verwiesen. Genau hier sollte auch die libtinyasuro.a liegen.
    Wenn dein eigenes Projekt jetzt nicht zwei Verzeichnisse unterhalb der Tiny ASURO Library liegt, kannst du diese Variable entsprechend anpassen, damit sie auf das Verzeichnis verweist, in dem die libtinyasuro.a und die Unterordner "asuro" und "util" mit den zugehörigen Headerfiles liegen.

    Nachtrag: Vielleicht kannst du mir einen Tipp geben, wie ich den Abschnitt "Makefiles" in der Dokumentation so umschreiben kann, dass diese Information besser verständlich wird. Danke.

    mfG
    Markus
    Geändert von markusj (31.03.2011 um 23:14 Uhr)

  3. #3
    Zitat Zitat von markusj Beitrag anzeigen
    ... im Makefile gibt es eine Zeile "TINYASURODIR = ../.."
    ...
    ... Genau hier sollte auch die libtinyasuro.a liegen.
    ...
    ... in dem die libtinyasuro.a und die Unterordner "asuro" und "util" mit den zugehörigen Headerfiles liegen.
    Dann war ich schon auf dem richtigen Weg.

    Den Pfad "TINYASURODIR = ../.." habe ich angepasst. Bzw. als das nicht funktioniert hat, die gleich Pfadstruktur verwendet.

    Übersehen habe ich aber, dass auch die libtinyasuro.a mitkopiert werden muss. Ich habe nur die Verzeichnisse "asuro", "util" und "examples" kopiert.

    Jetzt mit der kopiert libtinyasuro.a läuft der Buildvorgang einwandfrei.

    Nur weil Du gefragt hast. Ich habe mich an die Beschreibung "Einbinden der Bibliothek" gleich auf der ersten Seite der Doku gehalten. Nur ist da nur von den Ordnern "asuro" und "util" die Rede. Vielleicht könnte man einen Hinweise auf die libtinyasuro.a mit aufnehmen.

    Die Lib macht einen sehr guten Eindruck. Der Aufbau viel übersichtlicher als die der originalen Lib.

    Und falls ich noch an anderen Stellen hängen bleibe, melde ich mich einfach.

    Vielen Dank für Deine Hilfe.


    mfg

    Uwe
    Legasteniker on Board!
    gefundene Rechtschreibfehler dienen der Belustigung des Lesers und dürfen von diesem behalten werden.

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    20.08.2008
    Ort
    Kandel
    Alter
    29
    Beiträge
    1.220
    Zitat Zitat von Bot-Builder Beitrag anzeigen
    Nur weil Du gefragt hast. Ich habe mich an die Beschreibung "Einbinden der Bibliothek" gleich auf der ersten Seite der Doku gehalten. Nur ist da nur von den Ordnern "asuro" und "util" die Rede. Vielleicht könnte man einen Hinweise auf die libtinyasuro.a mit aufnehmen.

    Die Lib macht einen sehr guten Eindruck. Der Aufbau viel übersichtlicher als die der originalen Lib.
    Hallo Uwe,

    danke für den Hinweis, ich baue in die Doku einen entsprechenden Hinweis ein, beim nächsten Release ist das dann dabei.
    Und Danke für das Lob

    mfG
    Markus

Ähnliche Themen

  1. Antworten: 12
    Letzter Beitrag: 11.02.2014, 01:06
  2. Problem mit -o0 - Linker Fehler [gelöst]
    Von maxv im Forum C - Programmierung (GCC u.a.)
    Antworten: 2
    Letzter Beitrag: 24.05.2009, 17:21
  3. Linker motor Problem
    Von AcaAca im Forum Asuro
    Antworten: 8
    Letzter Beitrag: 28.09.2008, 21:22
  4. Asuro: Linker Motor dreht dauerhaft, rechter korrekt
    Von vbprogrammierer im Forum Asuro
    Antworten: 12
    Letzter Beitrag: 07.09.2005, 08:42
  5. Linker Motor läuft nicht (Asuro)
    Von honkitonk im Forum Asuro
    Antworten: 9
    Letzter Beitrag: 31.08.2005, 21:34

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •