-         

Ergebnis 1 bis 4 von 4

Thema: Atmega48 läuft mit 1Mhz statt 8Mhz

  1. #1
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    17.09.2004
    Alter
    32
    Beiträge
    647

    Atmega48 läuft mit 1Mhz statt 8Mhz

    Anzeige

    Hi,

    ich habe einen Atmega48. Dieser soll mit dem Internen Quarz/Osci mit 8Mhz laufen.

    Ich habe ihn mit diesem Programm gefüttert:
    Code:
    $regfile = "m48def.dat"
    $crystal = 8000000
    $baud = 9600
    
    Config Timer1 = Pwm , Pwm = 8 , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down , Prescale = 8
    Config Timer2 = Pwm , Pwm = On , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down , Prescale = 8
    
    Weiss Alias Pwm1a
    Rot Alias Pwm1b
    Gruen Alias Pwm2a
    Blau Alias Pwm2b
    
    Do
    
    Rot = 1
    Waitms 1000
    Rot = 0
    Gruen = 1
    Waitms 1000
    Gruen = 0
    Blau = 1
    Waitms 1000
    Blau = 0
    Weiss = 1
    Waitms 1000
    Weiss = 0
    
    Loop
    
    End
    Die Led´s leuchten 8 Sekunden! Sie sollten aber eigentlich nur 1 Sekunde leuchten. Daraus schliesse ich jetzt, das er nur auf 1Mhz läuft.

    Wie kriege ich den jetzt auf 8Mhz?

    Die Fuses sehen im Moment so aus wie im Anhang.

    Danke
    Gruß Daniel

    PS: Das ist nicht mein erstes Projekt, ich habe schon deutlich kompliziertere Sachen verwirklicht. Nur irgendwie will der Atmega48 nicht so wie ich will. Mit nem Atmega8 hatte ich keine Probleme.
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken fuses.png  
    Unser Sommer ist ein grün angestrichener Winter. Das einzige reife Obst, das wir haben, sind gebratene Äpfel. [Heinrich Heine]

  2. #2
    Neuer Benutzer Avatar von bussard
    Registriert seit
    03.09.2008
    Ort
    BRB
    Beiträge
    1
    Ab Werk laufen sie mit eingeschaltetem Teiler /8, also 1MHz. Also ENTWEDER die Fuses ändern oder (wenn du den schnelleren Takt nicht für dein eigentliches Projekt brauchst)
    $crystal = 8000000 auf $crystal = 1000000 setzen.

    Viel Erfolg

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von Searcher
    Registriert seit
    07.06.2009
    Ort
    NRW
    Beiträge
    1.410
    Blog-Einträge
    101
    Hi,
    CKDIV8 Fuse uncheck. Dann sollte er mit 8MHz laufen.

    Gruß
    Searcher
    Hoffentlich liegt das Ziel auch am Weg
    ..................................................................Der Weg zu einigen meiner Konstruktionen

  4. #4
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    17.09.2004
    Alter
    32
    Beiträge
    647
    @bussard: Die Idee hatte ich auch schon, aber leider brauche ich die 8Mhz.

    @Searcher: Perfekt!

    Jetzt läuft er auf 8Mhz.

    Ich danke euch beiden!
    Gruß Daniel
    Unser Sommer ist ein grün angestrichener Winter. Das einzige reife Obst, das wir haben, sind gebratene Äpfel. [Heinrich Heine]

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •