-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: rp6 loader probleme

  1. #1
    Benutzer Stammmitglied
    Registriert seit
    20.01.2011
    Beiträge
    36

    rp6 loader probleme

    Anzeige

    gestern habe ich mir nun den RP6 zugelegt und habe mich drauf gefreut loszulegen, doch daraus wurde nichts
    Bei der einen .exe fehlt eine dll, da ich gelesen hatt, das man die andere ausprobieren soll habe ich es mit der weiter gemacht, weil dort weniger fehlermeldungen kamen.
    Nachdem ich ein wenig gegooglet hatte und ein paar Beiträge von SlyD im arexx forum gelesen hatte habe ich die Windows standart lib auf BootLoader.useNativeLib.windows=RXTX geändert.
    Jetzt habe ich einen anderen fehler:
    Falsche ID empfangen
    auch schon gegoogelt/forensuche aber da habe ich bisher nur gefunden das ich das Kabel neu anstecken soll und das habe ich schon gemacht.

    Ach ja, ich habe win 7 professional 64bit
    und wenn ich den Loader nach dem Fehler schließen will stürzt er ab
    log:
    Code:
    RP6Loader log file
    
    SystemLogger started at: Thu Feb 24 13:11:54 CET 2011 (1298549514869)
    JVM System Information:
    
    java.runtime.name	=	Java(TM) SE Runtime Environment
    sun.boot.library.path	=	C:\Program Files (x86)\Java\jre6\bin
    java.vm.version	=	19.1-b02
    java.vm.vendor	=	Sun Microsystems Inc.
    java.vendor.url	=	http://java.sun.com/
    path.separator	=	;
    java.vm.name	=	Java HotSpot(TM) Client VM
    file.encoding.pkg	=	sun.io
    sun.java.launcher	=	SUN_STANDARD
    user.country	=	DE
    sun.os.patch.level	=	
    java.vm.specification.name	=	Java Virtual Machine Specification
    user.dir	=	C:\Users\Peter\Desktop\RP6Loader_20080328
    java.runtime.version	=	1.6.0_24-b07
    java.awt.graphicsenv	=	sun.awt.Win32GraphicsEnvironment
    java.endorsed.dirs	=	C:\Program Files (x86)\Java\jre6\lib\endorsed
    os.arch	=	x86
    java.io.tmpdir	=	C:\Users\Peter\AppData\Local\Temp\
    line.separator	=	
    
    java.vm.specification.vendor	=	Sun Microsystems Inc.
    user.variant	=	
    os.name	=	Windows 7
    sun.jnu.encoding	=	Cp1252
    java.library.path	=	.;.\lib
    java.specification.name	=	Java Platform API Specification
    java.class.version	=	50.0
    sun.management.compiler	=	HotSpot Client Compiler
    os.version	=	6.1
    user.home	=	C:\Users\Peter
    user.timezone	=	Europe/Berlin
    java.awt.printerjob	=	sun.awt.windows.WPrinterJob
    file.encoding	=	Cp1252
    java.specification.version	=	1.6
    java.class.path	=	RP6Loader_lib.jar;lib\jd2xx.jar;lib\RXTXcomm.jar;lib\comm.jar
    user.name	=	Peter
    java.vm.specification.version	=	1.0
    java.home	=	C:\Program Files (x86)\Java\jre6
    sun.arch.data.model	=	32
    user.language	=	de
    java.specification.vendor	=	Sun Microsystems Inc.
    awt.toolkit	=	sun.awt.windows.WToolkit
    java.vm.info	=	mixed mode, sharing
    java.version	=	1.6.0_24
    java.ext.dirs	=	C:\Program Files (x86)\Java\jre6\lib\ext;C:\Windows\Sun\Java\lib\ext
    sun.boot.class.path	=	C:\Program Files (x86)\Java\jre6\lib\resources.jar;C:\Program Files (x86)\Java\jre6\lib\rt.jar;C:\Program Files (x86)\Java\jre6\lib\sunrsasign.jar;C:\Program Files (x86)\Java\jre6\lib\jsse.jar;C:\Program Files (x86)\Java\jre6\lib\jce.jar;C:\Program Files (x86)\Java\jre6\lib\charsets.jar;C:\Program Files (x86)\Java\jre6\lib\modules\jdk.boot.jar;C:\Program Files (x86)\Java\jre6\classes
    java.vendor	=	Sun Microsystems Inc.
    file.separator	=	\
    java.vendor.url.bug	=	http://java.sun.com/cgi-bin/bugreport.cgi
    sun.io.unicode.encoding	=	UnicodeLittle
    sun.cpu.endian	=	little
    sun.desktop	=	windows
    sun.cpu.isalist	=	pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86
    
    
    JVM Memory Information:
    Free: 14633112 (14290 Kb)
    Max: 259522560 (253440 Kb)
    Total: 16252928 (15872 Kb)
    
    
    Initializing...
    RP6Loader Version: 1.4c
    Last build: 28.03.2008
    Loading Configuration...
    Done!
    Global->loadLocalizedText
    Loading Board Library...
    Done!
    OS:WIN
    Initializing native communication library: RXTX
    Stable Library
    =========================================
    Native lib Version = RXTX-2.1-7
    Java lib Version   = RXTX-2.1-7
    TERMINAL: RP6Loader Terminal
    TERMINAL:  - type ".help" for command list!
    Loading File List...
    Done!
    Global->Enabling log panel...
    RP6 Loader is ready to go.
    Message (Thu Feb 24 13:11:59 CET 2011) : RP6Main.actionPerformed: CONNECT
    Trying to open port: COM5
    Portlist: COM3, owned by: null, type: 1
    Portlist: COM5, owned by: null, type: 1
    COM5 open @38400-8n1
    Baudrate is set to: 38400
    Try to get ID...
    TERMINAL: 
    [RP6BOOT]
    
    Bootloader active "[RP6BOOT]"
    Connected to target!
    Target ID received:
    
    [RP Board ID 54, Firmware Version 66.79, Board Rev.: 79
    FEHLER (2)  ||| Falsche ID empfangen!
    Kommunikationsproblem!
    Bitte lesen Sie in der Bedienungsanleitung unter "Fehlerbehandlung" nach!
    Setup High Speed...
    TERMINAL: ]
    
    [READY]
    
    
    TERMINAL: [RP6BOOT]
    
    TERMINAL: 
    [READY]
    
    Message (Thu Feb 24 13:13:39 CET 2011) : RP6Main.actionPerformed: CONNECT
    Baudrate is set to: 38400
    Try to get ID...
    TERMINAL: 
    [RP6BOOT]
    
    Bootloader active "[RP6BOOT]"
    Connected to target!
    Target ID received:
    
    [RP Board ID 54, Firmware Version 66.79, Board Rev.: 79
    FEHLER (2)  ||| Falsche ID empfangen!
    Kommunikationsproblem!
    Bitte lesen Sie in der Bedienungsanleitung unter "Fehlerbehandlung" nach!
    Setup High Speed...
    TERMINAL: ]
    
    
    TERMINAL: [RP6BOOT]
    
    TERMINAL: 
    [READY]
    
    Message (Thu Feb 24 13:13:50 CET 2011) : RP6Main.actionPerformed: CONNECT
    Baudrate is set to: 38400
    Try to get ID...
    TERMINAL: 
    [RP6BOOT]
    
    Bootloader active "[RP6BOOT]"
    Connected to target!
    Target ID received:
    
    [RP Board ID 54, Firmware Version 66.79, Board Rev.: 79
    FEHLER (2)  ||| Falsche ID empfangen!
    Kommunikationsproblem!
    Bitte lesen Sie in der Bedienungsanleitung unter "Fehlerbehandlung" nach!
    Setup High Speed...
    TERMINAL: ]
    
    [READY]
    
    
    TERMINAL: [RP6BOOT]
    
    Message (Thu Feb 24 13:20:47 CET 2011) : RP6LoaderGUI.windowClosing: WINDOW_CLOSING,opposite=null,oldState=0,newState=0
    Saving File List...
    Done!
    Saving configuration...
    Done!
    
    JVM Memory Information:
    Free: 9681112 (9454 Kb)
    Max: 259522560 (253440 Kb)
    Total: 16252928 (15872 Kb)
    
    Comport: Try to close...
    Attempting to close port: COM5
    Edit: admin-rechte ändern auch nichts

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    13.03.2010
    Ort
    Hamburg
    Beiträge
    333
    Herzlich Willkommen im Roboternetz und Glückwunsch zu deinem Rp6

    Ich weiß nicht ob es bei deinem Problem Hilft aber, Dirk hat mal eine Funktionierende Anleitung geschrieben wie die gesammte Software unter Windows 7 64Bit Installiert wird.
    So Funktionierte das bei mir auch.

    Windows 7 64Bit Software Installation:
    http://www.roboternetz.de/phpBB2/zei...=windows+64bit

    Ich hoffe das hilft dir Gruß Alex

  3. #3
    Benutzer Stammmitglied
    Registriert seit
    20.01.2011
    Beiträge
    36
    ich habe alles deinstalliert und dann nach der Anleitung installiert, hat aber nichts geändert

  4. #4
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    13.03.2010
    Ort
    Hamburg
    Beiträge
    333
    Schade das es nicht geht.
    Hast du den Installer von der CD genommen?
    Wenn ja kannst du dir ja mal die Datein von Arexx Runterladen
    http://arexx.com/rp6/html/de/software.htm
    Sonst kannst du nochmal den Kompatibilitätsmodus testen und das Programm Als Windows Xp oder so ausführen.
    Eine idee wäre noch mal nachzusehen ob du die richtige java version hast

    Gruß Alex

  5. #5
    Benutzer Stammmitglied
    Registriert seit
    20.01.2011
    Beiträge
    36
    na klasse, ich habe gerade das kabel durchgemessen, wurde falsch gelötet -.-
    glaub ich zumindest, so sollte es doch nicht sein, oder?:

  6. #6
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    13.03.2010
    Ort
    Hamburg
    Beiträge
    333
    Soweit ich weiß nicht *lol*
    Das ist doch ein 1 zu 1 Kabel :O

  7. #7
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.781
    Blog-Einträge
    8
    Hallo

    Das gekreuzte Flachkabel ist richtig!

    http://www.roboternetz.de/phpBB2/vie...=540129#540129

    Ich habe auf meinem 64-Bit Win7 mit AMD X4 das 32-Bit-Java SDK installiert:

    http://www.roboternetz.de/phpBB2/zei...=531852#531852
    http://www.roboternetz.de/phpBB2/zei...=518368#518368

    Alle Dateien hatte ich bei meiner Neuinstallation direkt von den HPs der Anbieter (Java, WinAVR, Loader) runtergeladen, also nichts von der CD.

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

  8. #8
    Benutzer Stammmitglied
    Registriert seit
    20.01.2011
    Beiträge
    36
    jetzt hab ich beide JREs drauf, funktioniert immernoch nicht -.-
    jm ne idee?

  9. #9
    RN-Premium User Roboter-Spezialist
    Registriert seit
    21.04.2009
    Beiträge
    522
    Bei mir gabs unter Win7 x64 am Anfang auch Probleme mit dem Loader, hab sie aber irgendwie gelöst bekommen...
    Grade Java zickt da gerne schonmal rum...

    Als Alternative kann ich dir meinen eigenen Loader vorschlagen, den kannst du auf jeden Fall benutzen, bis der Richtige klappt.
    Ist zwar nur über die Kommandozeile bedienbar, aber das sollte erst mal reichen.
    Falls es dich interessiert, der Link ist in meiner Signatur

    (Ich hoffe ihr verzeiht mir meine Eigenwerbung )

  10. #10
    Moderator Robotik Visionär Avatar von radbruch
    Registriert seit
    27.12.2006
    Ort
    Stuttgart
    Alter
    54
    Beiträge
    5.781
    Blog-Einträge
    8
    Hallo

    Infos zur benötigten Version: http://www.java.com/de/download/faq/java_win64bit.xml
    Installierte Version: http://www.java.com/de/download/help/testvm.xml
    Test der Installation: http://www.java.com/de/download/installed.jsp

    Bei mir wird unter Architektur x86 angezeigt.

    Code:
    RobotLoader log file
    
    SystemLogger started at: Fri Feb 25 00:34:14 CET 2011 (1298590454978)
    JVM System Information:
    
    java.runtime.name	=	Java(TM) SE Runtime Environment
    sun.boot.library.path	=	D:\java\jre6\bin
    java.vm.version	=	19.1-b02
    java.vm.vendor	=	Sun Microsystems Inc.
    java.vendor.url	=	http://java.sun.com/
    path.separator	=	;
    java.vm.name	=	Java HotSpot(TM) Client VM
    file.encoding.pkg	=	sun.io
    sun.java.launcher	=	SUN_STANDARD
    user.country	=	DE
    sun.os.patch.level	=	
    java.vm.specification.name	=	Java Virtual Machine Specification
    user.dir	=	D:\_arm\RobotLoader_20100629
    java.runtime.version	=	1.6.0_24-b07
    java.awt.graphicsenv	=	sun.awt.Win32GraphicsEnvironment
    java.endorsed.dirs	=	D:\java\jre6\lib\endorsed
    os.arch	=	x86
    java.io.tmpdir	=	C:\Users\mic\AppData\Local\Temp\
    line.separator	=	
    
    java.vm.specification.vendor	=	Sun Microsystems Inc.
    user.variant	=	
    os.name	=	Windows 7
    sun.jnu.encoding	=	Cp1252
    java.library.path	=	.;.\lib
    java.specification.name	=	Java Platform API Specification
    java.class.version	=	50.0
    sun.management.compiler	=	HotSpot Client Compiler
    os.version	=	6.1
    user.home	=	C:\Users\mic
    user.timezone	=	Europe/Berlin
    java.awt.printerjob	=	sun.awt.windows.WPrinterJob
    file.encoding	=	Cp1252
    java.specification.version	=	1.6
    java.class.path	=	RobotLoader_lib.jar;lib\jd2xx.jar;lib\RXTXcomm.jar;lib\comm.jar
    user.name	=	mic
    java.vm.specification.version	=	1.0
    java.home	=	D:\java\jre6
    sun.arch.data.model	=	32
    user.language	=	de
    java.specification.vendor	=	Sun Microsystems Inc.
    awt.toolkit	=	sun.awt.windows.WToolkit
    java.vm.info	=	mixed mode, sharing
    java.version	=	1.6.0_24
    java.ext.dirs	=	D:\java\jre6\lib\ext;C:\Windows\Sun\Java\lib\ext
    sun.boot.class.path	=	D:\java\jre6\lib\resources.jar;D:\java\jre6\lib\rt.jar;D:\java\jre6\lib\sunrsasign.jar;D:\java\jre6\lib\jsse.jar;D:\java\jre6\lib\jce.jar;D:\java\jre6\lib\charsets.jar;D:\java\jre6\lib\modules\jdk.boot.jar;D:\java\jre6\classes
    java.vendor	=	Sun Microsystems Inc.
    file.separator	=	\
    java.vendor.url.bug	=	http://java.sun.com/cgi-bin/bugreport.cgi
    sun.io.unicode.encoding	=	UnicodeLittle
    sun.cpu.endian	=	little
    sun.desktop	=	windows
    sun.cpu.isalist	=	
    
    
    JVM Memory Information:
    Free: 14748024 (14402 Kb)
    Max: 259522560 (253440 Kb)
    Total: 16252928 (15872 Kb)
    
    
    Initializing...
    RobotLoader Version: 1.5f
    Last build: 09.06.2010
    Loading Configuration...
    Done!
    Global->loadLocalizedText
    Loading Board Library...
    Done!
    OS:WIN
    Initializing native communication library: JD2XX
    TERMINAL: RobotLoader Terminal
    TERMINAL:  - type ".help" for command list!
    Loading File List...
    Done!
    Global->Enabling log panel...
    RobotLoader is ready to go.
    Message (Fri Feb 25 00:34:29 CET 2011) : RP6Main.actionPerformed: CONNECT
    Trying to open port: USB0 | RP6 USB Interface | ARPVK74J
    Portlist: USB0 | RP6 USB Interface | ARPVK74J
    USB0 | RP6 USB Interface | ARPVK74J open @38400baud
    Device info:  --> Desc: RP6 USB Interface
    Device info:  --> ID: 67330049
    Baudrate is set to: 38400
    Try to get ID...
    TERMINAL: 
    [RP6BOOT]
    
    Bootloader active "[RP6BOOT]"
    Connected to target!
    Target ID received:
    RP6: Board ID 1, Firmware Version 1.4, Board Rev.: 5
    ["RP6 Robot Base", 1, MEGA32, 0, 30720, true]
    Board Memory: 0 to 30720 
    Board with Battery Sensor --> Reading Battery voltage...
    Voltage read: 7.27V
    Battery Voltage is in acceptable range.
    TERMINAL: 
    [READY]
    
    Message (Fri Feb 25 00:34:36 CET 2011) : RP6Main.actionPerformed: CLOSE
    Trying to close port...
    Port Closed!
    Message (Fri Feb 25 00:34:39 CET 2011) : RP6LoaderGUI.windowClosing: WINDOW_CLOSING,opposite=null,oldState=0,newState=0
    Saving File List...
    Done!
    Saving configuration...
    Done!
    
    JVM Memory Information:
    Free: 9776384 (9547 Kb)
    Max: 259522560 (253440 Kb)
    Total: 16252928 (15872 Kb)
    
    Trying to close port...
    Program terminated! (1298590479579)
    Ich verwende übrigens Version 1.5f des Loaders. Diese Version erkennt auch die IDs von cat und arm.

    Ist doch keine Eigenwerbung sondern ein Tool ;)

    Gruß

    mic

    Atmel’s products are not intended, authorized, or warranted for use
    as components in applications intended to support or sustain life!

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •