-         

Ergebnis 1 bis 3 von 3

Thema: RP6Loader hat Probleme mit 64 Bit Linux?

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    07.05.2010
    Beiträge
    5

    RP6Loader hat Probleme mit 64 Bit Linux?

    Anzeige

    Hi,
    vielleicht erst mal ein paar kurze Worte zu mir.
    Ich hatte vor etwa einem Jahr versucht einen Asuro zusammen zu bauen und hab das Teil auch so weit hinbekommen, dass er das Testprogramm ablaufen lässt.
    Leider musste ich feststellen, dass meine Lötfähigkeiten nicht so toll sind und die IR-Übertragung nicht funktionierte. Nach einigen Versuchen hatte ich dann aufgegeben und der Asuro ist erst mal in einer Kiste verschwunden. (Wenn ich besser weiß, was ich eigentlich tue kommt er auch wieder raus)

    Zu Weihnachten 2010 gab es dann einen RP6 mit dem ich bisher noch relativ wenig gemacht habe, weil mir einfach die Zeit gefehlt hat.
    Aber nun da die Vorlesungsfreie Zeit begonnen hat will ich ganz von vorne anfangen.

    Und damit kommen wir zu meinem Problem
    Ich nutze hauptsächlich Linux als Betriebssystem. Und bei einem 32 Bit Ubuntu funktioniert der RP6Loader (1.4c) auch ohne Probleme.

    Wenn ich nun aber auf meinem Laptop (64 Bit Ubuntu) arbeiten will, dann bekomme ich beim starten des Loaders über ein Terminal mit
    java -jar RP6Loader_lib.jar
    folgende Meldung:
    Code:
    java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver
    Exception in thread "main" java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path
    	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1681)
    	at java.lang.Runtime.loadLibrary0(Runtime.java:840)
    	at java.lang.System.loadLibrary(System.java:1047)
    	at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
    	at cls.ac.c(Unknown Source)
    	at cls.E.d(Unknown Source)
    	at cls.E.<init>(Unknown Source)
    	at cls.aq.<init>(Unknown Source)
    	at de.dsh.rp6loader.Init.<init>(Unknown Source)
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
    	at java.lang.Class.newInstance0(Class.java:372)
    	at java.lang.Class.newInstance(Class.java:325)
    	at de.dsh.rp6loader.Init.main(Unknown Source)
    Kennt jemand das Problem? Hat das was mit dem 64 Bit System oder mit dem Laptop zu tun?
    Ich bin da leider etwas ratlos.

    gruß Flo

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von SlyD
    Registriert seit
    27.11.2003
    Ort
    Paderborn
    Alter
    32
    Beiträge
    1.514
    > java -jar RP6Loader_lib.jar

    Das kann nicht gehen dann findet Java die nativen Libs nicht.
    Nimm das Skript das mit dabei ist.

    Besser auch direkt die ganz aktuelle Version nehmen und nochmal testen:

    http://www.arexx.com/forum/viewtopic.php?f=19&t=1114


    MfG,
    SlyD

  3. #3
    Neuer Benutzer Öfters hier
    Registriert seit
    07.05.2010
    Beiträge
    5
    Hi,
    ja dass java -jar RP6Loader_lib.jar nicht geht hatte ich dann auch noch gemerkt.
    Sorry für den sinnlosen Beitrag.
    Na wenigstens hab ich jetzt auch die aktuellste Version vom Loader und dafür auf jeden Fall danke.

    Funktioniert alles super.

    Ich hatte hier nach dem Loader gesucht:
    http://www.arexx.com/rp6/html/de/software.htm
    und da ist halt der 1.4c der aktuellste.

    gruß Flo

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •