-         

Ergebnis 1 bis 5 von 5

Thema: Rechtecktakt aus XO91 Oszillator?

  1. #1
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    09.11.2005
    Ort
    Ichtershausen
    Alter
    48
    Beiträge
    148

    Rechtecktakt aus XO91 Oszillator?

    Anzeige

    Hallo zusammen.

    Ich hab eine Problem mit einem XO91 Oszillator.
    http://www.produktinfo.conrad.com/da..._16_000MHZ.pdf
    Dieser sollte lauf Datenblatt CMOS/TTL-kompatibel sein. Ich wähnte mich sicher in dem irrigen Glauben, dass er da auch am Ausgang einen sauberen Rechteck liefert. Leider bringt er am Ausgang nur einen Sinus zwischen 0,6V und 2,7V. Damit kommt aber mein TMC457 Schrittmotortreiber von Trinamic nicht klar. Jetzt Suche ich nach einer einfachen Lösung, die ohne viel Zusatzaufwand das daraus ein gescheites Rechtecksignal mit 3.3V kompatiblen Pegeln macht. Hat jemand ne Idee?

  2. #2
    Erfahrener Benutzer Robotik Einstein
    Registriert seit
    27.08.2004
    Ort
    Kreis Starnberg
    Alter
    52
    Beiträge
    1.819
    Leider bringt er am Ausgang nur einen Sinus zwischen 0,6V und 2,7V.
    Laut Datenblatt sollte er besser sein (bei Betrieb mit 3,3V), zumindest solange die Last am Ausgang in der Spezifikation bleibt (15 pF sind nicht viel, das kann man mit einem suboptimalen Platinenlayout schnell zusammen haben). Dabei muss man natürlich auch die Last durch die Messung beachten und die Bandbreite des Messinstruments (Rechteck-Sinus). Rein von den Angaben in den Datenblättern sollte die Kombination eigentlich passen (Alle nötigen Angaben habe ich noch nicht gefunden). Vielleicht kann man mal probehalber ein zusätzliches Gatter dazwischenhängen, als Buffer/Treiber.
    Wenn ich das Datenblatt vom Oszillator richtig verstehe ist auch eine Version verfügbar, die wenigstens 50pF treibt, das klingt nach einem besseren Sicherheitsabstand.

  3. #3
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    09.11.2005
    Ort
    Ichtershausen
    Alter
    48
    Beiträge
    148
    15 pF sind nicht viel, das kann man mit einem suboptimalen Platinenlayout schnell zusammen haben
    Vom Ausgang geht eine etwa 10mm lange Leitung direkt zum IC. Sollte also keine Probleme machen.

    Vielleicht kann man mal probehalber ein zusätzliches Gatter dazwischenhängen, als Buffer/Treiber.
    Ich habe schon ein Gatter von einem CD40106 (inv. Schmitt-Trigger) dazwischen gehangen. Leider ohne Erfolg. Der scheint bei 3,3V nicht mehr sauber zu arbeiten obwohl er bis 3V spezifiziert ist. Vielleicht ist auch die Frequenz mit 16MHz zu hoch.

    Wenn ich nicht alle seriellen Schnittstellen an meinem Xmega-Controller in beschlag genommen hätte, dann hätte ich ja einen CLKOut vom Prozessor genommen. Leider liegen die CLKOut Ausgänge beim XMega128 auf den RxD Pins.

  4. #4
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    Der CD 40106 ist zu langsam schon bei 10 V Versorgungsspannung reicht das kaum für 16 MHz. Bei 5 V oder gar. 3.3 V schon gar nicht.

    An sich sollte das Ausgangssignal des Oszillators gut genug sein. Auch 0,6 V und 2,7 V als Signalpegel sollten die ICs bei 3.3 V Versorgung akzeptieren. Ein Problem könnte eventuell sein, wenn da kein Abblockkondensator am Oszillator ist Das könnte auch das geschliffene Signal erklären.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    09.11.2005
    Ort
    Ichtershausen
    Alter
    48
    Beiträge
    148
    Meinst du den Abblockkondensator in Reihe? oder gegen Masse?
    Ich überlege noch , ob ich es mal mit einem 74LVT14 probiere. der sollte sowohl von den Pegeln als auch von der Dynamik her besser geeinet zu sein als der CD40106. Da muss ich nur einen Lieferanten auftreiben.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •