-
        

Ergebnis 1 bis 4 von 4

Thema: Probleme mit Tricopter "Shrediquette"

  1. #1
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393

    Probleme mit Tricopter "Shrediquette"

    Anzeige

    Hallo,
    ich hoffe das Thema ist hier richtig,
    ich wollte nicht mehr den Thread von Willa zumüllen mit meinen Problemen.

    Es geht um den Shrediquette Tricopter von W. Thielicke.

    Ich habe in den letzten Wochen versucht einen tricopter zu bauen und bin zuerst recht gut voran gekommen. Nur jetzt stehe ich auf dem Schlauch:

    Zunächst einmal mein Setup:

    Steuerung: Triguide by W. Thielicke + I²C2PWM by W. Thielicke
    Motoren: TR 28-30B 14A 1050Kv
    Propeller: Maxxprod 10 14 2 Blatt
    ESC: Hobbyking SS Series 18-20A
    Batterie: Rhino 2150mAh 3S
    Servo: Turnigy MG90S Metal Gear Servo im Center mit Achse nach hinten
    Fernsteuerung: Futaba F14 40 Mhz mit 3-Wege Schalter + Empfänger

    Das Fehlerbild ist jetzt folgendes:
    Ich starte den Tricopter vom Boden und lasse ihn etwas umherschweben, in mehr oder weniger regelmäßigen Abständen zuckt der ganze Helicopter und plötzlich gibt einer der Motoren (nicht immer der selbe) Vollgas und der Tricopter stürzt natürlich ab.
    Zusätzlich ist mir aufgefallen, dass die LED der I²C Umsetzer ab und zu kurz ausgehen, kann das mit dem Zucken und dem Vollgas zu tun haben?

    Das zweite Problem ist, dass die Motren manchmal einfach abschalten und nach ein paar Sekunden wieder aangehen ohne, daß ich was auf der Funke mache. Die ESC bleiben eingeschaltet (kein Piepen zu hören)

    Als mögliche Fehlerquellen habe ich folgende auf dem Zettel:
    - Empfänger hat Störungen
    - Triguide Platine falsch gelötet
    - Wackelkontakt im IMU, Empänger, Triguide, I²C2PWM
    - ESC zu langsam

    Leider bin ich totaler Neuling auf diesem Gebiet, so fehlt es mir an Erfahrung bei der Fehlersuche.
    Habt ihr Tipps woran es liegen kann oder das gleiche Problem schonmal gehabt?
    Über Tipps zum richtigen Vorgehen wäre ich auch glücklich.
    Leider habe ich auch keine zweite Fernbedienung oder IMU um bestimmte Fehlerquellen auszuschließen.
    Wie findet man am besten kalte Lötstellen etc.
    Ich habe bei Youtube diverse Videos hochgeladen um das Verhalten zu dokumentieren.

    Danke für jede Hilfe!!!

    Nils

  2. #2
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    12.04.2008
    Alter
    32
    Beiträge
    563
    Moin,

    ich hab meine Kleine grad mal aus ihrer Schachtel geholt. Die LEDs auf den Konvertern gehen alle 2sek kurz aus. Das scheint also normal zu sein.

    Als erstes solltest du jetzt wie schon selbst geschrieben mal die Werte im Recievercheck überprüfen. Und das nicht nur für ein paar Sekunden sondern ruhig mal über ein paar Minuten laufen lassen. Dabei den Sender nicht betätigen um einfach mal zu sehen ob Spitzen in den Werten auftreten.

    Sollte sich dort nichts auffälliges zeigen würde ich als nächstes die Verkabelung und Platinen überprüfen. Ungewollte Lötbrücken (falls du Platinen ohne Stoplack hast), richtige Brücken bei den Konvertern für Rate und Motorwahl, kalte Lötstellen (meist matt, einfach nochmal mit dem Lötkolben ran), Wackelkontakte im Kabelstrang IMU-TriGuide.

    Sollte sich auch nach diesen Maßnahmen keine Besserung einstellen musst du wohl oder übel noch einmal Geld in die Hand nehmen und es mit anderen Reglern testen. Ich glaube im Original-Thread gab es mal den Kommentar eines anderen Piloten der mit ähnlichen Reglern ebenfalls Probleme hatte.

    Viel Erfolg

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von Willa
    Registriert seit
    26.10.2006
    Ort
    Bremen
    Alter
    37
    Beiträge
    1.269
    Hi,
    die i2c-konverter blinken kurz, wenn sie zwei sekunden lang kein I2C signal bekommen haben. d.h. nachdem der tricopter sich initialisiert hat dürfen die konverter-leds nicht mehr blinken. Dein Problem liegt mit 90% Wahrscheinlichkeit bei den Motorreglern und mit 9.9% beim Empfänger.
    Viele Grüße, William
    -> http://william.thielicke.org/

  4. #4
    Erfahrener Benutzer Roboter-Spezialist Avatar von jevermeister
    Registriert seit
    20.01.2011
    Ort
    Kiel
    Beiträge
    393
    Also ist dieses Kurze Blinken ein Problem oder nicht?
    Zwei sekunden sind in der Luft ne Menge Zeit...

    Wie ebreits im anderen Thread erwähnt wird jetzt nach und nach mit anderem Material geprüft,
    na aderer IMU, ne Andere Funke etc.

    Mal schauen was er Falsch gemacht hat,d er Nils...

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •