-         

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: TWI vernetzung zweier ATMega16

  1. #1
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22

    TWI vernetzung zweier ATMega16

    Anzeige

    Hallo zusammen,
    ich versuche nun schon seit guten 3 Tagen die Kommunikation zwischen zwei ATMEGA 16 hinzubekommen nur bekomme ich immer folgende fehler meldung beim Master:
    ../Master.c:16: undefined reference to `i2c_init'
    ../Master.c:19: undefined reference to `i2c_start'
    ../Master.c:21: undefined reference to `i2c_write'
    ../Master.c:22: undefined reference to `i2c_write'
    ../Master.c:23: undefined reference to `i2c_write'
    ../Master.c:24: undefined reference to `i2c_write'
    ../Master.c:25: undefined reference to `i2c_stop'
    ../Master.c:34: undefined reference to `i2c_start'
    ../Master.c:36: undefined reference to `i2c_write'
    ../Master.c:37: undefined reference to `i2c_rep_start'/../Master.c:39: undefined reference to `i2c_readAck'
    ../Master.c:40: undefined reference to `i2c_readAck'
    ../Master.c:41: undefined reference to `i2c_readNak'
    ../Master.c:42: undefined reference to `i2c_stop'

    und folgende bei slave:
    ../slave.c:22: undefined reference to `uart_puts'
    slave.o: In function `main':
    ../slave.c:38: undefined reference to `uart_init'
    ../slave.c:39: undefined reference to `uart_puts'
    ../slave.c:40: undefined reference to `uart_puts'
    ../slave.c:41: undefined reference to `uart_puts'
    ../slave.c:42: undefined reference to `uart_puts'
    ../slave.c:47: undefined reference to `uart_puts'
    slave.o:../slave.c:51: more undefined references to `uart_puts' follow

    Hier noch der Link zu den Beispielcode
    http://www.rn-wissen.de/index.php/TWI_Slave_mit_avr-gcc

  2. #2
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    22.06.2009
    Beiträge
    1.266
    Das sieht ganz danach aus, als ob du vergessen hast die Codefiles aus der Library mit hinzuzufügen. Mit welcher Programmierumgebung programmierst du denn ?

  3. #3
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22
    Ich Programmiere mit dem AVR Studio4
    im anhang mal die Dateien
    habe eigentlich die Codefiles hinzugefügt
    Angehängte Dateien Angehängte Dateien

  4. #4
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    22.06.2009
    Beiträge
    1.266
    Beim Slave fehlt aufjedenfall noch die uart.c und beim Master die i2cmaster.c
    Du musst neben den Definitionsfiles auch noch die Codefiles hinzufügen

  5. #5
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22
    Besten dank schonmal jetzt kommt nurnoch beim Master der Fehler:
    ../twimaster.c:12:23: error: i2cmaster.h: No such file or directory
    woran könnte das liegen?

    der Slave funzt soweit am PC

  6. #6
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    22.06.2009
    Beiträge
    1.266
    Der fehler sagt doch alles:
    No such file or directory
    Er findet die Datei nicht.

  7. #7
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22
    Aber die Datei ist in dem Ordner
    was kann ich da machen?

  8. #8
    Erfahrener Benutzer Roboter Genie
    Registriert seit
    22.06.2009
    Beiträge
    1.266
    Bist du dir auch sicher dass du die datei unter Header Files hinzugefügt hast ?

  9. #9
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22
    Ja hier ein Bild wo ich es in den Header Files drin habe
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken avr_170.jpg  

  10. #10
    Neuer Benutzer Öfters hier Avatar von Pinie
    Registriert seit
    10.12.2010
    Ort
    Ennepetal
    Beiträge
    22
    Hallo,
    ich wollte hier nochmal den Ordner Master hochladen vielleicht sieht jemand dann woran es liegen kann [-o<
    oder habe ich Irgendwo wieder was Falsch gemacht?
    Besten Dank schonmal
    und ein Schönen Abend noch
    Angehängte Dateien Angehängte Dateien

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •