-
        

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: schon wieder ein l297 problem

  1. #1
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2007
    Beiträge
    8

    schon wieder ein l297 problem

    Anzeige

    guten tag,
    nach langem fehlersuchen und foren durchstöbern habe ich keine antwort
    gefunden.

    ich habe eine l297/l298 steuerung zusammengebastelt.

    der schaltplan sieht wie folgt aus:
    http://www.rn-wissen.de/index.php/Bild:L298standard.gif
    mit dem unterschied, dass ich das ganze für 3 Schrittmotoren
    gleichzeitig gemacht habe (cnc steuerung).

    die motoren piepen ziemlich laut. (was schon mal komisch ist)

    die motoren werden im halbschritt betrieben und enable liegt immer auf
    high.

    mein problem ist nun die der stromsteuerung.
    es muss ja bei vref eine spannung von 0-3 volt anliegen. als rs1 und rs2
    habe ich 1 Ohm widerstände gewählt. die motoren laufen auch sehr schön.
    nur sobald ich mit dem strom höher gehe (vref 1,5v bis 3,0v) fangen die
    motoren richtig an zu vibrieren und leicht zu zucken und meine beiden 1
    ohm widerstände verabschieden sich mit einer rauchwolke....
    das ganze ist bei allen 3 kanälen gleich.

    als versorgung habe ich ein computernetzteil dh die motoren werden mit
    12 volt betrieben.

    motoren:
    http://www.cnc-spezialist.de/schritt...783e4640d35d40

    jemand ne idee woran das liegen könnte?

    vielen dank!

    mfg markus

  2. #2

  3. #3
    Erfahrener Benutzer Roboter Genie Avatar von BMS
    Registriert seit
    21.06.2006
    Ort
    TT,KA
    Alter
    26
    Beiträge
    1.192
    Hallo,
    sind die 1-Ohm-Widerstände diese kleinen 1/4-Watt-Widerstände im 4.Bild? Würde mal sagen, die sind unterdimensioniert.
    Wenn du den maximalen Strom (2A) ziehst, muss jeder Widerstand P=I²*R=(2A)²*1Ohm=4Watt verbraten. Das kann ein Viertel-Watt-Widerstand niemals leisten.
    Sonst: bleibt die Spannungsversorgung stabil? Kann das Schaltnetzteil genug Strom liefern?
    Grüße,
    Bernhard

  4. #4
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2007
    Beiträge
    8
    ja ich glaube auch dass ich da einfach größere nehmen muss. das netzteil liefert 25 A auf 12 volt und auf 5 volt 12 A also absolut ausreichend dimensioniert. die spannung bricht auch nicht ein.

  5. #5
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    15.12.2008
    Ort
    Bad Ems
    Alter
    55
    Beiträge
    109
    Hallo,

    also, die Sensing-Widerstände sind auf jeden Fall zu klein dimensioniert. Da die Preisunterschiede bei den Widerständen nicht so riesig sind, nehme ich in meinen Schaltungen immer 9W Widerstände. Die sind zwar überdimensioniert, aber sie brennen nicht durch, werden im Betrieb höchstens handwarm und ich bin auf der sicheren Seite.

    Deine Schaltung sieht ja so aus, wie die Standard-Schaltung aus dem Datenblatt. Ich vermisse da am Vref-Eingang den Spannungsteiler, mit dem festgelegt wird, wann der Chopper die Stromversorgung für die Motorspulen abschaltet. Wie erzeugst Du Vref?

    Wie Du schreibst, betreibst Du die Motoren mit 12 V. Das scheint mir deutlich zu wenig zu sein. Wenn Deine Schaltung mit dem L297 und L298 funktioniert, solltest Du die Motoren mit min. 36 V versorgen. Der Chopper sorgt dann dafür, dass der Stromfluss in den Motorspulen nicht zu hoch wird.

    Das Piepsen der Motoren sollte weniger werden, wenn Du Chopper-Frequenz an den drei L297 synchronisierst. Wie das funktioniert: Gucks Du: http://www.happy-micro.de/?p=666

    Ob das gut ist, dass Du Enable immer auf high hältst, musst Du selbst wissen. Ich würde es nicht machen. In dem Moment in dem Enable high wird, fließt Strom durch die Motorspulen. Das braucht man aber nicht immer. Manchmal steht die Maschine einfach still und muss auch nix halten. Wieso dann Strom fließen lassen? Du heizt damit ständig den L298 auf. Lass Ihn doch auch mal abkühlen.

    Frage ist auch, ob Du immer im Halbschritt-Betrieb arbeiten solltest. Wenn die Maschine nur positioniert, ohne Last, bist Du im Vollschritt-Betrieb schneller. Wenigstens landest Du dann nicht unbeabsichtigt im Wave-Drive-Mode (Verlust an Drehmoment).

    Vielleicht hilft das oben ein wenig, wenn nicht, frag nochmal nach. Dann würde mich aber auf jeden Fall Deine konkrete Schaltung interessieren.

    Gruß,
    Ralf
    http://www.Elektronik-Bastelkeller.de - Elektronik und Mikrocontroller als Hobby

  6. #6
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2007
    Beiträge
    8

    re

    hi,
    danke für die ausführliche antwort.
    habe mittlerweile 7 W widerstände drine und die schaltung funktioniert soweit!
    -> ja das ist die schaltung wie im datenblatt! vref stelle ich mittels poti ein.
    -> das problem hat aucht nichts mit der chopper frequenz zu tun. habe damit auch schon herumgespielt, hat aber nichts verändert.....
    -> mit der kühlwumme werden die l 298 nicht mal wirklich handwarm

    die schaltung funktioniert mittlerweile echt gut, auch wenn ich den strom hochdrehe.
    nur das piepen ist noch sehr extrem zu hören - es ist mehr ein kratzen, das im halbschritt stärker zu hören ist, es werden aber keine schritte zu viel oder zu wenig gemacht!

    ich glaube das hat was mit der induktivität der spulen zu tun........
    habe einen billigen Schrittmotor hingehängt, und nicht mal der kleinster piepton zu hören!!!

    die Schrittmotoren haben einen widerstand (die großen guten) von ca 3 Ohm pro phase.
    die billigen ca 70 Ohm.

    lg don

  7. #7
    Erfahrener Benutzer Fleißiges Mitglied
    Registriert seit
    15.12.2008
    Ort
    Bad Ems
    Alter
    55
    Beiträge
    109
    Hallo,

    nein, ich meinte auch nicht, dass es an der Chopper-Frequenz liegt, sondern daran, dass die Chopper der drei L297 nicht synchronisiert sind.

    Auszug aus dem Datenblatt:
    Ground noise problems in multiple configurations can be avoided by synchronising the chopper oscillators.
    This is done by connecting all the SYNC pins together, mounting the oscillator RC network on one device only and grounding the OSC pin on all other devices.
    Gruß,
    Ralf
    http://www.Elektronik-Bastelkeller.de - Elektronik und Mikrocontroller als Hobby

  8. #8
    Neuer Benutzer Öfters hier
    Registriert seit
    07.03.2007
    Beiträge
    8

    re

    die l297er habe ich schon ma synchronisiert, was aber leider nichts geholfen hatte......
    daran kann es auch nicht liegen.....


    lg

  9. #9
    Erfahrener Benutzer Roboter Genie Avatar von ManuelB
    Registriert seit
    15.06.2006
    Alter
    38
    Beiträge
    1.246
    Hallo,
    läuft die Stromregelung im slow oder fast Decay Modus? Fast verursacht oftmals schneller Geräusche als Slow Decay.
    Kann man über den Control Eingang ändern.

    MfG
    Manu

  10. #10
    Erfahrener Benutzer Begeisterter Techniker Avatar von Ostermann
    Registriert seit
    27.08.2009
    Ort
    Aachen
    Beiträge
    240
    Hallo zusammen!

    Zitat Zitat von Schachmann
    also, die Sensing-Widerstände sind auf jeden Fall zu klein dimensioniert. Da die Preisunterschiede bei den Widerständen nicht so riesig sind, nehme ich in meinen Schaltungen immer 9W Widerstände. Die sind zwar überdimensioniert, aber sie brennen nicht durch, werden im Betrieb höchstens handwarm und ich bin auf der sicheren Seite.
    Wobei die induktivitätsarm sein sollten, d.h. dicke Zementwiderstände sollte man eigentlich vermeiden.

    Ob das gut ist, dass Du Enable immer auf high hältst, musst Du selbst wissen. Ich würde es nicht machen. In dem Moment in dem Enable high wird, fließt Strom durch die Motorspulen. Das braucht man aber nicht immer. Manchmal steht die Maschine einfach still und muss auch nix halten. Wieso dann Strom fließen lassen? Du heizt damit ständig den L298 auf. Lass Ihn doch auch mal abkühlen.
    In dem Moment, wo man die Motoren ganz abschaltet, geht aber auch die Position verloren, was bei CNC-Anwendungen nicht unbedingt gewünscht ist Statt dessen kann man Vref auf ca. 50% absenken, wenn alle Achsen stehen. Wegen P=I²*R wird dann in den Motoren nur 1/4 der Leistung verbraten.

    Frage ist auch, ob Du immer im Halbschritt-Betrieb arbeiten solltest. Wenn die Maschine nur positioniert, ohne Last, bist Du im Vollschritt-Betrieb schneller.
    Nicht wenn man es richtig macht und in den Positionen, wo nur eine Wicklung bestromt wird, Vref anhebt. Im Vollschritt hat man dagegen deutlich schneller mit Resonanzen zu kämpfen.

    Mit freundlichen Grüßen
    Thorsten Ostermann
    --
    Wir bewegen Ihre Ideen!
    Intelligente Lösungen mit elektrischen Antrieben.
    http://www.mechapro.de

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •