-         

Ergebnis 1 bis 3 von 3

Thema: BTM222 Daten empfangen auf PC bisher nur Datenschrott

  1. #1
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.08.2006
    Ort
    Kitzscher
    Alter
    38
    Beiträge
    237

    BTM222 Daten empfangen auf PC bisher nur Datenschrott

    Anzeige

    SMARTPHONES & TABLETS-bis zu 77% RABATT-Kostenlose Lieferung-Aktuell | Cool | Unentbehrlich
    Hallo

    ich habe das Bluetooth Modul BTM222 und die fertige Leiteplatine von Ulrig Radig (http://shop.ulrichradig.de/Projekte/...chparam=btm222 ) aufgebaut und habe zum Senden einen ATMEGA32 in Betrieb genommen und diesen an die Com Schnittstelle des BTM222 angeschlossen.

    Am PC steckt ein USB Class 2 Bluetooth Stick. Mit diesem Stick habe ich dann die Bluetooth Verbindung aufgbebaut und den richtigen Com Port eingestellt.

    Gehe ich nun in das Hyperterminal wähle die Standart Bautrate von 19200 welche im ATMEGA eingestellt ist und im BTM222 so bekomme ich nur Datenschrott und nicht das was ich eigentlich empfangen möchte.

    An der BTM222 Firmware habe ich nichts verändert diese arbeitet mit den Standarteinstellungen ab Werk.


    Mein Programm im ATMEGA ist recht einfach gehalten :

    Code:
    $regfile = "m32def.dat"
    $crystal = 16000000
    $baud = 19200                                               ' use baud rate
    $hwstack = 32                                               ' default use 32 for the hardware stack
    $swstack = 10                                               ' default use 10 for the SW stack
    $framesize = 40                                             ' default use 40 for the frame space
    
    Config Com1 = Dummy , Synchrone = 0 , Parity = None , Stopbits = 1 , Databits = 8 , Clockpol = 0
    Dim A As Byte , S As String * 10
    S = "ABC"
    A = Asc(s)
    Print A                                                     'will print 65
    Ich empfange immer nur in HEX Code:
    E5 EB 93 95 93 95 E5 EB 93 95 93 95 E5
    oder in ASC Code ein "Quadrat" (Dec: 255)


    Entweder ich bin zu dumm zu begreifen mit welchen Format hier die Daten verschickt werden oder ich empfange die Strahlung der Mikrowelle vom Nachbarn

    Es wäre toll wenn mich jemand in die richtige Richtung der Fehlersuche leiten könnte. Ich habe die Platine jetzt schon das 2. Mal zusammengebaut und bei beiden ist es das gleiche Problem.

    Gruß
    Steffen


    PS.: Gerade habe ich diesen Beitrag entdeckt : http://www.roboternetz.de/phpBB2/zei...ghlight=btm222 wo es darum geht das die Antenne zu lang ist bzw. die Sendeleistung zu stark dem werde ich jetzt mal nachgehen da ich zum testen auch nur unter 1m Abstand zum Empfänger habe.

    Ergebniss Antenne gekürzt und es hat sich nichts verändert. Schade


    PSS.: Bautrate auf 2400 Baut runtergeschraubt und jetzt habe ich versucht vom ATMEGA32 ein "Hallo" zu schicken was im Terminal Programm ankommt ist das : "+::" (ohne die Anführungszeichen).

    Ich verstehe nicht was falsch ist. Das BTM222 läßt sich konfigurieren über UART aber beim senden kommt nur unsinn an ?!

  2. #2
    Erfahrener Benutzer Roboter Genie Avatar von Crazy Harry
    Registriert seit
    15.01.2006
    Ort
    Raum Augsburg - Ulm
    Beiträge
    1.192
    Die Baudrate des µC/BTM-Moduls und des BT-COM-Port hat nichts miteinander zu tun. Ich habe die BTM112 im Einsatz: der µC sendet mit 19200 und Hyperterm steht auf 57600 - nur so geht das bei mir. Wichtig ist nur, daß Hyperterm und die Einstellung des virtuellen COM-Ports gleich sind. Das BTM steht Standard auf 19200 (in/out). Ich verwende das Modul "so wie es ist" ohne die Konfiguration zu verändern.
    Ich programmiere mit AVRCo

  3. #3
    Erfahrener Benutzer Roboter-Spezialist
    Registriert seit
    19.08.2006
    Ort
    Kitzscher
    Alter
    38
    Beiträge
    237
    Oh das erstaunt mich jetzt damit hätte ich jetzt nicht gerechnet.
    Nirgendswo steht beschrieben das es mit 57600 sendet. Na da kann ich das Wochende weiter testen mal sehen ob es dann endlich funktionieren will.

    Vielen Dank Crazy Harry für den Tip

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •