-         

Ergebnis 1 bis 7 von 7

Thema: Wo liegt mein Fehler bei diesem Spannungsteiler ?

  1. #1

    Wo liegt mein Fehler bei diesem Spannungsteiler ?

    Anzeige

    Hallo,

    ich bin gerade damit beschäftigt meinen R/C 1:5er auf LiPo für die Empfängerstromversorgung umzustellen.

    Weil ich sowieso noch ein paar andere Feature (Licht, E-Start, Drehzahlwarner, ...) einbauen will, soll ein ATmega8 (oder 328, den habe ich noch hier) rein, der dann den 3s LiPo Akku Zellenweise überwacht.

    Wie bekannt, misst der ATmega ja alle Spannungen gegen GND, so dass ich einen Spannungsteiler ab der 2. Zelle des LiPo brauche.

    Nun kommt aber mein Problem:
    Ich habe einen Spannungsteiler so aufgebaut, wie auf dem Bild zu sehen.
    Mit dem Multimeter gemessen, geht die Sache etwa hin und ich habe max. 4,5 Volt (Toleranz der Widerstände sei dank) zwischen Masse und den ADCx.

    Wenn ich diese Konstruktion aber nun an den ATmega hänge, brutzelt das Gehäuse auf und es knallt kurz. --> Die Spannungen gehen dann bis auf 10 V an den ADC Eingängen hoch. (2 Mega 8 hat es gekostet.)

    Hat jemand eine Idee, woher dieser Fehler kommen kann ? Schließlich sind die ADC Eingänge des ATmega doch sehr hochohmig.

    Wenn ich mein Programm in einen intakten Mega 8 (32 lade und dann einzeln mit dem Labornetzteil Spannung an die ADC anlege, kann ich den Spannungswert am USART auslesen. Mein Programm ist also nicht der Fehler.

    Danke für eure Hilfe.

    Michael
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken lipo.png  

  2. #2
    Erfahrener Benutzer Roboter Experte Avatar von Tido
    Registriert seit
    14.11.2006
    Ort
    OWL
    Alter
    41
    Beiträge
    609
    Setz mal die waagerechten Widerstände auf die linke Seite des Verbindungspunktes. R8 und R10 müssen getauscht werden.
    MfG
    Tido

    ---------------------------------------------------
    Have you tried turning it off and on again???
    ---------------------------------------------------

  3. #3
    Erfahrener Benutzer Begeisterter Techniker
    Registriert seit
    11.08.2009
    Ort
    Süden
    Alter
    62
    Beiträge
    332
    Auf dem AC1 (unten) hast du keinen Spannungsteiler drin. Es kan also die Spannung des Akkus voll auf den Prz. gehen. Wenn der gerade NIderohmig ist fliesst der gesamte Stom des Battrie in den Prz. Wo soll der damit hin?

  4. #4
    Also so, wie auf dem Bild ?

    Wenn ich wirklich so dusselig war und mich beim Aufbau des Spannungsteilers so vertan habe ... Dann werde ich auch noch andere Sachen wie die FET - Schaltung für den Anlasser und das Licht nochmal genau durchtesten, bevor ich anfange eine Platine zu entwerfen ... Ich werde doch ganz schön alt.

    @Achim S.
    4,2 Volt bzw. max. 4,22 Volt bei voll geladenem Akku sollte der ADC Eingang doch abkönnen ?

    Ich stecke erst den Lastteil des Akku an, damit der Proz. und das BEC für die R/C Sachen Saft haben. Dann erst den Balancerstecker des Akkus an die Schaltung.

    Die Pins des Mega sind doch ungesteuert im Tri-State Zustand oder ?

    Michael
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken lipo_korr.png  

  5. #5
    Erfahrener Benutzer Robotik Visionär
    Registriert seit
    26.11.2005
    Ort
    bei Uelzen (Niedersachsen)
    Beiträge
    7.942
    So sieht die Schaltung schon einigermaßen aus. Der eine 42 K Widerstand ist überflüssig und nur eine extra Last für die eine Zelle.

    Ob der ADC Eingang die 4,2 V versträgt, hängt von der Spannungsversorgung ab. Wenn AVCC mehr als 3,8 V ist, sollte es gut gehen, bei weniger kann es schief gehen. Der AD Kanal für die eine Zelle direkt sollte als Schutz einen Serienwiderstand kriegen (z.B. 22 K) - dann sind die 4,2 V auch noch OK wenn AVCC auf 0 ist.

  6. #6
    Erfahrener Benutzer Roboter Experte
    Registriert seit
    15.11.2006
    Beiträge
    463
    Auch wenn der Spannungsteiler falsch ist, sollte eigentlich durch die interne Schutzdiode des AVRs und die Widerstände zwischen Akkuspannung und AVR nichts passieren, ausser dass die Schaltung keine richtigen Werte misst. Die Spannungsmessung der ersten Zelle (max 4.2 Volt) sollte eigentlich auch kein Problem sein. Da muss es also noch einen anderen Fehler geben.

    Die Pins des AVR sind nach dem Reset in Tristate, haben aber (mit Ausnahme von reset) integrierte Schutzdioden nach GND/VCC.

    Den R1 in dem korrigierten Spannungsteiler kannst du dir auch sparen, da dieser nur parallel zum Akku geschaltet ist und keine sinnvolle Funktion erfüllt.

  7. #7
    Erfahrener Benutzer Roboter Genie Avatar von Hessibaby
    Registriert seit
    20.11.2003
    Ort
    Gelsenkirchen
    Alter
    65
    Beiträge
    1.597
    Also, ich würde den Spannungsteiler so dimensionieren dass ich am ADC-Eingang ca. 2,5V habe ( also im mittleren Bereich ) d.h. bei Deiner Dimensionierung 1. Zelle 42k/42k 2.Zelle 42k/84k 3.Zelle 42k/126k , außerdem würde ich nur gleiche Widerstände nehmen und wertmäßig in Reihe schalten, das reduziert die Toleranzen.

    Planung ersetzt Zufall durch Irrtum

    Gruß aus dem Ruhrgebiet Hartmut

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •